summaryrefslogtreecommitdiff
path: root/media-gfx/word_cloud/word_cloud-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/word_cloud/word_cloud-1.8.0.ebuild')
-rw-r--r--media-gfx/word_cloud/word_cloud-1.8.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/word_cloud-1.8.0.ebuild b/media-gfx/word_cloud/word_cloud-1.8.0.ebuild
new file mode 100644
index 000000000000..9e8a918b2496
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.0-bundled-font.patch )