summaryrefslogtreecommitdiff
path: root/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch')
-rw-r--r--media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch b/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch
new file mode 100644
index 000000000000..f58c3e4d9c45
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch
@@ -0,0 +1,27 @@
+Fixed build with imagemagick-7 (bug #592324).
+Thanks-to: Jürgen Rose
+
+diff -r -U3 zbar-0.10_p20121015_orig/configure.ac zbar-0.10_p20121015/configure.ac
+--- zbar-0.10_p20121015_orig/configure.ac 2016-08-28 16:59:23.969753652 +0200
++++ zbar-0.10_p20121015/configure.ac 2016-08-28 17:17:15.384494517 +0200
+@@ -324,7 +324,7 @@
+ dnl double check ImageMagick install (bug #2582232)
+ CPPFLAGS_save="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
+- AC_CHECK_HEADER([wand/MagickWand.h],
++ AC_CHECK_HEADER([MagickWand/MagickWand.h],
+ [have_IM="yes"],
+ [have_IM="broken"])
+ CPPFLAGS="$CPPFLAGS_save"])])
+diff -r -U3 zbar-0.10_p20121015_orig/zbarimg/zbarimg.c zbar-0.10_p20121015/zbarimg/zbarimg.c
+--- zbar-0.10_p20121015_orig/zbarimg/zbarimg.c 2015-08-05 11:10:32.000000000 +0200
++++ zbar-0.10_p20121015/zbarimg/zbarimg.c 2016-08-28 17:10:39.532787196 +0200
+@@ -44,7 +44,7 @@
+ #endif
+
+ #ifdef HAVE_IMAGEMAGICK
+-# include <wand/MagickWand.h>
++# include <MagickWand/MagickWand.h>
+
+ /* ImageMagick frequently changes API names - just use the original
+ * (more stable?) names to match GraphicsMagick