summaryrefslogtreecommitdiff
path: root/media-gfx/zbar/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/zbar/files')
-rw-r--r--media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch27
-rw-r--r--media-gfx/zbar/files/zbar-0.23.1_fix_leftover_on_shell_compatibility.patch24
-rw-r--r--media-gfx/zbar/files/zbar-0.23.1_fix_unittest.patch78
3 files changed, 102 insertions, 27 deletions
diff --git a/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch b/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch
deleted file mode 100644
index f58c3e4d9c45..000000000000
--- a/media-gfx/zbar/files/zbar-0.10_p20121015-ImageMagick-7.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Fixed build with imagemagick-7 (bug #592324).
-Thanks-to: Jürgen Rose
-
-diff -r -U3 zbar-0.10_p20121015_orig/configure.ac zbar-0.10_p20121015/configure.ac
---- zbar-0.10_p20121015_orig/configure.ac 2016-08-28 16:59:23.969753652 +0200
-+++ zbar-0.10_p20121015/configure.ac 2016-08-28 17:17:15.384494517 +0200
-@@ -324,7 +324,7 @@
- dnl double check ImageMagick install (bug #2582232)
- CPPFLAGS_save="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
-- AC_CHECK_HEADER([wand/MagickWand.h],
-+ AC_CHECK_HEADER([MagickWand/MagickWand.h],
- [have_IM="yes"],
- [have_IM="broken"])
- CPPFLAGS="$CPPFLAGS_save"])])
-diff -r -U3 zbar-0.10_p20121015_orig/zbarimg/zbarimg.c zbar-0.10_p20121015/zbarimg/zbarimg.c
---- zbar-0.10_p20121015_orig/zbarimg/zbarimg.c 2015-08-05 11:10:32.000000000 +0200
-+++ zbar-0.10_p20121015/zbarimg/zbarimg.c 2016-08-28 17:10:39.532787196 +0200
-@@ -44,7 +44,7 @@
- #endif
-
- #ifdef HAVE_IMAGEMAGICK
--# include <wand/MagickWand.h>
-+# include <MagickWand/MagickWand.h>
-
- /* ImageMagick frequently changes API names - just use the original
- * (more stable?) names to match GraphicsMagick
diff --git a/media-gfx/zbar/files/zbar-0.23.1_fix_leftover_on_shell_compatibility.patch b/media-gfx/zbar/files/zbar-0.23.1_fix_leftover_on_shell_compatibility.patch
new file mode 100644
index 000000000000..62993a8b2b25
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.1_fix_leftover_on_shell_compatibility.patch
@@ -0,0 +1,24 @@
+From 8e74a2e223bd40e8cf95ac2580df56ac8500a859 Mon Sep 17 00:00:00 2001
+From: Boyuan Yang <byang@debian.org>
+Date: Wed, 22 Apr 2020 10:29:39 -0400
+Subject: [PATCH] configure.ac: Fix leftover on shell compatibility
+
+Uses "=" instead of "==" in string comparision for POSIX
+compatibility. This is a leftover of previous similar fix.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 105da09..df0220a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -845,7 +845,7 @@ dnl summary log
+ echo ""
+ echo "please verify that the detected configuration matches your expectations:"
+ echo "------------------------------------------------------------------------"
+-AS_IF([test "x$USE_NLS" == "xyes"],
++AS_IF([test "x$USE_NLS" = "xyes"],
+ [echo "gettext $USE_NLS"]
+ )
+ AS_IF([test "x$win32" != "xno"],
diff --git a/media-gfx/zbar/files/zbar-0.23.1_fix_unittest.patch b/media-gfx/zbar/files/zbar-0.23.1_fix_unittest.patch
new file mode 100644
index 000000000000..3f538c81138f
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.1_fix_unittest.patch
@@ -0,0 +1,78 @@
+diff -ur a/configure.ac b/configure.ac
+--- a/configure.ac 2020-04-21 00:09:21.000000000 +0300
++++ b/configure.ac 2020-04-23 16:53:06.654339488 +0300
+@@ -336,6 +336,14 @@
+ AC_SUBST(DBUS_CONFDIR)
+ ])
+
++dnl zbarimg tests
++AC_ARG_WITH([zbarimg_tests],
++ [AS_HELP_STRING([--without-zbarimg-tests],
++ [disable tests for zbarimg])],
++ [],
++ [with_zbarimg_tests="yes"])
++AM_CONDITIONAL([HAVE_ZBARIMG_TESTS], [test "x$with_zbarimg_tests" = "xyes"])
++
+ dnl libjpeg
+ AC_ARG_WITH([jpeg],
+ [AS_HELP_STRING([--without-jpeg],
+@@ -724,25 +732,12 @@
+
+ AC_ARG_VAR([CLASSPATH], [Java class path (include JUnit to run java tests)])
+ AS_IF([test "x$CLASSPATH" = "x"], [CLASSPATH="."])
++AC_SUBST(CLASSPATH)
+
+-dnl Search for Java unit test library
+-AS_IF([test -z "$JUNIT_HOME"],
+- [JUNIT_HOME="/usr/share/java"])
+-
+-AS_IF([test -f "$JUNIT_HOME/junit4.jar"],
+- [JUNIT="$JUNIT_HOME/junit4.jar"],
+- [AS_IF([test -f "$JUNIT_HOME/junit.jar"],
+- [JUNIT="$JUNIT_HOME/junit.jar"])])
+-
+-AS_IF([test "x$JUNIT" != "x"],
+- [AS_IF([test -f "/usr/share/java/hamcrest/all.jar"],
+- [CLASSPATH="$JUNIT:/usr/share/java/hamcrest/all.jar:$CLASSPATH"
+- AC_SUBST(CLASSPATH)
+- with_java_unit="yes"])],
+- [AS_IF([test -f "/usr/share/java/hamcrest-all.jar"],
+- [CLASSPATH="$JUNIT:/usr/share/java/hamcrest-all.jar:$CLASSPATH"
+- AC_SUBST(CLASSPATH)
+- with_java_unit="yes"])])
++AC_ARG_WITH([java_unit],
++ [AS_HELP_STRING([--without-java-unit],
++ [Enable java unittest])],
++ [with_java_unit="yes"])
+
+ AM_CONDITIONAL([HAVE_JAVA_UNIT], [test "x$with_java_unit" = "xyes"])
+
+@@ -905,6 +900,8 @@
+ [echo " => the Java interface will *NOT* be built"])
+ AS_IF([test "x$with_java_unit" != "xyes"],
+ [echo " => the Java unit test will *NOT* be enabled"])
++AS_IF([test "x$with_zbarimg_tests" != "xyes"],
++ [echo " => zbarimg tests will *NOT* be enabled"])
+ #echo "NPAPI Plugin --with-npapi=$with_npapi"
+ #AS_IF([test "x$with_mozilla" != "xyes"],
+ # [echo " => the Mozilla/Firefox/OpenOffice plugin will *NOT* be built"])
+diff -ur a/test/Makefile.am.inc b/test/Makefile.am.inc
+--- a/test/Makefile.am.inc 2020-04-21 00:09:21.000000000 +0300
++++ b/test/Makefile.am.inc 2020-04-23 17:03:07.819999370 +0300
+@@ -91,11 +91,16 @@
+ regress-decoder: test/test_decode
+ @abs_top_builddir@/test/test_decode -q -n 100000
+
++if HAVE_ZBARIMG_TESTS
+ check-images-py: zbarimg/zbarimg
+ @PYTHON@ @abs_top_srcdir@/test/barcodetest.py
+
+ check-images: zbarimg/zbarimg
+ @abs_top_builddir@/test/test_examples.sh
++else
++check-images-py:
++check-images:
++endif
+
+ check-convert: test/test_convert
+ @abs_top_srcdir@/test/test_convert