summaryrefslogtreecommitdiff
path: root/media-gfx
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/Manifest.gzbin37685 -> 37685 bytes
-rw-r--r--media-gfx/libredwg/Manifest2
-rw-r--r--media-gfx/libredwg/libredwg-0.13.2.ebuild114
-rw-r--r--media-gfx/plantuml/Manifest2
-rw-r--r--media-gfx/plantuml/plantuml-1.2022.7.ebuild33
5 files changed, 116 insertions, 35 deletions
diff --git a/media-gfx/Manifest.gz b/media-gfx/Manifest.gz
index f45f6d5e7051..f2716e59086e 100644
--- a/media-gfx/Manifest.gz
+++ b/media-gfx/Manifest.gz
Binary files differ
diff --git a/media-gfx/libredwg/Manifest b/media-gfx/libredwg/Manifest
index 615a20c32924..08c5cdf81c2a 100644
--- a/media-gfx/libredwg/Manifest
+++ b/media-gfx/libredwg/Manifest
@@ -1,4 +1,6 @@
+DIST libredwg-0.13.2.tar.gz 20627421 BLAKE2B 7d11c5f390a2e9d1afbe26b07a44e3b38a2734df39a0e499b55c59e873686625adf66a0a25de4509dee3fe285488e8d89e2e176e2aaa7c0a13c52abe6472b910 SHA512 ae93bf958c196cc54b8c05664e7201b82a3975845d544ae45cde437d716507ef1de08bf89615b5a67cf3841a014782af335031668ad59b34721a78648caaba67
DIST libredwg-0.13.tar.gz 20613784 BLAKE2B 26bab07b651b75b483b5211c77610a7d0af1f6adaca956a5766a6602c6c7e07fe0be3ec976a2119920c3d2df92c827cd9a9632563a91b4467159adb941ca39f7 SHA512 11585b4dcf83c2304e01010f68eb03da14c8d6affef944254a30067acb981d7f02507a932ad4509dfd65252e43d19c22966cc51945621764c4283daf0a1f0ab4
DIST libredwg-85695f3d5903b1cd5b4030efe50db3b4f5f3c928.tar.gz 12597 BLAKE2B cd01f6c446d5d129545fdae07c0101d133e1f4e69ee62e94c27c3c2853dcc30854f40aed0c6f38f6594c5f5eb9e7b2d18d3b2e4f487b7bf1a3f7f39facde38bc SHA512 1d08cfa6216e0fe671dab77a0bd0b4ef0c4eb174878eba909c680e0ee93a82079b3cbf60afe2de7b0078258de8bcc588961e59cf0c14fe5f2d1f70db639ef95a
+EBUILD libredwg-0.13.2.ebuild 2808 BLAKE2B d297fae57d55f3ac039d791870242af3692da80314f96e2388fbbde59ac7ca678b5ee5b5429ed8194aeeeabd11c7ceb8e05b1dfcc2db453c8f5245dd573b1b80 SHA512 fee4244e5d428c979b9efca95bb3b492c35d603a2f22fa0de5f5b5ea019aa34bb1142b96008207f124b301edd5cfda521cbcffa7f4b47c81e62f4f9eaf836d11
EBUILD libredwg-0.13.ebuild 2808 BLAKE2B d297fae57d55f3ac039d791870242af3692da80314f96e2388fbbde59ac7ca678b5ee5b5429ed8194aeeeabd11c7ceb8e05b1dfcc2db453c8f5245dd573b1b80 SHA512 fee4244e5d428c979b9efca95bb3b492c35d603a2f22fa0de5f5b5ea019aa34bb1142b96008207f124b301edd5cfda521cbcffa7f4b47c81e62f4f9eaf836d11
MISC metadata.xml 406 BLAKE2B c39713a8733c296d7b9c8d87210f1bec2bcebf415d2dcb6e6326fd6a89e9b84b44bffd781cd953de35894220b51277d39c3fd80ad8c9fe8f22cb29fdb920467c SHA512 a474d5abfc3db689b006dad09dc5ab003526141269d30e6acb7c241054be518a21f6a034ed9939a75098386cd01012d460bf70e0c12f0f14023ac48682c44e81
diff --git a/media-gfx/libredwg/libredwg-0.13.2.ebuild b/media-gfx/libredwg/libredwg-0.13.2.ebuild
new file mode 100644
index 000000000000..57215dfb3169
--- /dev/null
+++ b/media-gfx/libredwg/libredwg-0.13.2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="doxygen"
+# File is hardcoded to be run from ../ so we use this instead of DOCS_DIR
+DOCS_CONFIG_NAME="doc/Doxyfile"
+
+inherit autotools docs python-single-r1 perl-functions
+
+JSMN_COMMIT="85695f3d5903b1cd5b4030efe50db3b4f5f3c928"
+
+DESCRIPTION="C library to handle DWG files"
+HOMEPAGE="https://www.gnu.org/software/libredwg/ https://github.com/LibreDWG/libredwg"
+SRC_URI="
+ https://github.com/LibreDWG/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/zserge/jsmn/archive/${JSMN_COMMIT}.tar.gz -> ${PN}-${JSMN_COMMIT}.tar.gz
+"
+
+LICENSE="GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# https://github.com/LibreDWG/libredwg/issues/342
+RESTRICT="test"
+
+IUSE="debug python perl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ perl? ( dev-lang/perl )
+ dev-libs/libpcre2
+ dev-libs/pslib
+"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ perl? ( dev-lang/swig )
+"
+BDEPEND="|| (
+ sys-devel/gcc[sanitize]
+ sys-libs/compiler-rt-sanitizers[asan(-)]
+ )
+ dev-vcs/git
+"
+
+src_unpack() {
+ # Build system really wants jsmn to be here
+ default
+ rm -r "${S}/jsmn" || die
+ mv "${WORKDIR}/jsmn-${JSMN_COMMIT}" "${S}/jsmn" || die
+}
+
+src_prepare() {
+ default
+ # Fix variable references itself error, fails in src_install otherwise.
+ sed -i -e 's/TEXINPUTS="$(TEXINPUTS)$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/TEXINPUTS="$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/g' doc/Makefile.am || die
+ # https://github.com/LibreDWG/libredwg/issues/404
+ # Workaround: release tarball does not include dwg2ps.1.
+ # Upstream autotools stuff has to be run in git repo
+ git init -q || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -qm 'init' || die
+ git tag ${PV} || die
+ eautoreconf
+}
+
+src_configure() {
+ perl_set_version
+ local myconf=(
+ --enable-write
+ --enable-dxf
+ --enable-json
+ --disable-gcov
+ --disable-werror
+ $(use_enable !debug release)
+ $(use_enable debug trace)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(use_enable python python "${EPYTHON}")
+ $(usex perl "--with-perl-install=vendor" "--with-perl-install=no")
+ )
+
+ if use python || use perl; then
+ myconf+=( --enable-bindings )
+ else
+ myconf+=( --disable-bindings )
+ fi
+
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ perl_set_version
+ emake
+ docs_compile
+}
+
+src_install() {
+ perl_set_version
+ default
+ use python && python_optimize
+ # remove .la files if static-libs disabled
+ if ! use static-libs; then
+ rm "${ED}/usr/$(get_libdir)/libredwg.la" || die
+ if use python; then
+ rm "${D}/$(python_get_sitedir)/_LibreDWG.la" || die
+ fi
+ fi
+}
diff --git a/media-gfx/plantuml/Manifest b/media-gfx/plantuml/Manifest
index e298e52b9c68..af739e1206e5 100644
--- a/media-gfx/plantuml/Manifest
+++ b/media-gfx/plantuml/Manifest
@@ -1,7 +1,5 @@
-DIST plantuml-1.2022.7.tar.gz 5438055 BLAKE2B 864bc3ac35082cae6ec52d8668572f5c116e8185695ad81d85977ec417b4f789d60538cb3f7d8b54398d28994fc4e60a4eebd33f600795ec2d1ca516c6c96719 SHA512 8e84efdb73ad864f61fbde2ea260ff2712276e91093a25096c1cae27d1256eb6697a05c1e3f2829a7fe34f1d1ab7854703976ed796d493c928b35df689eda492
DIST plantuml-1.2023.13.tar.gz 11975624 BLAKE2B dc8792c1b47efe7d27fa4c870271da61d1efcae0554b036d81bc5e6ef27ae522683820d0979bef3f5114780585db4c79edd46199dbab871352fb5562ea2d3a91 SHA512 e0beff723887209971f42984759f04e07140e6e866e1bd9cb50b3e6eb3efbc39d3e1c10a48d7c07655562487e75563affdd616f4f0f50eb22bdf2574f0fa9f4a
DIST plantuml-1.2024.1.tar.gz 12021969 BLAKE2B a137c9abd235cf57d6c669e25258e6823633829d3f2b67b90f0489d86d4904578b0c798a052f35705acc933112fe20e85bba77f5f514a6e63e22660f7dbdbab5 SHA512 54c587ffe888d720565179b2392958951acd8012745bd0c5c2197a51e4d9eef736ddde7014c6a45817ee5f291c3151b824f5490fad397946e1fea4390c45dedd
-EBUILD plantuml-1.2022.7.ebuild 750 BLAKE2B fc8574f91fddc1a1c4643bcef80049a129bd3462c5d42a2eef297c5f7dfe45eca37b0db569a8c31899e4d296348710595ecbdc4ceb3e594b2ee9442e5b86565f SHA512 ec030e822f381dbf1b0fe822826afc3849ee56aeaada5429cf87192f0059d7f68f1ffb949a404f59c52f899e4d3b3d6b8959ef4f633c97c5661a90b4bfb6c77d
EBUILD plantuml-1.2023.13.ebuild 789 BLAKE2B 5e8987e5d28799f3901b6c5eb8d9b8683f6deb3a68c98c01a53dc215194ca44168516da088d4a965461a21b979e31ae6d8f450fdecabaf045bbbda7db9489ba1 SHA512 79d8846d8ff01d85a8f197f6db73af23786e9697ad4cf97368f99af3e676868799144633517274205e18510fbff9237e6c5af76368e4fb9f56b829280df58c65
EBUILD plantuml-1.2024.1.ebuild 793 BLAKE2B 7b7d7df1dbafb2df922d592e2206fde50a3f051d035ee1f05861da0bc4685d9bc22444bd010319c2e86f6aa2f18a5170f1f456a33990ea2a96c16946d015f09c SHA512 609949e761bd85e649ca0dec33886f1c87322db569eb30feb0f99b206c8bf988ce38169c8abe5e691974facfcb9c686c12afdd41a858cd9d585db5601f168f4b
MISC metadata.xml 879 BLAKE2B b711489e5c713d9b6ee8489e7ca080b9af19965e10ce3795e3dd16e3cabd0b9284bb1a75646baf2c0134cce31189a9e7dea499129750e20f4971f53aee66feaf SHA512 cfde5b9a2e44e38bc2eca2d7e32e6d4a18d0413325e41b0823091fdefcd15b035f32572397c27173887d370b2cca7673638ccf32690447dcab91ff31bc309c76
diff --git a/media-gfx/plantuml/plantuml-1.2022.7.ebuild b/media-gfx/plantuml/plantuml-1.2022.7.ebuild
deleted file mode 100644
index 8ba5d39fd289..000000000000
--- a/media-gfx/plantuml/plantuml-1.2022.7.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="source"
-inherit java-pkg-2 java-ant-2 desktop xdg
-
-DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
-HOMEPAGE="https://plantuml.com"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-DEPEND=">=virtual/jdk-1.8:*"
-
-RDEPEND="
- >=virtual/jre-1.8:*
- dev-java/ant-core:0
- media-gfx/graphviz"
-
-EANT_BUILD_TARGET="dist"
-EANT_GENTOO_CLASSPATH="ant-core"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-src_install() {
- java-pkg_dojar ${PN}.jar
- java-pkg_dolauncher ${PN} --jar ${PN}.jar
- use source && java-pkg_dosrc src/*
-
- make_desktop_entry plantuml PlantUML
-}