summaryrefslogtreecommitdiff
path: root/media-libs/bcg729/bcg729-999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/bcg729/bcg729-999999.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-999999.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/media-libs/bcg729/bcg729-999999.ebuild b/media-libs/bcg729/bcg729-999999.ebuild
index 4155676ac3c2..5263aff5d73a 100644
--- a/media-libs/bcg729/bcg729-999999.ebuild
+++ b/media-libs/bcg729/bcg729-999999.ebuild
@@ -1,33 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils git-r3
+
+inherit cmake git-r3
DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
EGIT_REPO_URI="https://github.com/BelledonneCommunications/bcg729"
+S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="static-libs"
-RDEPEND="
- !media-plugins/mediastreamer-bcg729
-"
-S=${WORKDIR}/${P/_/-}
+RDEPEND="!media-plugins/mediastreamer-bcg729"
+
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0_beta-cmake-build.patch
)
-src_configure() {
- mycmakeargs=(
- -DENABLE_STATIC=$(usex static-libs)
- )
- cmake-utils_src_configure
-}
-
src_install() {
- cmake-utils_src_install
+ cmake_src_install
find "${ED}" -name '*.la' -delete || die
}