summaryrefslogtreecommitdiff
path: root/media-libs/blib
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/blib')
-rw-r--r--media-libs/blib/Manifest2
-rw-r--r--media-libs/blib/blib-1.1.7-r4.ebuild63
-rw-r--r--media-libs/blib/files/blib-1.1.7-C23.patch105
3 files changed, 170 insertions, 0 deletions
diff --git a/media-libs/blib/Manifest b/media-libs/blib/Manifest
index ed2a660b7d01..c8af7c9236c1 100644
--- a/media-libs/blib/Manifest
+++ b/media-libs/blib/Manifest
@@ -1,4 +1,6 @@
+AUX blib-1.1.7-C23.patch 3303 BLAKE2B 0560814f9d4f1836c3a975cbd59e30d38c38e152574303223d4d0645878aa777ce479d319d3b7b3d910b24afd5c3fc5e1c8cb663fc17d08500c4b39b4b09fbb8 SHA512 41984f232797e5bd4b844ae01083b5bff98cc6c1900ab515188b540ffb3dab951e85cde374d8758cb774b17ee83268348abe229476bd47fbff5ecd58920d91d8
AUX blib-1.1.7-deprecated.patch 409 BLAKE2B 8fd46eae8511441442f1da04e38b27dc63f03f485bb8610667cb162e29fdba51996de58ec8046e227c48e90e2ef6785edaeb7dfbea55338f7b10639194d33ed9 SHA512 7b1e845db80ff2071d4e20ed40b5f5349978a9e8a5f68fa09ca51a69dc596e4752c838092fc24bf8226da95acb1f34477a3ff5d4ac2bb2844e83bd7cc6e229f3
DIST blib-1.1.7.tar.gz 570809 BLAKE2B 4b6c6738dd67a81b09ff0a280d3522d8cd41046b6eebe0ff4d6bf78df49fa3aa20382e0b02b3ee17c8c536fe34445a85a80433a39a87c2f0f650612fcd37914a SHA512 060fe2ff453c1dd073ff6105217618157da54416243b0f086a4f1324028b2fc222f6f732de1914d0e2e82df3565801b68d1ff49df4e6b89cd409bad73eb01ad6
EBUILD blib-1.1.7-r3.ebuild 1078 BLAKE2B 71275b3dafd020a5bb627c5148677871e8fe2be567dc063a3278bf4a3ffd22a6655cddd3f3e1b58f1a00926094086386606aedb12d01b9063e0194cd678a0293 SHA512 27161f6947681f4ade56d37d891367dbb8b51a90c501b1e3ae69b4b3d61f63c4df513127583468712d4a5593ea29b98464a2cf5959fa5bf08cf1bed68f8e293a
+EBUILD blib-1.1.7-r4.ebuild 1176 BLAKE2B 8d59d2e5ca2aa08c30d03b90c972cc445273488186c9dd8fb90522751ca1ac159d7f9b5f02e542577a8fda8888e0ae22b7e00b8ac3758b2fa2786975a4111e45 SHA512 cf176112a2f7253bd73a96febfab5104ab9a93f12fa69b0fcc2ca63c58a7a22fd523a6f6f070d85b6e1b3e39f95f75720443b84d3c464627ea5aa644ddc0af64
MISC metadata.xml 220 BLAKE2B 6f39345ea8474519439cc9768baf57bf07c0d8051eba252c30638ce35f30f8cbd1ecb06f7448893fa72ab9338630c83211fd366d66136b6ed090558fb376982c SHA512 3a2781821a74f9512a2b1fa55c8982a23f880b96b1707fdedf129d37685c2793eefe75a8080afe2bac64ed44d5f24648e6a25e163f87fe76a2b6be76b995647a
diff --git a/media-libs/blib/blib-1.1.7-r4.ebuild b/media-libs/blib/blib-1.1.7-r4.ebuild
new file mode 100644
index 000000000000..1c39f810fe2c
--- /dev/null
+++ b/media-libs/blib/blib-1.1.7-r4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library full of useful things to hack the Blinkenlights"
+HOMEPAGE="http://www.blinkenlights.de"
+SRC_URI="http://www.blinkenlights.de/dist/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aalib gtk"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ aalib? ( media-libs/aalib )
+ gtk? (
+ app-accessibility/at-spi2-core:2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/harfbuzz:=
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/pango
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-deprecated.patch
+ "${FILESDIR}"/${P}-C23.patch
+)
+
+src_prepare() {
+ default
+
+ # drop DEPRECATED flags, bug #391105
+ sed -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ -i {blib,gfx,{,test/}modules}/Makefile.{am,in} || die
+
+ #https://bugs.gentoo.org/899808
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable aalib aa)
+ --disable-directfb
+ $(use_enable gtk)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/media-libs/blib/files/blib-1.1.7-C23.patch b/media-libs/blib/files/blib-1.1.7-C23.patch
new file mode 100644
index 000000000000..662e1d20dc24
--- /dev/null
+++ b/media-libs/blib/files/blib-1.1.7-C23.patch
@@ -0,0 +1,105 @@
+https://bugs.gentoo.org/921126
+Fix for incompatible pointer types: Just upsize the size
+everywhere it's used, so it fits in largest, gsize
+diff -ru a/blib/bpacket.c a/blib/bpacket.c
+--- a/blib/bpacket.c 2025-01-09 18:10:29.298407575 +0400
++++ a/blib/bpacket.c 2025-01-09 18:13:09.318508466 +0400
+@@ -48,10 +48,10 @@
+ gint height,
+ gint channels,
+ gint maxval,
+- gint *data_size)
++ gsize *data_size)
+ {
+ BPacket *packet;
+- gint size;
++ gsize size;
+
+ g_return_val_if_fail (width > 0, NULL);
+ g_return_val_if_fail (height > 0, NULL);
+diff -ru a/blib/bpacket.h a/blib/bpacket.h
+--- a/blib/bpacket.h 2025-01-09 18:10:29.297407580 +0400
++++ a/blib/bpacket.h 2025-01-09 18:12:22.749770123 +0400
+@@ -42,7 +42,7 @@
+ gint height,
+ gint channels,
+ gint maxval,
+- gint *data_size);
++ gsize *data_size);
+ gsize b_packet_size (BPacket *packet);
+ void b_packet_hton (BPacket *packet);
+ void b_packet_ntoh (BPacket *packet);
+diff -ru a/blib/breceiver.c b/blib/breceiver.c
+--- a/blib/breceiver.c 2025-01-09 18:23:21.159070702 +0400
++++ b/blib/breceiver.c 2025-01-09 18:24:36.299648508 +0400
+@@ -354,7 +354,7 @@
+
+ case MAGIC_BLFRAME:
+ {
+- gint size;
++ gsize size;
+
+ fake = b_packet_new (18, 8, 1, 1, &size);
+
+Dealing with implicit declarations: autoreconf and #include "config.h"
+in places where they were not included previously
+diff -ru a/configure.in a/configure.in
+--- a/configure.in 2025-01-09 18:10:29.297407580 +0400
++++ a/configure.in 2025-01-09 18:15:55.400575296 +0400
+@@ -20,6 +20,8 @@
+ BLIB_API_VERSION=$BLIB_MAJOR_VERSION.$BLIB_MINOR_VERSION
+ BLIB_VERSION=$BLIB_MAJOR_VERSION.$BLIB_MINOR_VERSION.$BLIB_MICRO_VERSION
+
++AC_USE_SYSTEM_EXTENSIONS
++
+ AC_SUBST(BLIB_MAJOR_VERSION)
+ AC_SUBST(BLIB_MINOR_VERSION)
+ AC_SUBST(BLIB_MICRO_VERSION)
+diff -ru a/modules/bcountdown.c b/modules/bcountdown.c
+--- a/modules/bcountdown.c 2025-01-09 18:23:21.161070691 +0400
++++ b/modules/bcountdown.c 2025-01-09 18:25:27.179362628 +0400
+@@ -21,6 +21,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
++#include "config.h"
++
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/time.h>
+diff -ru a/modules/bdropout.c b/modules/bdropout.c
+--- a/modules/bdropout.c 2025-01-09 18:23:21.161070691 +0400
++++ b/modules/bdropout.c 2025-01-09 18:25:53.499214744 +0400
+@@ -18,6 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
++#include "config.h"
++
+ #include <stdlib.h>
+
+ #include <glib.h>
+diff -ru a/modules/bpushline.c b/modules/bpushline.c
+--- a/modules/bpushline.c 2025-01-09 18:23:21.161070691 +0400
++++ b/modules/bpushline.c 2025-01-09 18:23:30.867016155 +0400
+@@ -18,6 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
++#include "config.h"
++
+ #include <stdlib.h>
+
+ #include <glib.h>
+diff -ru a/modules/btetris.c b/modules/btetris.c
+--- a/modules/btetris.c 2025-01-09 18:23:21.161070691 +0400
++++ b/modules/btetris.c 2025-01-09 18:25:36.835308374 +0400
+@@ -18,6 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
++#include "config.h"
++
+ #include <string.h>
+ #include <stdlib.h>
+ #include <unistd.h>