summaryrefslogtreecommitdiff
path: root/media-libs/cogl
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/cogl')
-rw-r--r--media-libs/cogl/Manifest2
-rw-r--r--media-libs/cogl/cogl-1.22.4.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
index 48768eb33147..266ca4249c2f 100644
--- a/media-libs/cogl/Manifest
+++ b/media-libs/cogl/Manifest
@@ -1,3 +1,5 @@
DIST cogl-1.22.2.tar.xz 1682360 BLAKE2B f5a1543266bd87c6835322d5dbf501ec4f9fec52cc18d73d140323fef2f1b6b2293b5998bc8914b0a8cb514e7fefe5a1500793e1c7d8b5e0a4365fe8ef13233f SHA512 2ec99f5ff22683d12925b9a1f748387b47c4506aaf3c5afec851b3b6fe6b7cdfd211fb7e4359bd7a1d1b7cb3cb7fbd257efbcb7d2941d0f133a60bad1c9645e3
+DIST cogl-1.22.4.tar.xz 1723856 BLAKE2B 9e8532e3a0d17662042e2e61e45a7ddab6d3a35c7fbb070426b574292d7d3ed81e42a05cde9ab9a58ecda4eb6d560d0dca6c44b7791bba195e2ab2a33e8c0dc1 SHA512 85f3af49c16dd2e545a3b91c076ac10107a4b9d0dc785cefe489e91eabdd82837f732685f1f0dca1695fc2f8095f42d5f30f145b659eb4295964787f06c1e37a
EBUILD cogl-1.22.2.ebuild 3860 BLAKE2B b9d54bb15ad24bfea7d35239c1a047ca2b9c7bb323a2e920febe5e9c5c0715a277e7edd067d0401c945f86b455fa93160a5d99e2925a03d80766fee7fa6437ec SHA512 5322d779a49ed67efbadef97588e6b9a23a422f31efc9e5b90c1604605df09a2a2b8dccdb777ed091bb3a354ebdda280676e3142e96f7520fdf35ebda701bba8
+EBUILD cogl-1.22.4.ebuild 3862 BLAKE2B aec883f43490d01b4caebbe5158cd781a7da768b9b03b7bf83c63b0134f5cfd2cc38376b4a6d53066c858003cbf1436d6613eaa83112da69adaea1dbe8acd425 SHA512 250842d2b6a1c55155a30732285421c8987e2f1d915384217b1a17a48f48923041464919f33b552a0a453ac848c0188a1ccc298de0b14bb929a981ac2eee98bc
MISC metadata.xml 457 BLAKE2B 79c55fb3e5a1e5772c7b26cea5b54b15d683772204ec2ff2229481085130f4945b877a4608f01308a297571c01fa0da50220cd44b6a333eb34d2aae71c3a9157 SHA512 e0e4be51119ec98c906ca2f5df69c9024d77855fafa53ec00bc30b481f33dfd98708c2c9021737f84a46121788079fdc1d9ecffc2693a3257819f05879318a44
diff --git a/media-libs/cogl/cogl-1.22.4.ebuild b/media-libs/cogl/cogl-1.22.4.ebuild
new file mode 100644
index 000000000000..7061df2b3cde
--- /dev/null
+++ b/media-libs/cogl/cogl-1.22.4.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 multilib virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="https://www.cogl3d.org/"
+
+LICENSE="MIT BSD"
+SLOT="1.0/20" # subslot = .so version
+
+# doc and profile disable for now due to bugs #484750 and #483332
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
+REQUIRED_USE="
+ wayland? ( gles2 )
+ || ( gles2 opengl )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXrandr-1.2
+ virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.34.2:= )
+ kms? (
+ media-libs/mesa[gbm]
+ x11-libs/libdrm:= )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )
+ wayland? (
+ >=dev-libs/wayland-1.1.90
+ media-libs/mesa[egl,wayland] )
+"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.19
+ virtual/pkgconfig
+ test? (
+ app-eselect/eselect-opengl
+ media-libs/mesa[classic] )
+"
+
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+# For some reason GL3 conformance test all fails again...
+RESTRICT="test"
+
+src_prepare() {
+ # Do not build examples
+ sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+
+ if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: think about quartz, sdl
+ # Prefer gl over gles2 if both are selected
+ # Profiling needs uprof, which is not available in portage yet, bug #484750
+ # FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
+ gnome2_src_configure \
+ --disable-examples-install \
+ --disable-maintainer-flags \
+ --enable-cairo \
+ --enable-deprecated \
+ --enable-gdk-pixbuf \
+ --enable-glib \
+ $(use_enable debug) \
+ $(use_enable opengl glx) \
+ $(use_enable opengl gl) \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable gles2 xlib-egl-platform) \
+ $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
+ $(use_enable gstreamer cogl-gst) \
+ $(use_enable introspection) \
+ $(use_enable kms kms-egl-platform) \
+ $(use_enable pango cogl-pango) \
+ $(use_enable test unit-tests) \
+ $(use_enable wayland wayland-egl-platform) \
+ $(use_enable wayland wayland-egl-server) \
+ --disable-profile
+# $(use_enable profile)
+}
+
+src_test() {
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
+ ewarn "Skipping tests because a binary OpenGL library is enabled. To"
+ ewarn "run tests for ${PN}, you need to enable the Mesa library:"
+ ewarn "# eselect opengl set xorg-x11"
+ return
+ fi
+ virtx emake check LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa"
+}
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,*.jpg}
+ fi
+
+ gnome2_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}