summaryrefslogtreecommitdiff
path: root/media-libs/flac
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/flac')
-rw-r--r--media-libs/flac/Manifest2
-rw-r--r--media-libs/flac/flac-1.5.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/flac/Manifest b/media-libs/flac/Manifest
index baf718e9dbbe..ec533752a98e 100644
--- a/media-libs/flac/Manifest
+++ b/media-libs/flac/Manifest
@@ -1,3 +1,5 @@
DIST flac-1.4.3.tar.xz 1006728 BLAKE2B c4f441aeaa0493433347b8a110ca01865fd40d5b21150174372af2fee4fa5c3397a67add31138e92999eab9d9abe6c46a5ac29e13cbac60093fbff6d7a672ad3 SHA512 3cf095720bd590a588be8ccbe187d22e7a1c60ab85b1d510ce5e8a22ab0a51827b9acfeaad59bbd645a17d1f200f559255a640101b0330709a164306c0e9709e
+DIST flac-1.5.0.tar.xz 1078872 BLAKE2B 6b1c9a36db5daf24e2c21fa8429aa8776df5fd2fb430de8ee6728628a1ffc44f49c2bdedba514a24dea5ea87553e32dd08af4830870d64d77b3f776e4fe69644 SHA512 34c9193b804e990b0828a5759e4d7ef1d1859174262d3b305d03e65285edb35c7f429e8071d9dd2c6da0c16e842b40b439bf215704636ae15dd5886151f0d17a
EBUILD flac-1.4.3.ebuild 2118 BLAKE2B 7bb5bbf82ef6d9341565f373a078e58710ae5811328a9477851c118d616dfcdaaac4df283bfaf394bdc21b01bf922605702955bd7712008286be2a57869678f4 SHA512 06a04f7023f05a83086665d0e88d219f5644e8f909f9bc354ddc9b7c34e6f39cec98aeb1fd29a06ab2bf994ed380f962536bebadb563cafbce1b0c76e330b1e1
+EBUILD flac-1.5.0.ebuild 2125 BLAKE2B e8dfad436be0968a2e45a2ac5ac570df62aaff1092d2c6487c714f129d82a0ae130667d7a4ff761afdba3e7dd67176aed555f4894cf28b25ac445d8f7baa3cec SHA512 d517bc05897afc5635a63a1117884c7cd93f07b2d2357d061aeb19501794081dbb381b00da0ede120341db9896cb5363938d6335a77d2c0041d30850b72114db
MISC metadata.xml 377 BLAKE2B 9fa4c0dc0300b2d2deb791a29d7a2ce6b00e05399ccc29581bc4ab83b1bdff3fecd2edbe6cef3cf8b4111cae5064edf4ccec9205e6791fb57f41d363c6352e95 SHA512 9d9d3c80a5a7c0255476ddc86ebf2fc76e42fc278185e9d5c4c814ff395f6d7d74e9a3e680be2966e89113a76dd482e1fe53f761a59474cf46e8b2469849fc2e
diff --git a/media-libs/flac/flac-1.5.0.ebuild b/media-libs/flac/flac-1.5.0.ebuild
new file mode 100644
index 000000000000..95829c04c272
--- /dev/null
+++ b/media-libs/flac/flac-1.5.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool multilib-minimal
+
+DESCRIPTION="Free lossless audio encoder and decoder"
+HOMEPAGE="https://xiph.org/flac/"
+SRC_URI="https://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
+# <libFLAC SONAME>-<libFLAC++ SONAME>
+SLOT="0/11-14"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="+cxx debug ogg cpu_flags_x86_avx2 cpu_flags_x86_avx static-libs"
+# AVX configure switch is for both AVX & AVX2
+REQUIRED_USE="
+ cpu_flags_x86_avx2? ( cpu_flags_x86_avx )
+"
+
+RDEPEND="ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # -fipa-pta exposes a test failure in replaygain_analysis (https://gcc.gnu.org/PR115533)
+ # TODO: Replace with some -ffp-contract= option?
+ append-flags $(test-flags-CC -fno-ipa-pta)
+
+ local myeconfargs=(
+ --disable-doxygen-docs
+ --disable-examples
+ --disable-valgrind-testing
+ --disable-version-from-git
+ $([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
+
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cxx cpplibs)
+ $(use_enable debug)
+ $(use_enable ogg)
+ $(use_enable static-libs static)
+
+ $(multilib_native_enable programs)
+
+ # cross-compile fix (bug #521446)
+ # no effect if ogg support is disabled
+ --with-ogg
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ # configure has --enable-exhaustive-tests we could pass...
+ # there's also --disable-thorough-test.
+ if [[ ${UID} != 0 ]]; then
+ # Parallel tests work for CMake but don't for autotools as of 1.4.3
+ # https://github.com/xiph/flac/commit/aaffdcaa969c19aee9dc89be420eae470b55e405
+ emake -j1 check
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}