summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-base
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-base')
-rw-r--r--media-libs/gst-plugins-base/Manifest1
-rw-r--r--media-libs/gst-plugins-base/files/gst-plugins-base-1.20.6-libs_allocators.patch75
2 files changed, 0 insertions, 76 deletions
diff --git a/media-libs/gst-plugins-base/Manifest b/media-libs/gst-plugins-base/Manifest
index d70afb8e4475..93865d297520 100644
--- a/media-libs/gst-plugins-base/Manifest
+++ b/media-libs/gst-plugins-base/Manifest
@@ -1,4 +1,3 @@
-AUX gst-plugins-base-1.20.6-libs_allocators.patch 2382 BLAKE2B b332ff3ad81b99da5447193615eda91c532335d789d2244b1288a16cac2239bb3585f8c803efb3eabd318780717b8bce517954274a6dc65c395738eb2cddac00 SHA512 8e791c901884f7eb3dfb67c1d5ffdcd62997fc68dd950a53a0ad9f16544c99d6b46eb822710badbe81b41522340a219412d767dd945c38b60d5ec2a6d061c8a0
DIST gst-plugins-base-1.22.11.tar.xz 2373020 BLAKE2B 0809629afae7b82a12079dc40dd5a6a7c86876b591389c3179a74cea975b0ef3c66d9fc2f42a2f722892de2c75ef87eb0cfc5cc5df65f0ebefa02a891b0c392a SHA512 cfd8f7fe66f4707e043c8f070110eb80f9804cec529c8d29b13dbc8604db90e3f010c9614d538ad076b826df54f75ce5ebac355bd05a874e44dccead6a953c60
EBUILD gst-plugins-base-1.22.11.ebuild 5566 BLAKE2B 9959bb15251f63b488d4250d68345528b818fd9a291c0a53e641b32a55bd0d6c7e978cfd45f035bab946167c79971b987a7385705afddb6cbe06485e484baf93 SHA512 8e901d537e2cef251ae4168bd28f15061ad04fc2f7d94e6fe0cf38166874e14bdb521489e1c05cdfe0d2d6c3ed196acedc72394ab85c54c08020906ea1696f79
MISC metadata.xml 1013 BLAKE2B 97a1460e8774c2a5b51a2a19e0c770794439af5e661eb26e365f0eb4edc6887b7b7e02335f4d8ef9dee0dea84cfc5f6f550f0569d1ecbbf9c715d91f3b5fbd9b SHA512 9e69852f7dda892dd3e395a403d06319d7438db93c03e8c82e4584acc2493d7f91d79d6ad6c02149419a08b81ca08428ccbc8472cb4848d60428b5d29992d907
diff --git a/media-libs/gst-plugins-base/files/gst-plugins-base-1.20.6-libs_allocators.patch b/media-libs/gst-plugins-base/files/gst-plugins-base-1.20.6-libs_allocators.patch
deleted file mode 100644
index 44e4c1d388a7..000000000000
--- a/media-libs/gst-plugins-base/files/gst-plugins-base-1.20.6-libs_allocators.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-https://bugs.gentoo.org/907415
-https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/2487
-https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/2480
-https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/4422
-
-From a299399f5c93737bf963e34543578dba098b2f50 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
-Date: Mon, 10 Apr 2023 16:06:19 +0200
-Subject: [PATCH] tests: allocators: Fix fdmem test with recent GLib
-
-The test failed with recent GLib, where `g_close` emits a critical
-warning on EBADF. Remove the `g_close` check from `test_fdmem` and add
-another version that tests `GST_FD_MEMORY_FLAG_DONT_CLOSE`.
-
-We will depend on the Valgrind test run to warn us about leaked FDs.
-
-Fixes: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/2480
-Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/4422>
---- a/tests/check/libs/allocators.c
-+++ b/tests/check/libs/allocators.c
-@@ -95,7 +95,43 @@ GST_START_TEST (test_fdmem)
- gst_memory_unmap (mem, &info);
-
- gst_memory_unref (mem);
-- fail_unless (g_close (fd, NULL) == 0);
-+ gst_object_unref (alloc);
-+}
-+
-+GST_END_TEST;
-+
-+GST_START_TEST (test_fdmem_dont_close)
-+{
-+ GstAllocator *alloc;
-+ GstMemory *mem;
-+ GstMapInfo info;
-+ GError *error = NULL;
-+ int fd;
-+ const char *data = "0123456789";
-+
-+ fd = g_file_open_tmp (NULL, NULL, &error);
-+ fail_if (error);
-+ fail_unless (write (fd, data, 10) == 10);
-+
-+ alloc = gst_fd_allocator_new ();
-+ fail_unless (alloc);
-+ mem = gst_fd_allocator_alloc (alloc, fd, 10,
-+ GST_FD_MEMORY_FLAG_KEEP_MAPPED | GST_FD_MEMORY_FLAG_DONT_CLOSE);
-+
-+ fail_unless (gst_memory_map (mem, &info, GST_MAP_READ));
-+ fail_unless (info.data[5] == '5');
-+ gst_memory_unmap (mem, &info);
-+
-+ fail_unless (gst_memory_map (mem, &info, GST_MAP_WRITE));
-+ info.data[5] = 'X';
-+ gst_memory_unmap (mem, &info);
-+
-+ fail_unless (gst_memory_map (mem, &info, GST_MAP_READ));
-+ fail_unless (info.data[5] == 'X');
-+ gst_memory_unmap (mem, &info);
-+
-+ gst_memory_unref (mem);
-+ fail_unless (g_close (fd, NULL));
- gst_object_unref (alloc);
- }
-
-@@ -110,6 +146,7 @@ allocators_suite (void)
- suite_add_tcase (s, tc_chain);
- tcase_add_test (tc_chain, test_dmabuf);
- tcase_add_test (tc_chain, test_fdmem);
-+ tcase_add_test (tc_chain, test_fdmem_dont_close);
-
- return s;
- }
---
-GitLab