summaryrefslogtreecommitdiff
path: root/media-libs/libdvdread
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libdvdread')
-rw-r--r--media-libs/libdvdread/Manifest4
-rw-r--r--media-libs/libdvdread/libdvdread-6.0.0.ebuild44
-rw-r--r--media-libs/libdvdread/libdvdread-9999.ebuild34
3 files changed, 72 insertions, 10 deletions
diff --git a/media-libs/libdvdread/Manifest b/media-libs/libdvdread/Manifest
index ae5d201ac82f..fbba370f5b90 100644
--- a/media-libs/libdvdread/Manifest
+++ b/media-libs/libdvdread/Manifest
@@ -1,4 +1,6 @@
DIST libdvdread-5.0.3.tar.bz2 394885 BLAKE2B dc30548b8cdf30b9c114f4314fe0a2350b31e38321f662072e81492d126050eea8a601f12c03a8aa2c10c453f3ff84064fa4768cebe9395e4314cb2a29e872ca SHA512 1ca438f0b5c406549eec62e1abef1e8745b9f932bcd30a3194ee9e37995b269ec8f1652a24cc3d2cb11ddb964e4a47a06e5405f9402e616586ff6263a1af3fc2
+DIST libdvdread-6.0.0.tar.bz2 394627 BLAKE2B 08007113d726f96d2b179aadd2e5737ab9eeee2a52864eeaab3d2633993c66ca076559c920bd291033de794f2037d7480e4ad6f704822303f5c5b29db6b8d7cd SHA512 b07179f2f665adf6ddd7bf8b7c48cd279f3f413c5719b8ca8467e53c7cd0cac02a40101f3717186dc0e4e69e5d9c7ac6bf98a76901412d74150b9fc7bfdd2479
EBUILD libdvdread-5.0.3.ebuild 1008 BLAKE2B 4e629e1d24dda90ccedff708db1a54d73b435641c997b75805ca784ecc3d8bab106178bbbf9768196b61a962831d30c7b145bdace0bca7f87392059280f61da7 SHA512 557cf66d4d654fbf0f26f1917700209edf7a8ca67f83792224658c6c44559802f4d6da8f6cf67bcf520f9279fbb67542233575dfcf3575dd64a4a7a09bcc4c62
-EBUILD libdvdread-9999.ebuild 1017 BLAKE2B 6dfc7242a9fbeafeaad35fc868022e626dd3f674a4d7fff94672c9e24d7c531f619f423a95f7451bb2006ffc650dc05dae676a47ba2fd124ae9b650d9fd754e9 SHA512 79d7549e9467957bcd57997e531600c990da884d1e5fa468483847af1fac3b9c1a010e1f9feb64157664d205b645c674be0ea6ec2b2128d25b8db768f8156fb7
+EBUILD libdvdread-6.0.0.ebuild 1156 BLAKE2B ffdc1f7a0f7fd5e2a8e17e64a18f7a6df2f93cb305b5851251ee2c494dec221dc8e50e8d6d69b8a8e7be56b042d7ba36496b7f7c05bed189256bc309d0b02008 SHA512 193e1c2ece5c75ff5e326ee789fe493a5e42ccb8f8afa311edef85196e6dd32506d1443489e6ae5b26edc86d135aa662de84bdb609fc8249b8a068bbd6a7729f
+EBUILD libdvdread-9999.ebuild 1156 BLAKE2B ffdc1f7a0f7fd5e2a8e17e64a18f7a6df2f93cb305b5851251ee2c494dec221dc8e50e8d6d69b8a8e7be56b042d7ba36496b7f7c05bed189256bc309d0b02008 SHA512 193e1c2ece5c75ff5e326ee789fe493a5e42ccb8f8afa311edef85196e6dd32506d1443489e6ae5b26edc86d135aa662de84bdb609fc8249b8a068bbd6a7729f
MISC metadata.xml 221 BLAKE2B dbd3c4ca4e95a1ad33f79e707799593ad704252f4f1c17e08c7e42ede0e4ad153eb659fc130717823dad18cab485c7b941a7089d2d964b96d2e2f7c5f1ba8df2 SHA512 e5a88aac41d38b1bdf0becef8d0a08d1875eb803fac3f791524a7810c8068cfd2239a42717bddf9835daf6c0b2c5d5592b12669882bbc2abaab39955d7de7fb4
diff --git a/media-libs/libdvdread/libdvdread-6.0.0.ebuild b/media-libs/libdvdread/libdvdread-6.0.0.ebuild
new file mode 100644
index 000000000000..3a46c0663f6a
--- /dev/null
+++ b/media-libs/libdvdread/libdvdread-6.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="https://www.videolan.org/developers/libdvdnav.html"
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libdvdread.git"
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/libdvdread/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+css static-libs"
+
+RDEPEND="css? ( >=media-libs/libdvdcss-1.3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS TODO README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_with css libdvdcss)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/media-libs/libdvdread/libdvdread-9999.ebuild b/media-libs/libdvdread/libdvdread-9999.ebuild
index 8ca3b52a7401..3a46c0663f6a 100644
--- a/media-libs/libdvdread/libdvdread-9999.ebuild
+++ b/media-libs/libdvdread/libdvdread-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-inherit autotools-multilib
+EAPI=6
+
+inherit autotools multilib-minimal
DESCRIPTION="Library for DVD navigation tools"
HOMEPAGE="https://www.videolan.org/developers/libdvdnav.html"
@@ -20,9 +19,26 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="+css static-libs"
-RDEPEND="css? ( >=media-libs/libdvdcss-1.3.0[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r4
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
-DEPEND="${RDEPEND}"
+RDEPEND="css? ( >=media-libs/libdvdcss-1.3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
DOCS=( AUTHORS ChangeLog NEWS TODO README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_with css libdvdcss)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+}