summaryrefslogtreecommitdiff
path: root/media-libs/libsdl2
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/Manifest3
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild193
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.9.ebuild2
3 files changed, 196 insertions, 2 deletions
diff --git a/media-libs/libsdl2/Manifest b/media-libs/libsdl2/Manifest
index 852416583258..dcc920fba393 100644
--- a/media-libs/libsdl2/Manifest
+++ b/media-libs/libsdl2/Manifest
@@ -2,6 +2,7 @@ AUX libsdl2-2.0.10-static-libs.patch 2388 BLAKE2B 84d6a6fe3a2630ca899aa01c6d16bf
AUX libsdl2-2.0.6-static-libs.patch 2373 BLAKE2B 4632bf1c0d841d148acfbdf4c0fc25eb0eb3436478c1dddb4165c14d543793e2c378401f7b371976ffea38d6c3ceba4c4e4bfe415c0cfc4d07e62f2ec18dfc3f SHA512 c03037185a21ac3e2a664ab85847a0af95a44f579c2959fbc74d55ea8e59f7ed04775dcaea1fc2e284fca7ce6debca15a4062ba0e9bb0086f3dec49ba8044fb0
DIST SDL2-2.0.10.tar.gz 5550762 BLAKE2B b51eb0b256da683586889a648f62363935f5c70b31172999aa9b80bac9f3e761bc34a3fc379c02f5dbc50734cde53743d297ca7f79d30b0272ddf0313c8752af SHA512 f49b869362699b3282f6e82920e59c7fac581bcbf955f18a81cc126293c08093a90df7fcb39517cc8bc32708d2213fe645a42b655d6d811c1386efebb3d3c798
DIST SDL2-2.0.9.tar.gz 5246942 BLAKE2B 901ccb36301d7c9a76bb9f645ff3bc642ff101b969cfb0eff065db9de25a9ed3e80a0392b76dabf414e8f18298485304e45a9501786166709e31014e795bef03 SHA512 a78a4708b2bb5b35a7c7b7501eb3bd60a9aa3bb95a3d84e57763df4a377185e7312a94b66321eef7ca0d17255e4b402fc950e83ef0dbbd08f14ff1194107dc10
+EBUILD libsdl2-2.0.10-r1.ebuild 5438 BLAKE2B e2e140c772d53b7531eb1c8ac0f294afc8b3a279fcd81faf25f7ed3dbcda84ce2ed4d61a849dfc66d0cc878248219dee1b13aaae66ec28277c82f00c526d7743 SHA512 8608277808fe0fad47306221b7a2cd3e5b812318d2c703477af86e745bbf1015c69f03c32a2f3d98dbaf894a512077372aeeeddfdd5ef5edd8e0f53caee813cb
EBUILD libsdl2-2.0.10.ebuild 5317 BLAKE2B 514f47229ea5f5a45442b8b7ce0bb000e0abb7a79bc99f660d5eea07c2dd696475231ab8e8b103fe333f963e7d2115f2e881dcb95a43055520e2c8826069e016 SHA512 7b513bdbf4d03550503ce8ddaa7c4562045b13e8d539de49641d8d13572c58d16dd04e5ad8f25b3de95456ff055b342784fd73ba335909e99f8b39e837f86833
-EBUILD libsdl2-2.0.9.ebuild 5397 BLAKE2B 25db64fa1f24e9e6c097a3dead86ac350afa31712ed6c87bae67b4b30584dc96fbe65c4edca029dc0dcbea510259bcdb4896fbef577b5a951e4455da85bdf759 SHA512 76f69076eaa39510c84284cbedf19614c681eb0708bc98f324155211ca806927232bad73613fa06fd2a5569a503349872707fa5f83b1410f54ec10fc799b00ea
+EBUILD libsdl2-2.0.9.ebuild 5398 BLAKE2B eb8ed8622ad10513e4dee37004930e0d07f693a15ca39a3f2d00ef0349dcf8aaa3e1c0d93514f37ba996c2f5c0711f7e99f33019ba0c06f81b5ab5ee58ce6232 SHA512 b1a74ce26af362f629c1ce84c52a647f436d7c55650061f2e9006f66b58f757315e09e809b8708c51125ff0869b6f6c4a272d5a242d60972db3f16ff910d0090
MISC metadata.xml 1653 BLAKE2B 37ded083266a7086c89e02ecf5a79ea7c56c85ef50474d200035a96f425345c5882288c594c0d7ede0de4edc0f2b570fcaee60f98e64b45d152af1964486be38 SHA512 9af14f6cbf34ade124c668374929122f37badcbbeec765cda4a68a9475d6eb4e5159e71607d82aa2c664c6049d24077d1ab58f163858104a86367f3ef51a33b3
diff --git a/media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild b/media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..ba7791dcca78
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
+
+MY_P="SDL2-${PV}"
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="https://www.libsdl.org/"
+SRC_URI="https://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="alsa altivec aqua cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus gles haptic jack +joystick kms libsamplerate nas opengl oss pulseaudio +sound static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+REQUIRED_USE="
+ alsa? ( sound )
+ gles? ( video )
+ jack? ( sound )
+ nas? ( sound )
+ opengl? ( video )
+ pulseaudio? ( sound )
+ vulkan? ( video )
+ wayland? ( gles )
+ xinerama? ( X )
+ xscreensaver? ( X )"
+
+CDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ kms? (
+ >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.0.0[${MULTILIB_USEDEP},gbm]
+ )
+ libsamplerate? ( media-libs/libsamplerate[${MULTILIB_USEDEP}] )
+ nas? (
+ >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ )
+ opengl? (
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ tslib? ( >=x11-libs/tslib-1.0-r3[${MULTILIB_USEDEP}] )
+ udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},egl,gles2,wayland]
+ >=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXcursor-1.1.14[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
+ xinerama? ( >=x11-libs/libXinerama-1.1.3[${MULTILIB_USEDEP}] )
+ xscreensaver? ( >=x11-libs/libXScrnSaver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ )"
+RDEPEND="${CDEPEND}
+ vulkan? ( media-libs/vulkan-loader )"
+DEPEND="${CDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/SDL2/SDL_config.h
+ /usr/include/SDL2/SDL_platform.h
+ /usr/include/SDL2/begin_code.h
+ /usr/include/SDL2/close_code.h
+)
+
+PATCHES=(
+ # https://bugzilla.libsdl.org/show_bug.cgi?id=1431
+ "${FILESDIR}"/${PN}-2.0.10-static-libs.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Unbundle some headers.
+ rm -rv src/video/khronos || die
+ ln -s "${SYSROOT}${EPREFIX}"/usr/include src/video/khronos || die
+
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ # sorted by `./configure --help`
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --enable-atomic
+ $(use_enable sound audio)
+ $(use_enable video)
+ --enable-render
+ --enable-events
+ $(use_enable joystick)
+ $(use_enable haptic)
+ --enable-power
+ --enable-filesystem
+ $(use_enable threads)
+ --enable-timers
+ --enable-file
+ --enable-loadso
+ --enable-cpuinfo
+ --enable-assembly
+ $(use_enable cpu_flags_x86_sse ssemath)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_3dnow 3dnow)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable altivec)
+ $(use_enable oss)
+ $(use_enable alsa)
+ --disable-alsa-shared
+ $(use_enable jack)
+ --disable-jack-shared
+ --disable-esd
+ $(use_enable pulseaudio)
+ --disable-pulseaudio-shared
+ --disable-arts
+ $(use_enable libsamplerate)
+ $(use_enable nas)
+ --disable-nas-shared
+ --disable-sndio
+ --disable-sndio-shared
+ $(use_enable sound diskaudio)
+ $(use_enable sound dummyaudio)
+ $(use_enable wayland video-wayland)
+ --disable-wayland-shared
+ $(use_enable video_cards_vc4 video-rpi)
+ $(use_enable X video-x11)
+ --disable-x11-shared
+ $(use_enable X video-x11-xcursor)
+ $(use_enable X video-x11-xdbe)
+ $(use_enable xinerama video-x11-xinerama)
+ $(use_enable X video-x11-xinput)
+ $(use_enable X video-x11-xrandr)
+ $(use_enable xscreensaver video-x11-scrnsaver)
+ $(use_enable X video-x11-xshape)
+ $(use_enable X video-x11-vm)
+ $(use_enable aqua video-cocoa)
+ --disable-video-directfb
+ --disable-fusionsound
+ --disable-fusionsound-shared
+ $(use_enable kms video-kmsdrm)
+ --disable-kmsdrm-shared
+ $(use_enable video video-dummy)
+ $(use_enable opengl video-opengl)
+ --disable-video-opengles1
+ $(use_enable gles video-opengles2)
+ $(use_enable vulkan video-vulkan)
+ $(use_enable udev libudev)
+ $(use_enable dbus)
+ --disable-ibus
+ $(use_enable tslib input-tslib)
+ --disable-directx
+ --disable-rpath
+ --disable-render-d3d
+ $(use_with X x)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+ dodoc {BUGS,CREDITS,README,README-SDL,TODO,WhatsNew}.txt docs/README*.md
+}
diff --git a/media-libs/libsdl2/libsdl2-2.0.9.ebuild b/media-libs/libsdl2/libsdl2-2.0.9.ebuild
index 396d2a768982..d3e2d57715df 100644
--- a/media-libs/libsdl2/libsdl2-2.0.9.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.9.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://www.libsdl.org/release/${MY_P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 sparc x86"
IUSE="cpu_flags_x86_3dnow alsa altivec aqua custom-cflags dbus gles haptic libsamplerate +joystick kms cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
REQUIRED_USE="