summaryrefslogtreecommitdiff
path: root/media-libs/libsdl
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/Manifest2
-rw-r--r--media-libs/libsdl/libsdl-1.2.15_p20221201.ebuild166
2 files changed, 168 insertions, 0 deletions
diff --git a/media-libs/libsdl/Manifest b/media-libs/libsdl/Manifest
index 8cea9c028340..159f7492ec94 100644
--- a/media-libs/libsdl/Manifest
+++ b/media-libs/libsdl/Manifest
@@ -4,6 +4,8 @@ AUX libsdl-1.2.15-slibtool.patch 2288 BLAKE2B 5018f714eb40320eb0d310de1553638d66
AUX libsdl-1.2.15-strict-prototypes.patch 10377 BLAKE2B d0c029a3a4ecade9300d5ca4bb40a962fe0a89c1468ee9109e0552975153f8f9d8a5bf6c7a387af52513b75dc74cf53c6c727e1da372aedb85dd1ff69eb25249 SHA512 2c4c6b5aa8cdda8b49718457e25a7d86de3371be5589c061358a221d2c99fec1e8cb4b27e6850b4353f7ec36b1e226c4c553ed39927f30d8692481d5c21774e6
DIST SDL-1.2.15_p20210224.tar.gz 3991106 BLAKE2B be0906950c80cddf15bc458f7734a3ebfa767b11e2f54bf9f771155f4420947900b95bbbebf01341d9dba4c1c7cfe9d54e43150e5f7781622b99668b3362adeb SHA512 3521fe996cf8a8ebb9beaa4802ac05cf5f3a2e7ed1c9b362a818d965b26ec8b3bbebfaac7c827feae44becf5bdd764378cb4282d129285f23a982b5c7474e006
DIST SDL-1.2.15_p20221103.tar.gz 4002891 BLAKE2B 2329cec3579a2eb226ee7c8566f7f995b21b4f7fac3a0b40f237cf2d13576347a001dac96caf35d7da0fa95b4ee1684fbb9972a82e2691e4c83c1c0984b46029 SHA512 bd2cf4119dd9be99094d3379b15067817d4d40490d894e2338da9c365378d79edcfe2d7df03f57ac948f5fd1f949e5acb5b2233be484084a828c98af350f1830
+DIST SDL-1.2.15_p20221201.tar.gz 4002787 BLAKE2B 87b729cb16cfb36efa2b66166ef21d4c5c8bc99f8c8b4683885f04699122945a60512c5875d0c8425ddfe33b2eb901d11f27afbd9e3656cde3f30de5a5f1537c SHA512 5e70977cf5beaffebb28ae84f778e08d3cf56b2badda125ec1f08ac26c6b4e60a148d9ca9b2d7efee8a5fbc0b1a343d1d27a05be1c08e5d9251da67aea209659
EBUILD libsdl-1.2.15_p20210224.ebuild 5059 BLAKE2B 1dc2cdebb3c5053b32b575abb49193c0feeaf1007c7446bb5e1c023b267785cf92c0503793572b840de822ead7936bc3387b890b80370eca5e8b20fc2a83398b SHA512 f676a7866500b2ee49e7da7b7b0d922b51dd9ae2477f847961590a88211655394537f0ddac7fab0b3cf4b52973e192bc15788841f92459d53407392369eb47b2
EBUILD libsdl-1.2.15_p20221103.ebuild 4960 BLAKE2B 3464a6523798271f547da6a856910d75a123f5f200e36ffb04f4ca77b94d42c7739cd8c6e8e02be0b3a31c381ed485e43d250c2539a8e0ffeaa7dccecdccc5b4 SHA512 ed05b921ae942f7843bf970f9a7d082582eb742980cfdf25556847182ec7cd71bd006108b27e15d9575b4b66f9b04dae3252f76e153f21e221cb3297ee2f06a0
+EBUILD libsdl-1.2.15_p20221201.ebuild 4960 BLAKE2B e615d5e01dbb7018f406c0cd96b3bdb2f54431fc970ee26708d66f51089d9626222212afee18fb56ae0fb0345419abb1781a8403a83208c172174026543306e6 SHA512 b8482667853f2fe21d5365b796e7db929704f50bf6977fb14518137aacbcd9c97853d82c21dc8731a912e74d2a35bda7407d91ce65ca3ab1f4be25d941303659
MISC metadata.xml 1499 BLAKE2B 8dd0fbe5e6f71338330483fa433316564c420e0cb9f52297fcb6c34a452bae23e25963effd2caa43c099e11759eca3c65dff64b5957460271d27b188688887cc SHA512 be99021a150b521998a455243f68d89c980bf5610bb67d1475746d7b64b009baa83294c1b2ddc101f3c164e22765ce073b9e27c07ca5bbbe9eaa4f75dc4fd305
diff --git a/media-libs/libsdl/libsdl-1.2.15_p20221201.ebuild b/media-libs/libsdl/libsdl-1.2.15_p20221201.ebuild
new file mode 100644
index 000000000000..3a3700ce6d5b
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.15_p20221201.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal toolchain-funcs
+
+MY_COMMIT="ca3acd25348edc9b6e984fc1712fd4d365931dc1"
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="https://libsdl.org/"
+SRC_URI="https://github.com/libsdl-org/SDL-1.2/archive/${MY_COMMIT}.tar.gz -> SDL-${PV}.tar.gz"
+S="${WORKDIR}"/SDL-1.2-${MY_COMMIT}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+# WARNING:
+# If you turn on the custom-cflags use flag in USE and something breaks,
+# you pick up the pieces. Be prepared for bug reports to be marked INVALID.
+IUSE="aalib alsa custom-cflags dga fbcon +joystick libcaca nas opengl oss pulseaudio +sound static-libs tslib +video X xinerama xv"
+
+RDEPEND="
+ aalib? ( >=media-libs/aalib-1.4_rc5-r6[${MULTILIB_USEDEP}] )
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ libcaca? ( >=media-libs/libcaca-0.99_beta18-r1[${MULTILIB_USEDEP}] )
+ nas? (
+ >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ )
+ opengl? (
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ )
+ tslib? ( >=x11-libs/tslib-1.0-r3[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ sound? ( >=media-libs/audiofile-0.3.5[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ nas? ( x11-base/xorg-proto )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ pulseaudio? ( virtual/pkgconfig )
+ x86? (
+ || (
+ >=dev-lang/yasm-0.6.0
+ >=dev-lang/nasm-0.98.39-r3
+ )
+ )"
+
+pkg_setup() {
+ if use custom-cflags ; then
+ ewarn "Since you've chosen to use possibly unsafe CFLAGS,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the custom-cflags use flag in USE."
+ fi
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-$(ver_cut 1-3)-sdl-config.patch
+ "${FILESDIR}"/${PN}-$(ver_cut 1-3)-gamma.patch
+)
+
+DOCS=( BUGS CREDITS README-SDL.txt TODO WhatsNew )
+
+HTML_DOCS=( {docs,VisualC}.html docs/{html,images,index.html} )
+
+src_prepare() {
+ default
+
+ if $(tc-is-gcc) && [[ ${CHOST} == *-darwin* ]] ; then
+ # GCC at least has no idea what -fpascal-strings is
+ sed -i -e '/EXTRA_CFLAGS="$EXTRA_CFLAGS -fpascal-strings"/d' configure.ac || die
+ # We have trouble building against Frameworks with GCC for now (no Blocks support, etc)
+ # error: unknown type name ‘CGImageSourceAnimationBlock’
+ sed -i \
+ -e '/EXTRA_CFLAGS="$EXTRA_CFLAGS -DTARGET_API_MAC_CARBON"/d' \
+ -e '/EXTRA_CFLAGS="$EXTRA_CFLAGS -DTARGET_API_MAC_OSX"/d' \
+ configure.ac || die
+ fi
+
+ AT_M4DIR="${EPREFIX}/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=
+
+ if $(tc-is-gcc) && [[ ${CHOST} == *-darwin* ]] ; then
+ # We can't build against Cocoa because we lack Blocks + Objective C++ support in
+ # GCC (for now)
+ use video && myconf="${myconf} --disable-video-cocoa"
+ # CD support drags in audio
+ myconf="${myconf} --disable-cdrom"
+ else
+ myconf="${myconf} --enable-cdrom"
+ fi
+
+ if use !x86 && use !x86-linux ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} --enable-nasm"
+ fi
+ use custom-cflags || strip-flags
+ use sound || myconf="${myconf} --disable-audio"
+ use video \
+ && myconf="${myconf} --enable-video-dummy" \
+ || myconf="${myconf} --disable-video"
+ use joystick || myconf="${myconf} --disable-joystick"
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable prefix rpath) \
+ --disable-arts \
+ --disable-esd \
+ --enable-events \
+ --enable-threads \
+ --enable-timers \
+ --enable-file \
+ --enable-cpuinfo \
+ --disable-alsa-shared \
+ --disable-esd-shared \
+ --disable-sndio \
+ --disable-pulseaudio-shared \
+ --disable-arts-shared \
+ --disable-nas-shared \
+ --disable-osmesa-shared \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio) \
+ $(use_enable nas) \
+ $(use_enable X video-x11) \
+ $(use_enable dga) \
+ $(use_enable xv video-x11-xv) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable dga video-dga) \
+ $(use_enable fbcon video-fbcon) \
+ --disable-video-ggi \
+ --disable-video-svga \
+ $(use_enable aalib video-aalib) \
+ $(use_enable libcaca video-caca) \
+ $(use_enable opengl video-opengl) \
+ --disable-video-ps3 \
+ $(use_enable tslib input-tslib) \
+ $(use_with X x) \
+ $(use_enable static-libs static) \
+ --disable-video-x11-xme \
+ --disable-video-directfb \
+ ${myconf}
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -type f -name "*.la" -delete || die
+ einstalldocs
+}