summaryrefslogtreecommitdiff
path: root/media-libs/libxmp
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libxmp')
-rw-r--r--media-libs/libxmp/Manifest4
-rw-r--r--media-libs/libxmp/libxmp-4.6.1.ebuild28
-rw-r--r--media-libs/libxmp/libxmp-9999.ebuild4
3 files changed, 33 insertions, 3 deletions
diff --git a/media-libs/libxmp/Manifest b/media-libs/libxmp/Manifest
index 07f961056ba1..7693021ca57e 100644
--- a/media-libs/libxmp/Manifest
+++ b/media-libs/libxmp/Manifest
@@ -1,4 +1,6 @@
DIST libxmp-4.6.0.tar.gz 738532 BLAKE2B d383cb2e8c15c27e9f55954a4ae2ead6978b7e073e647ab667a2c0bb15848ff582626611b3f274ac5075bcdb7b5cfdc1a4f95d2ea76dc0ea64dab595ba8ca1b8 SHA512 d287544c9b569515f1a3fa92d8d930097b252e84f86cba5dd70e9b4460d0fa70754ece45dcc7ec314e434d821b43207d700afb12c9df80b467d73e9d029baafe
+DIST libxmp-4.6.1.tar.gz 798994 BLAKE2B 8bf853ee85b61c9bec46bd786f4741fcf2cff37a07cea4d8d6f60a66c09d6c9a6144e54786e8744942285d642ee7ab454290f06d0da946f2985d0c417752be26 SHA512 a772a489d8c1bedda378cd36f4f359bc224a1ac16ba12486b675667c76826d1308697f03e2d6502b654e4127eaaf3930684ee4367a73b75432273662af29111d
EBUILD libxmp-4.6.0.ebuild 647 BLAKE2B 0dd03920869d12453cf7e489923ea79fd83c5e567fd6400b5395ca57685122e562dbb6fec1052734769eeb2068dee2aa0b6cb534f197ef2acacde38814b37c7c SHA512 edceadf37a62563d7a43652081ebec381c83aabda3e38e3d0072a666edbe69eb95c97a0c3b9193f1f38eafa01ce5fcd8dd826317537bf92d8e65dba902aecac3
-EBUILD libxmp-9999.ebuild 588 BLAKE2B e41633e95546950e8783f1d1d9533cc2d0eb74b0438044cc21bf4cca7fdb5b9e0debba1bb5af32f45d77c3f631823e7af58557aedaf7b40fba39cf121742dd13 SHA512 20725513d17f020c3ebc28e616adb3f364df6fbfb3e947b9a3f13a047f2464834f4143a31d3d1ee75ff09a26e87e3c799ad7f5dc8643479777f72648b917c8a7
+EBUILD libxmp-4.6.1.ebuild 653 BLAKE2B d7657a9e16a6887e2a6d435d5a132509538c9f7b86e3ba350e5ed75c10b28f83d4136fef228eecec42e0ce0a6b7e5f506c4002957c6069b13451366193b10f4f SHA512 8f056c156419e2f73ce5e08ab16711f8998138f0a3fbf3e028a1983c24d9303049a348c40eaba85daa98943809427a7dd0b034b2cbf263ac9a532917eb00e60f
+EBUILD libxmp-9999.ebuild 602 BLAKE2B 5b41171b295bbcc012f7c8cdac6cdb2afa4ce6117da3ceba041e5b87eb3428473bdab496c43b1348716db3a0ea171d3dc06d794b0f715cc3f3efc7ffc46cc797 SHA512 4d72118768fde5a197626facec4a7cdbfd6770636457017c0bdc87ec378aaaf44cd7f65db12ecd3d8be95570c8a181287c08fb3b2b0a15dba43929c372188bcc
MISC metadata.xml 246 BLAKE2B 03221de27616f3f7500121e460112bd248eaee25473a1866f22ad14529545303feeac5f21cd63d996a70ef4575780fabd63f8663a54174f4df7871090f39644d SHA512 79fe8212db6969bff7497a619d4e8f6c3118b490a69eb31e73a70cc788beb03715d4a6d3bca8f1be2756137a13334e29ce90956b5498e7581c91899069bbb8e9
diff --git a/media-libs/libxmp/libxmp-4.6.1.ebuild b/media-libs/libxmp/libxmp-4.6.1.ebuild
new file mode 100644
index 000000000000..56b147867904
--- /dev/null
+++ b/media-libs/libxmp/libxmp-4.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library that renders module files to PCM data"
+HOMEPAGE="https://github.com/libxmp/libxmp"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
+else
+ SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+# bzip2 depacker code is 0BSD
+LICENSE="MIT 0BSD public-domain"
+SLOT="0"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_compile() {
+ emake V=1
+}
diff --git a/media-libs/libxmp/libxmp-9999.ebuild b/media-libs/libxmp/libxmp-9999.ebuild
index f6027f5b906c..1e3ce2b867a3 100644
--- a/media-libs/libxmp/libxmp-9999.ebuild
+++ b/media-libs/libxmp/libxmp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ else
fi
# bzip2 depacker code is 0BSD
-LICENSE="MIT 0BSD"
+LICENSE="MIT 0BSD public-domain"
SLOT="0"
src_prepare() {