summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 1da56517de7e..5c410fcd9811 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -43,6 +43,7 @@ REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
gles1? ( egl )
gles2? ( egl )
+ osmesa? ( gallium )
vulkan? ( dri3
video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
@@ -116,7 +117,6 @@ RDEPEND="
X? (
>=x11-libs/libX11-1.6.2:=[${MULTILIB_USEDEP}]
>=x11-libs/libxshmfence-1.1:=[${MULTILIB_USEDEP}]
- >=x11-libs/libXdamage-1.1.4-r1:=[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2:=[${MULTILIB_USEDEP}]
>=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
>=x11-libs/libxcb-1.13:=[${MULTILIB_USEDEP}]
@@ -317,6 +317,10 @@ pkg_pretend() {
if ! use llvm; then
use opencl && ewarn "Ignoring USE=opencl since USE does not contain llvm"
fi
+
+ if use osmesa && ! use llvm; then
+ ewarn "OSMesa will be slow without enabling USE=llvm"
+ fi
}
python_check_deps() {
@@ -347,6 +351,8 @@ multilib_src_configure() {
local emesonargs=()
if use classic; then
+ dri_driver_enable !gallium swrast
+
# Intel code
dri_driver_enable video_cards_i915 i915
dri_driver_enable video_cards_i965 i965
@@ -372,6 +378,12 @@ multilib_src_configure() {
use wayland && platforms+=",wayland"
[[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ if use X || use egl; then
+ emesonargs+=(-Dglvnd=true)
+ else
+ emesonargs+=(-Dglvnd=false)
+ fi
+
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -432,6 +444,7 @@ multilib_src_configure() {
gallium_enable -- kmsro
fi
+ gallium_enable -- swrast
gallium_enable video_cards_lima lima
gallium_enable video_cards_panfrost panfrost
gallium_enable video_cards_v3d v3d
@@ -476,14 +489,6 @@ multilib_src_configure() {
vulkan_enable video_cards_v3d broadcom
fi
- if use gallium; then
- gallium_enable -- swrast
- emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )
- else
- dri_driver_enable -- swrast
- emesonargs+=( -Dosmesa=$(usex osmesa classic none) )
- fi
-
driver_list() {
local drivers="$(sort -u <<< "${1// /$'\n'}")"
echo "${drivers//$'\n'/,}"
@@ -492,13 +497,13 @@ multilib_src_configure() {
emesonargs+=(
$(meson_use test build-tests)
-Dglx=$(usex X dri disabled)
- -Dglvnd=true
- -Dshared-glapi=true
+ -Dshared-glapi=enabled
$(meson_feature dri3)
$(meson_feature egl)
$(meson_feature gbm)
$(meson_feature gles1)
$(meson_feature gles2)
+ $(meson_use osmesa)
$(meson_use selinux)
$(meson_feature zstd)
-Dvalgrind=$(usex valgrind auto false)