summaryrefslogtreecommitdiff
path: root/media-libs/mlt/mlt-6.16.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mlt/mlt-6.16.0-r1.ebuild')
-rw-r--r--media-libs/mlt/mlt-6.16.0-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/media-libs/mlt/mlt-6.16.0-r1.ebuild b/media-libs/mlt/mlt-6.16.0-r1.ebuild
index 76fc970c2228..dc4435ed3601 100644
--- a/media-libs/mlt/mlt-6.16.0-r1.ebuild
+++ b/media-libs/mlt/mlt-6.16.0-r1.ebuild
@@ -209,17 +209,16 @@ src_install() {
if use python; then
cd "${S}"/src/swig/python || die
- insinto $(python_get_sitedir)
- doins mlt.py
- exeinto $(python_get_sitedir)
- doexe _mlt.so
+ python_domodule mlt.py _mlt.so
+ chmod +x "${D}$(python_get_sitedir)/_mlt.so" || die
dodoc play.py
python_optimize
fi
if use ruby; then
cd "${S}"/src/swig/ruby || die
- exeinto $("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ local rubydir=$("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ exeinto "${rubydir#${EPREFIX}}"
doexe mlt.so
dodoc play.rb thumbs.rb
fi