summaryrefslogtreecommitdiff
path: root/media-libs/openctm/openctm-1.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openctm/openctm-1.0.3-r1.ebuild')
-rw-r--r--media-libs/openctm/openctm-1.0.3-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-libs/openctm/openctm-1.0.3-r1.ebuild b/media-libs/openctm/openctm-1.0.3-r1.ebuild
index 60585930f8ea..e4014df8c998 100644
--- a/media-libs/openctm/openctm-1.0.3-r1.ebuild
+++ b/media-libs/openctm/openctm-1.0.3-r1.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils multilib flag-o-matic toolchain-funcs
+inherit edos2unix flag-o-matic toolchain-funcs
MY_P=OpenCTM-${PV}
DESCRIPTION="OpenCTM - the Open Compressed Triangle Mesh."
HOMEPAGE="http://openctm.sourceforge.net"
SRC_URI="https://downloads.sourceforge.net/project/openctm/${MY_P}/${MY_P}-src.tar.bz2 -> ${P}-src.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0/1"
@@ -18,17 +19,16 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
dev-libs/tinyxml
+ media-libs/freeglut
media-libs/glew:0=
media-libs/pnglite
sys-libs/zlib
virtual/jpeg:0
- media-libs/freeglut
virtual/opengl
- x11-libs/gtk+:2"
+ x11-libs/gtk+:2
+"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}/${P}-escape-hyphens-in-ctmconv-man-page.patch"
"${FILESDIR}/${P}-link-ctmviewer-with-libGLU.patch"
@@ -53,5 +53,5 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${ED}" LIBDIR="${ED}/usr/$(get_libdir)" -f Makefile.linux install
+ emake DESTDIR="${ED}" LIBDIR="${ED}/usr/$(get_libdir)" -f Makefile.linux install
}