summaryrefslogtreecommitdiff
path: root/media-libs/opencv/files/opencv_contrib-4.8.1-rgbd.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opencv/files/opencv_contrib-4.8.1-rgbd.patch')
-rw-r--r--media-libs/opencv/files/opencv_contrib-4.8.1-rgbd.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/media-libs/opencv/files/opencv_contrib-4.8.1-rgbd.patch b/media-libs/opencv/files/opencv_contrib-4.8.1-rgbd.patch
new file mode 100644
index 000000000000..0e1f12d6df46
--- /dev/null
+++ b/media-libs/opencv/files/opencv_contrib-4.8.1-rgbd.patch
@@ -0,0 +1,15 @@
+From: Paul Zander <negril.nx+gentoo@gmail.com>
+
+Fixes compilation when using GLVND.
+
+diff --git a/modules/rgbd/CMakeLists.txt b/modules/rgbd/CMakeLists.txt
+index 79e1562..eaebc3a 100644
+--- a/modules/rgbd/CMakeLists.txt
++++ b/modules/rgbd/CMakeLists.txt
+@@ -7,5 +7,5 @@ if(NOT HAVE_EIGEN)
+ endif()
+
+ if(HAVE_OPENGL)
+- ocv_target_link_libraries(${the_module} PRIVATE "${OPENGL_LIBRARIES}")
++ ocv_target_link_libraries(${the_module} PRIVATE "${OPENGL_LIBRARIES}" GL)
+ endif()