summaryrefslogtreecommitdiff
path: root/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opensubdiv/opensubdiv-3.3.0.ebuild')
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
deleted file mode 100644
index fc3580b365e6..000000000000
--- a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils toolchain-funcs versionator
-
-MY_PV="$(replace_all_version_separators '_')"
-DESCRIPTION="An Open-Source subdivision surface library"
-HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
-SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="cuda doc opencl openmp ptex tbb"
-
-RDEPEND="media-libs/glew:=
- media-libs/glfw:=
- cuda? ( dev-util/nvidia-cuda-toolkit:* )
- opencl? ( virtual/opencl )
- ptex? ( media-libs/ptex )"
-
-DEPEND="${RDEPEND}
- tbb? ( dev-cpp/tbb )
- doc? (
- dev-python/docutils
- app-doc/doxygen
- )"
-
-S="${WORKDIR}/OpenSubdiv-${MY_PV}"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-quotes.patch"
- "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
- "${FILESDIR}/${P}-add-CUDA9-compatibility.patch"
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- local mycmakeargs=(
- -DNO_CLEW=1
- -DNO_DOC=$(usex !doc)
- -DNO_TBB=$(usex !tbb)
- -DNO_PTEX=$(usex !ptex)
- -DNO_OMP=$(usex !openmp)
- -DNO_OPENCL=$(usex !opencl)
- -DNO_CUDA=$(usex !cuda)
- -DNO_REGRESSION=1 # They don't work with certain settings
- -DNO_EXAMPLES=1 # Not needed.
- -DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
- -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- )
-
- cmake-utils_src_configure
-}