summaryrefslogtreecommitdiff
path: root/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild')
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
new file mode 100644
index 000000000000..336f6354c109
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="-* ~arm"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}/firmware-${PV}"
+
+RESTRICT="binchecks"
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ insopts -m 0755
+ insinto "/opt/vc/lib"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}