summaryrefslogtreecommitdiff
path: root/media-libs/rlottie/rlottie-0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/rlottie/rlottie-0.1-r1.ebuild')
-rw-r--r--media-libs/rlottie/rlottie-0.1-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/media-libs/rlottie/rlottie-0.1-r1.ebuild b/media-libs/rlottie/rlottie-0.1-r1.ebuild
deleted file mode 100644
index c3825364a0c3..000000000000
--- a/media-libs/rlottie/rlottie-0.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
-HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
-SRC_URI="https://github.com/Samsung/rlottie/archive/v${PV}.tar.gz -> ${P}-1.tar.gz"
-
-LICENSE="BSD FTL JSON LGPL-2.1 MIT"
-SLOT="0/0.0.1"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="debug examples test"
-
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-PATCHES=( "${FILESDIR}"/${P}-disable-werror.patch )
-
-src_configure() {
- local emesonargs=(
- -D cache=true
- -D module=true
- -D thread=true
-
- -D cmake=false
- -D example=false
-
- $(meson_use debug dumptree)
- $(meson_use debug log)
- $(meson_use test)
- )
-
- meson_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
- eninja test
-}