summaryrefslogtreecommitdiff
path: root/media-libs/sdl3-ttf
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl3-ttf')
-rw-r--r--media-libs/sdl3-ttf/Manifest3
-rw-r--r--media-libs/sdl3-ttf/metadata.xml23
-rw-r--r--media-libs/sdl3-ttf/sdl3-ttf-3.2.2.ebuild45
3 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/sdl3-ttf/Manifest b/media-libs/sdl3-ttf/Manifest
new file mode 100644
index 000000000000..61ae9d6adeb1
--- /dev/null
+++ b/media-libs/sdl3-ttf/Manifest
@@ -0,0 +1,3 @@
+DIST sdl3-ttf-3.2.2.tar.gz 1572749 BLAKE2B 04ce84ad0d19375b6f1e4ccaeb54e0c74f732a59adb64b1c45b27bb36ffeb898686bddcb3208b6dd35dbe1950b207d01d7799fae88501261928b64cee369cc70 SHA512 b9adc28d584759b1cc1072d071caad95ade263a1fb24e294d66fc15e132d44bc62925875cb1f1b596089def9b47d7b73f42ffa4e120ee51982f993dc7a7d3bd7
+EBUILD sdl3-ttf-3.2.2.ebuild 1217 BLAKE2B aa28df04d49c5bae9f85fa2961920d8e9897b697290df2e81f56171e9a2238f3649055f05d0e6edb72856ac0729d3cb660656b413c421406976ab8741a9045b5 SHA512 335243a0600405bbeb4425a980502937fb772741afd30b2bd30d832f9c3d8d0b6d540ed0c5cbce3037c806aecb387794ce49ce07d929386c6766ff6531b6e77a
+MISC metadata.xml 825 BLAKE2B 3ca765cd60bc9f8ccce719281a4c214f10e6cd128660c0833ce5f3b822c8d6eb765095f48fc6eb725deec6b015984cead047b0d2bb31b162e5380daddcee3a6a SHA512 092e51c907074a7d902da8854192f2d2e4f9d2e4cedd2c5c0a4a43874bd2a1b39563d2632c7816758b3b665986fdd88bfe56287c13c93ebbb0b4710ac29ff5c5
diff --git a/media-libs/sdl3-ttf/metadata.xml b/media-libs/sdl3-ttf/metadata.xml
new file mode 100644
index 000000000000..db4ceaabdfeb
--- /dev/null
+++ b/media-libs/sdl3-ttf/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>kangie@gentoo.org</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <longdescription>
+ This library is a wrapper around the FreeType and Harfbuzz libraries,
+ allowing you to use TrueType fonts to render text in SDL applications.
+ </longdescription>
+ <use>
+ <flag name="harfbuzz">Use <pkg>media-libs/harfbuzz</pkg> for enhanced font rendering</flag>
+ <flag name="plutosvg">Use <pkg>media-libs/plutosvg</pkg> for colour emoji support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">libsdl-org/SDL_ttf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/sdl3-ttf/sdl3-ttf-3.2.2.ebuild b/media-libs/sdl3-ttf/sdl3-ttf-3.2.2.ebuild
new file mode 100644
index 000000000000..a90b3d91dba9
--- /dev/null
+++ b/media-libs/sdl3-ttf/sdl3-ttf-3.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+MY_P="SDL_ttf-release-${PV}"
+DESCRIPTION="Library that allows you to use TrueType fonts in SDL applications"
+HOMEPAGE="https://github.com/libsdl-org/SDL_ttf"
+SRC_URI="https://github.com/libsdl-org/SDL_ttf/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+harfbuzz +plutosvg static-libs X"
+
+# On bumps, check external/ for versions of bundled freetype + harfbuzz
+# to crank up the dep bounds.
+RDEPEND="
+ >=media-libs/libsdl3-3.2.10[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.13.2[harfbuzz?,${MULTILIB_USEDEP}]
+ virtual/opengl[${MULTILIB_USEDEP}]
+ harfbuzz? ( >=media-libs/harfbuzz-8.1.1:=[${MULTILIB_USEDEP}] )
+ plutosvg? ( >=media-libs/plutosvg-0.0.6[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DSDLTTF_VENDORED=OFF
+ -DSDLTTF_INSTALL_MAN=ON
+ -DSDLTTF_HARFBUZZ=$(usex harfbuzz)
+ -DSDLTTF_PLUTOSVG=$(usex plutosvg)
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES.txt README.md
+
+ rm -rf "${ED}"/usr/share/licenses/ || die
+}