summaryrefslogtreecommitdiff
path: root/media-libs/suil/suil-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/suil/suil-0.8.2.ebuild')
-rw-r--r--media-libs/suil/suil-0.8.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/suil/suil-0.8.2.ebuild b/media-libs/suil/suil-0.8.2.ebuild
new file mode 100644
index 000000000000..98098e4d492d
--- /dev/null
+++ b/media-libs/suil/suil-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt4"
+
+RDEPEND="media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ "--mandir=${EPREFIX}/usr/share/man" \
+ "--docdir=${EPREFIX}/usr/share/doc/${PF}" \
+ $(use gtk || echo "--no-gtk") \
+ $(use qt4 || echo "--no-qt") \
+ $(use doc && echo "--docs")
+}