summaryrefslogtreecommitdiff
path: root/media-libs/tiff-compat/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/tiff-compat/files')
-rw-r--r--media-libs/tiff-compat/files/tiff-4.4.0-hylafaxplus-regression.patch34
-rw-r--r--media-libs/tiff-compat/files/tiff-4.4.0_rc1-skip-thumbnail-test.patch32
-rw-r--r--media-libs/tiff-compat/files/tiff-4.5.0_rc1-skip-tools-tests-multilib.patch52
3 files changed, 118 insertions, 0 deletions
diff --git a/media-libs/tiff-compat/files/tiff-4.4.0-hylafaxplus-regression.patch b/media-libs/tiff-compat/files/tiff-4.4.0-hylafaxplus-regression.patch
new file mode 100644
index 000000000000..c640f6e1b1a7
--- /dev/null
+++ b/media-libs/tiff-compat/files/tiff-4.4.0-hylafaxplus-regression.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/883641
+https://gitlab.com/libtiff/libtiff/-/issues/489
+https://gitlab.com/libtiff/libtiff/-/commit/72de8fd00be8a583a6b16cc0b700105020d249ba
+
+From 72de8fd00be8a583a6b16cc0b700105020d249ba Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Tue, 29 Nov 2022 14:57:27 +0100
+Subject: [PATCH] TIFFWriteRawStrip(): restore capabilities to append data in
+ the current strip (fixes #489)
+
+This fixes a regression of libtiff 4.4.0
+--- a/libtiff/tif_write.c
++++ b/libtiff/tif_write.c
+@@ -341,10 +341,13 @@ TIFFWriteRawStrip(TIFF* tif, uint32_t strip, void* data, tmsize_t cc)
+ return ((tmsize_t) -1);
+ }
+
+- tif->tif_curstrip = strip;
++ if (tif->tif_curstrip != strip)
++ {
++ tif->tif_curstrip = strip;
+
+- /* this informs TIFFAppendToStrip() we have changed or reset strip */
+- tif->tif_curoff = 0;
++ /* this informs TIFFAppendToStrip() we have changed or reset strip */
++ tif->tif_curoff = 0;
++ }
+
+ if (td->td_stripsperimage == 0) {
+ TIFFErrorExtR(tif, module,"Zero strips per image");
+--
+GitLab
+
+
diff --git a/media-libs/tiff-compat/files/tiff-4.4.0_rc1-skip-thumbnail-test.patch b/media-libs/tiff-compat/files/tiff-4.4.0_rc1-skip-thumbnail-test.patch
new file mode 100644
index 000000000000..574a02dd3487
--- /dev/null
+++ b/media-libs/tiff-compat/files/tiff-4.4.0_rc1-skip-thumbnail-test.patch
@@ -0,0 +1,32 @@
+https://gitlab.com/libtiff/libtiff/-/merge_requests/334
+
+From 62a49eeb3f0c986c5fcbfc53cd3d7ef2a3fab9b3 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 21 May 2022 01:01:35 +0100
+Subject: [PATCH] test/tiffcp-thumbnail.sh: skip test if tools aren't built
+
+In Gentoo, we avoid building the tools for multilib (32-bit, x86) builds on
+amd64/x86_64 because we only need the library to keep binary applications working.
+
+This causes a test failure in just tiffcp-thumbnail.sh as the 'thumbnail'
+binary isn't built. Skip it if unavailable as it's only a single test.
+
+Fixes: https://gitlab.com/libtiff/libtiff/-/issues/421
+--- a/test/tiffcp-thumbnail.sh
++++ b/test/tiffcp-thumbnail.sh
+@@ -4,7 +4,12 @@
+ #
+ . ${srcdir:-.}/common.sh
+
++if [ ! -x "${TIFFCP}" ] || [ ! -x "${THUMBNAIL}" ] ; then
++ # https://gitlab.com/libtiff/libtiff/-/issues/421
++ exit 77
++fi
++
+ outfile1=o-tiffcp-thumbnail-in.tif
+ outfile2=o-tiffcp-thumbnail-out.tif
+ f_test_convert "${TIFFCP} -c g3:1d" "${IMG_MINISWHITE_1C_1B}" "${outfile1}"
+-f_test_convert "${THUMBNAIL}" "${outfile1}" "${outfile2}"
+\ No newline at end of file
++f_test_convert "${THUMBNAIL}" "${outfile1}" "${outfile2}"
+GitLab
diff --git a/media-libs/tiff-compat/files/tiff-4.5.0_rc1-skip-tools-tests-multilib.patch b/media-libs/tiff-compat/files/tiff-4.5.0_rc1-skip-tools-tests-multilib.patch
new file mode 100644
index 000000000000..831afd287226
--- /dev/null
+++ b/media-libs/tiff-compat/files/tiff-4.5.0_rc1-skip-tools-tests-multilib.patch
@@ -0,0 +1,52 @@
+https://gitlab.com/libtiff/libtiff/-/merge_requests/334
+
+From e7605b93b12c2bf3c864910c23ac976045b5a05a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 21 May 2022 01:01:35 +0100
+Subject: [PATCH 1/2] test (autotools): skip script tests if tools aren't built
+
+In Gentoo, we avoid building the tools for multilib (32-bit, x86) builds on
+amd64/x86_64 because we only need the library to keep binary applications working.
+
+This causes a test failure in e.g. tiffcp-thumbnail.sh as the 'thumbnail'
+binary isn't built. Skip it if unavailable.
+
+Fixes: https://gitlab.com/libtiff/libtiff/-/issues/421
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -55,13 +55,14 @@ XFAIL_TESTS =
+ CLEANFILES = test_packbits.tif o-*
+
+ if HAVE_JPEG
++if TIFF_TOOLS
+ JPEG_DEPENDENT_CHECK_PROG=raw_decode
+ JPEG_DEPENDENT_TESTSCRIPTS=\
+ tiff2rgba-quad-tile.jpg.sh \
+ tiff2rgba-ojpeg_zackthecat_subsamp22_single_strip.sh \
+ tiff2rgba-ojpeg_chewey_subsamp21_multi_strip.sh \
+ tiff2rgba-ojpeg_single_strip_no_rowsperstrip.sh
+-
++endif
+ else
+ JPEG_DEPENDENT_CHECK_PROG=
+ JPEG_DEPENDENT_TESTSCRIPTS=
+@@ -76,6 +77,7 @@ check_PROGRAMS = \
+ endif
+
+ # Test scripts to execute
++if TIFF_TOOLS
+ TESTSCRIPTS = \
+ ppm2tiff_pbm.sh \
+ ppm2tiff_pgm.sh \
+@@ -156,6 +158,9 @@ TESTSCRIPTS = \
+ testfax4.sh \
+ testdeflatelaststripextradata.sh \
+ $(JPEG_DEPENDENT_TESTSCRIPTS)
++else
++TESTSCRIPTS=
++endif
+
+ # This list should contain the references files
+ # from the 'refs' subdirectory
+--
+GitLab