summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Manifest.gzbin69631 -> 69647 bytes
-rw-r--r--media-libs/lv2/Manifest1
-rw-r--r--media-libs/lv2/lv2-1.18.10.ebuild85
-rw-r--r--media-libs/mesa/Manifest2
-rw-r--r--media-libs/mesa/mesa-24.2.2.ebuild490
-rw-r--r--media-libs/vidstab/Manifest6
-rw-r--r--media-libs/vidstab/vidstab-1.1.1-r1.ebuild2
-rw-r--r--media-libs/vidstab/vidstab-1.1.1.ebuild2
-rw-r--r--media-libs/vidstab/vidstab-9999.ebuild2
9 files changed, 498 insertions, 92 deletions
diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index ecb95c65c09f..91b2df07409f 100644
--- a/media-libs/Manifest.gz
+++ b/media-libs/Manifest.gz
Binary files differ
diff --git a/media-libs/lv2/Manifest b/media-libs/lv2/Manifest
index 23a7b82bddd2..f1e50a09ba74 100644
--- a/media-libs/lv2/Manifest
+++ b/media-libs/lv2/Manifest
@@ -2,5 +2,4 @@ AUX lv2-1.18.10-tests-optional.patch 1245 BLAKE2B 1b77b64a9b613bf2299cb4bfc8f53f
AUX lv2-1.18.6-add-missing-lv2.h.patch 401 BLAKE2B 36380468184705a7f0076e293af0c69c60815676046749f2c6bf41c8e0ad747115c673671d67bfc2882d9782288f9b7627b9dafadb023063bc478bbfa0c7c86d SHA512 bdc404792a522c2bca25ca243c469a4d109b253a761d32981055469314b23e3bb470c60b46d75b6ee1f077c7d978b51dfb2d95671cdb1eb6fd83aad01c6df4d6
DIST lv2-1.18.10.tar.xz 237380 BLAKE2B 72f9bc50ebac5d71279e0616bb1eb3c2a6748a28ff68988294135b18c7adc68c46a52b4698faf79f633768bf850d5052128a9f84b90aa9b5f9a56721acaf04c3 SHA512 ab4bcf593f633b1ed16c0eb6aa4525458a00655ef9c87619bf85eaa966f8fd094a8e871b825f679e0d97923f8bbbf11841ff467022390ca2f1a5b5f66ccd5d1b
EBUILD lv2-1.18.10-r1.ebuild 1911 BLAKE2B 741cc7756f494796ef108128e4974eff376b02928e24794f2d8a5d9d839de7d3bedc8163d075d9a13854f7b8b6cc23076d49a0b90f31b2ca8ee272fff6b6c1c4 SHA512 004705638ed80893ec1def1aaf69792429c41b59ae71376dfb666575aa643acd29cc8f96ec31321110b301c563c568b2e2388672e60198eaf52d51e922c524b7
-EBUILD lv2-1.18.10.ebuild 1804 BLAKE2B 0e07017df793c1307671399a37b1d581186b25539f4030787f6c29ba17812d734f3b6e6fed7129967d11a6cbf0ddbd5fe27da51d9b7d82ae96ab9275cb58f593 SHA512 6eb5571a6fa4ab2365097cf9dd11f8a4bfa5d5a7338738aed9f5917fee6c723611507da554b96f0aad6bea3cfa77eebfbbb867bf10dc60214b26e2ce8adf439c
MISC metadata.xml 466 BLAKE2B dadec1c479bf528c62768913e86892f085a1879288abe0b55dcab28ec54583629445c38efce1deb20cfcfdeeb1d6989e10295c8c2014874b83e742e08db26089 SHA512 bfa47b7b47c935f8d2ff2f9d99fd56bb1cc5e98467d18636e73dc59e4ed7f0fa795c05e0bfd27a3146bfe615b4254c67960b06465989dd3d9524894b1063c63c
diff --git a/media-libs/lv2/lv2-1.18.10.ebuild b/media-libs/lv2/lv2-1.18.10.ebuild
deleted file mode 100644
index 7896910a2127..000000000000
--- a/media-libs/lv2/lv2-1.18.10.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit meson-multilib python-single-r1
-
-DESCRIPTION="A simple but extensible successor of LADSPA"
-HOMEPAGE="https://lv2plug.in/"
-SRC_URI="https://lv2plug.in/spec/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc plugins test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- plugins? ( virtual/pkgconfig )
- doc? (
- app-text/doxygen
- dev-python/rdflib
- )
- test? (
- dev-libs/serd
- dev-libs/sord[tools]
- dev-python/rdflib
- )
-"
-CDEPEND="
- ${PYTHON_DEPS}
- plugins? (
- media-libs/libsamplerate
- media-libs/libsndfile
- x11-libs/gtk+:2[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="
- ${CDEPEND}
- doc? ( dev-python/markdown )
-"
-RDEPEND="
- ${CDEPEND}
- $(python_gen_cond_dep '
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- ')
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.18.6-add-missing-lv2.h.patch"
- "${FILESDIR}/${P}-tests-optional.patch"
-)
-
-src_prepare() {
- default
-
- # XXX: Drop this > 1.18.10, -Dstrict=false should prevent it now, bug #906047.
- sed -i -e "/codespell = /s:get_option('tests'):false:" test/meson.build || die
-
- # fix doc installation path
- sed -iE "s%lv2_docdir = .*%lv2_docdir = '"${EPREFIX}"/usr/share/doc/${PF}'%g" meson.build || die
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Dlv2dir="${EPREFIX}"/usr/$(get_libdir)/lv2
- -Dstrict=false
- $(meson_native_use_feature doc docs)
- $(meson_feature plugins)
- $(meson_feature test tests)
- )
-
- meson_src_configure
-}
-
-multilib_src_install_all() {
- local DOCS=( NEWS README.md )
- einstalldocs
-}
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
index ba5e37ae6d43..7978c513dc9e 100644
--- a/media-libs/mesa/Manifest
+++ b/media-libs/mesa/Manifest
@@ -8,6 +8,7 @@ DIST mesa-24.1.7.tar.xz 29206724 BLAKE2B b3102fcf96c032d07826186c2d60dc93e5c17b2
DIST mesa-24.2.0-rc4.tar.xz 29324360 BLAKE2B da26f43fa3e940a406e4987ed311fd22fc7608d4e09fc6cfd6584fe8873b8c5fdbf51d5f32042c46a883739cd22204a3dde2a0a1d6283c3453bc635bfba24ed5 SHA512 5a0b9043e8c3222faeaad31f435f3ea440d670ffa5497340c5809666a857fa4c77288745d52372a2267e9f9be97fc04e0d20b81bc027c1b7a33176a3bfa6b3c6
DIST mesa-24.2.0.tar.xz 29342732 BLAKE2B dfbd0e5b8de3db475f40a8313ee3013bb513d505541e056efd84aad50d5043414dd2c0b95e6c7336a1b4d29037274dae2fa1fdb9697187bf239a5adb54dd3721 SHA512 a585c788801b5a341d356e44d958b148e6e14f6b3d7224e99a92faa2f004bf0cfc90103c5fdc651afb22f805c6f9dc594f9f3f5ecebcea36f6305b3a6ccb9294
DIST mesa-24.2.1.tar.xz 29431192 BLAKE2B f4ef9fd08bbf16551498a8edce1e19e594a0b85ee1f05f8f7c80fcf12ec7ac4cb5947b713791f5202201f8cfc48773507d869dbd239e6fc3dcf2c3a621892327 SHA512 3b77e5faec51b67583131123b0cc010b52325ea308e4075323102aa999d9c9fbb65b873eb537ed4f577b5a0811e7f096e7e101510cb50326ea5c439b4b468380
+DIST mesa-24.2.2.tar.xz 29441876 BLAKE2B 14b29989b056c3bc76cb64babef6e93dd31af37ea72674adaad3f7ef7373c004996e375941662b1c3bbacfd707a21e2e3631a116a841130edfa1bfe3450ae5ab SHA512 d9979f7a1ae7bfeb0658d1b6c9021b7d0043c3ca71db9deaa2fc8a3d4c07cd58497b9233737a31fb66ef711a369a859757a63fb86c2aadd859867f9a4eaf16a9
DIST paste-1.0.14.crate 18157 BLAKE2B 35e8548611c51ee75f4d04926149e5e54870d7073d9b635d550a6fa0f85891f57f326bdbcff3dd8618cf40f8e08cf903ef87d9c034d5921d8b91e1db842cdd7c SHA512 3a793f0e5e773a7f7defc798a4c17ae9a40d715144632ea6cb0a8c785e14c4212046491df016bb9838281f8eaf327a79f01c1e2ac5f26785c028bc880faff9ee
DIST proc-macro2-1.0.70.crate 44343 BLAKE2B fff0dec06b21e391783cc136790238acb783780eaedcf14875a350e7ceb46fdc100c8b9e3f09fb7f4c2196c25d4c6b61e574c0dad762d94533b628faab68cf5c SHA512 ae9366856853f7d96caf7a7581843d36bfc7843f8683897b19ffc666c03b0b1eff502ddb18ca4c1c1a239a368f03f6cc258b0e2795f64b61c6a31404462eec5f
DIST proc-macro2-1.0.86.crate 48958 BLAKE2B 4b89e07f23af8328dbb34fe2b3f1b202f1e6a3885a6269740a23359b41bb4099ac2484565d3b2b0936261689ca525785ac620c766997234fd8d0f409e80e5ea3 SHA512 1cdb7e22a35ae231d880c9420784c9acf97bda2db258b3d34aae5061dc1858449defe19a49e12c6a4173906aa72a4115059ac2db0fc760205fd2ab8b5b414434
@@ -24,5 +25,6 @@ EBUILD mesa-24.1.7.ebuild 13739 BLAKE2B 23b5b302962a028676b753f1bf71b85986445e64
EBUILD mesa-24.2.0.ebuild 13665 BLAKE2B 77bb4aebb4bc005d1a03fa4f34dc47380302b4b7f6614bc3cd6413fbc08b29d49677255e728d76168bed215a3048f2a11c27460c334d7933e3e106bc0b898d30 SHA512 ae6303ce7eb79a2ca55c82de2f95d6cde71350f6fd72f11ab043ff06215d860e13016e7af825b98b4aa082fed306091114c9d52734560da6c2fc1e329b0619af
EBUILD mesa-24.2.0_rc4.ebuild 13665 BLAKE2B f2191d5fac54380bacaf3e4f71ed7fa854e95c6e23f779800d046cfbd758bca20908af8a4d0023bbf2a3078b9c6aa602eed6ba158b18c3cd516ec3085de683e8 SHA512 5a956ca54b19d4d755e23baccaaea48144c9bd894e65c05f6ca79dd6d3ebe5967fbb55186fe25774b3c6adcd56bde70fb15bbf998f7441c2042e6af003125b07
EBUILD mesa-24.2.1.ebuild 13665 BLAKE2B 77bb4aebb4bc005d1a03fa4f34dc47380302b4b7f6614bc3cd6413fbc08b29d49677255e728d76168bed215a3048f2a11c27460c334d7933e3e106bc0b898d30 SHA512 ae6303ce7eb79a2ca55c82de2f95d6cde71350f6fd72f11ab043ff06215d860e13016e7af825b98b4aa082fed306091114c9d52734560da6c2fc1e329b0619af
+EBUILD mesa-24.2.2.ebuild 13665 BLAKE2B 77bb4aebb4bc005d1a03fa4f34dc47380302b4b7f6614bc3cd6413fbc08b29d49677255e728d76168bed215a3048f2a11c27460c334d7933e3e106bc0b898d30 SHA512 ae6303ce7eb79a2ca55c82de2f95d6cde71350f6fd72f11ab043ff06215d860e13016e7af825b98b4aa082fed306091114c9d52734560da6c2fc1e329b0619af
EBUILD mesa-9999.ebuild 13493 BLAKE2B 57454a8ab031ba3a0aa41db56efa9a8c2fa47f7afda0af8b817316e43776f6babe3e24a9c239431a9b9646630ca98dca889fb13666a167c26818872f1a079962 SHA512 90d86f138a4f437c09514a1f6f4bf4504bf0dfc6ff18ce20206998ec02b2e1c0177e7aa2a750fbd4ce25c9017bae611b77a7d90225da22e61208c87fcc307042
MISC metadata.xml 1435 BLAKE2B 53690878512b86ce0b8dce38b083684c85ad5c1a655d5a69cb3265e156869845263eb16f271691b66c9f0cd76e97b56908acf7a1792d6abac0ec99447826cbb5 SHA512 842106e5d6eb60ff33c8cae7f0d52983c4f7e104152718b50fc790cbcb2506551a6fc7841fe8e3c7963850c238f77505b0e49b10a3a936baf459e1acaf73e07f
diff --git a/media-libs/mesa/mesa-24.2.2.ebuild b/media-libs/mesa/mesa-24.2.2.ebuild
new file mode 100644
index 000000000000..a64eb1901f88
--- /dev/null
+++ b/media-libs/mesa/mesa-24.2.2.ebuild
@@ -0,0 +1,490 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {15..18} )
+LLVM_OPTIONAL=1
+CARGO_OPTIONAL=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit flag-o-matic llvm-r1 meson-multilib python-any-r1 linux-info rust-toolchain toolchain-funcs
+
+MY_P="${P/_/-}"
+
+CRATES="
+ syn@2.0.68
+ proc-macro2@1.0.86
+ quote@1.0.33
+ unicode-ident@1.0.12
+ paste@1.0.14
+"
+
+inherit cargo
+
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="https://www.mesa3d.org/ https://mesa.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/mesa.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://archive.mesa3d.org/${MY_P}.tar.xz
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+fi
+
+# This should be {CARGO_CRATE_URIS//.crate/.tar.gz} to correspond to the wrap files,
+# but there are "stale" distfiles on the mirrors with the wrong names.
+# export MESON_PACKAGE_CACHE_DIR="${DISTDIR}"
+SRC_URI+="
+ ${CARGO_CRATE_URIS}
+"
+
+S="${WORKDIR}/${MY_P}"
+EGIT_CHECKOUT_DIR=${S}
+
+LICENSE="MIT SGI-B-2.0"
+SLOT="0"
+
+RADEON_CARDS="r300 r600 radeon radeonsi"
+VIDEO_CARDS="${RADEON_CARDS}
+ d3d12 freedreno intel lavapipe lima nouveau nvk panfrost v3d vc4 virgl
+ vivante vmware zink"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS}
+ cpu_flags_x86_sse2 d3d9 debug +llvm
+ lm-sensors opencl +opengl osmesa +proprietary-codecs selinux
+ test unwind vaapi valgrind vdpau vulkan
+ vulkan-overlay wayland +X xa +zstd"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ d3d9? (
+ || (
+ video_cards_freedreno
+ video_cards_intel
+ video_cards_nouveau
+ video_cards_panfrost
+ video_cards_r300
+ video_cards_r600
+ video_cards_radeonsi
+ video_cards_vmware
+ video_cards_zink
+ )
+ )
+ llvm? ( ${LLVM_REQUIRED_USE} )
+ vulkan-overlay? ( vulkan )
+ video_cards_lavapipe? ( llvm vulkan )
+ video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
+ video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
+ video_cards_zink? ( vulkan opengl )
+ video_cards_nvk? ( vulkan video_cards_nouveau )
+ vdpau? ( X )
+ xa? ( X )
+"
+
+LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.121"
+RDEPEND="
+ >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
+ >=media-libs/libglvnd-1.3.2[X?,${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.9[${MULTILIB_USEDEP}]
+ unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
+ llvm? (
+ $(llvm_gen_dep "
+ sys-devel/llvm:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ opencl? (
+ dev-util/spirv-llvm-translator:\${LLVM_SLOT}
+ sys-devel/clang:\${LLVM_SLOT}[llvm_targets_AMDGPU(+),${MULTILIB_USEDEP}]
+ )
+ ")
+ video_cards_r600? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
+ video_cards_radeon? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ )
+ )
+ lm-sensors? ( sys-apps/lm-sensors:=[${MULTILIB_USEDEP}] )
+ opencl? (
+ >=virtual/opencl-3
+ dev-libs/libclc[spirv(-)]
+ >=dev-util/spirv-tools-1.3.231.0
+ virtual/libelf:0=
+ )
+ vaapi? (
+ >=media-libs/libva-1.7.3:=[${MULTILIB_USEDEP}]
+ )
+ vdpau? ( >=x11-libs/libvdpau-1.5:=[${MULTILIB_USEDEP}] )
+ video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ video_cards_zink? ( media-libs/vulkan-loader:=[${MULTILIB_USEDEP}] )
+ selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.18.0[${MULTILIB_USEDEP}] )
+ ${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_intel?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxshmfence-1.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.17:=[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-keysyms[${MULTILIB_USEDEP}]
+ )
+ zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
+"
+for card in ${RADEON_CARDS}; do
+ RDEPEND="${RDEPEND}
+ video_cards_${card}? ( ${LIBDRM_DEPSTRING}[video_cards_radeon] )
+ "
+done
+RDEPEND="${RDEPEND}
+ video_cards_radeonsi? ( ${LIBDRM_DEPSTRING}[video_cards_amdgpu] )
+"
+
+DEPEND="${RDEPEND}
+ video_cards_d3d12? ( >=dev-util/directx-headers-1.613.0[${MULTILIB_USEDEP}] )
+ valgrind? ( dev-debug/valgrind )
+ wayland? ( >=dev-libs/wayland-protocols-1.34 )
+ X? (
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-base/xorg-proto
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ opencl? (
+ >=virtual/rust-1.62.0
+ >=dev-util/bindgen-0.58.0
+ )
+ >=dev-build/meson-1.4.1
+ app-alternatives/yacc
+ app-alternatives/lex
+ virtual/pkgconfig
+ $(python_gen_any_dep "
+ >=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]
+ dev-python/packaging[\${PYTHON_USEDEP}]
+ dev-python/pyyaml[\${PYTHON_USEDEP}]
+ ")
+ video_cards_intel? (
+ ~dev-util/intel_clc-${PV}
+ dev-libs/libclc[spirv(-)]
+ $(python_gen_any_dep "dev-python/ply[\${PYTHON_USEDEP}]")
+ )
+ vulkan? (
+ dev-util/glslang
+ video_cards_nvk? (
+ >=dev-util/bindgen-0.68.1
+ >=dev-util/cbindgen-0.26.0
+ >=virtual/rust-1.74.1
+ )
+ )
+ wayland? ( dev-util/wayland-scanner )
+"
+
+QA_WX_LOAD="
+x86? (
+ usr/lib/libglapi.so.0.0.0
+ usr/lib/libOSMesa.so.8.0.0
+ usr/lib/libGLX_mesa.so.0.0.0
+)"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ else
+ unpack ${MY_P}.tar.xz
+ fi
+
+ # We need this because we cannot tell meson to use DISTDIR yet
+ pushd "${DISTDIR}" >/dev/null || die
+ mkdir -p "${S}"/subprojects/packagecache || die
+ local i
+ for i in *.crate; do
+ ln -s "${PWD}/${i}" "${S}/subprojects/packagecache/${i/.crate/}.tar.gz" || die
+ done
+ popd >/dev/null || die
+}
+
+pkg_pretend() {
+ if use vulkan; then
+ if ! use video_cards_d3d12 &&
+ ! use video_cards_freedreno &&
+ ! use video_cards_intel &&
+ ! use video_cards_lavapipe &&
+ ! use video_cards_nouveau &&
+ ! use video_cards_nvk &&
+ ! use video_cards_panfrost &&
+ ! use video_cards_radeonsi &&
+ ! use video_cards_v3d &&
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain d3d12, freedreno, intel, lavapipe, nouveau, nvk, panfrost, radeonsi, v3d, or virgl"
+ fi
+ fi
+
+ # VA
+ if use vaapi; then
+ if ! use video_cards_d3d12 &&
+ ! use video_cards_nouveau &&
+ ! use video_cards_r600 &&
+ ! use video_cards_radeonsi &&
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vaapi since VIDEO_CARDS does not contain d3d12, nouveau, r600, radeonsi, or virgl"
+ fi
+ fi
+
+ if use vdpau; then
+ if ! use video_cards_d3d12 &&
+ ! use video_cards_nouveau &&
+ ! use video_cards_r600 &&
+ ! use video_cards_radeonsi &&
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vdpau since VIDEO_CARDS does not contain d3d12, nouveau, r600, radeonsi, or virgl"
+ fi
+ fi
+
+ if use xa; then
+ if ! use video_cards_freedreno &&
+ ! use video_cards_intel &&
+ ! use video_cards_nouveau &&
+ ! use video_cards_vmware; then
+ ewarn "Ignoring USE=xa since VIDEO_CARDS does not contain freedreno, intel, nouveau, or vmware"
+ fi
+ fi
+
+ if ! use llvm; then
+ use opencl && ewarn "Ignoring USE=opencl since USE does not contain llvm"
+ fi
+
+ if use osmesa && ! use llvm; then
+ ewarn "OSMesa will be slow without enabling USE=llvm"
+ fi
+}
+
+python_check_deps() {
+ python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/packaging[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/pyyaml[${PYTHON_USEDEP}]" || return 1
+ if use llvm && use vulkan && use video_cards_intel && use amd64; then
+ python_has_version -b "dev-python/ply[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+pkg_setup() {
+ # warning message for bug 459306
+ if use llvm && has_version sys-devel/llvm[!debug=]; then
+ ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
+ ewarn "detected! This can cause problems. For details, see bug 459306."
+ fi
+
+ if use video_cards_intel ||
+ use video_cards_radeonsi; then
+ if kernel_is -ge 5 11 3; then
+ CONFIG_CHECK="~KCMP"
+ elif kernel_is -ge 5 11; then
+ CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ elif kernel_is -ge 5 10 20; then
+ CONFIG_CHECK="~KCMP"
+ else
+ CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ fi
+ linux-info_pkg_setup
+ fi
+
+ use llvm && llvm-r1_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -i -e "/^PLATFORM_SYMBOLS/a '__gentoo_check_ldflags__'," \
+ bin/symbols-check.py || die # bug #830728
+}
+
+multilib_src_configure() {
+ local emesonargs=()
+
+ # bug #932591 and https://gitlab.freedesktop.org/mesa/mesa/-/issues/11140
+ tc-is-gcc && [[ $(gcc-major-version) -ge 14 ]] && filter-lto
+
+ local platforms
+ use X && platforms+="x11"
+ use wayland && platforms+=",wayland"
+ emesonargs+=(-Dplatforms=${platforms#,})
+
+ if use video_cards_freedreno ||
+ use video_cards_intel || # crocus i915 iris
+ use video_cards_nouveau ||
+ use video_cards_panfrost ||
+ use video_cards_r300 ||
+ use video_cards_r600 ||
+ use video_cards_radeonsi ||
+ use video_cards_vmware || # svga
+ use video_cards_zink; then
+ emesonargs+=($(meson_use d3d9 gallium-nine))
+ else
+ emesonargs+=(-Dgallium-nine=false)
+ fi
+
+ if use video_cards_d3d12 ||
+ use video_cards_nouveau ||
+ use video_cards_r600 ||
+ use video_cards_radeonsi ||
+ use video_cards_virgl; then
+ emesonargs+=($(meson_feature vaapi gallium-va))
+ use vaapi && emesonargs+=( -Dva-libs-path="${EPREFIX}"/usr/$(get_libdir)/va/drivers )
+ else
+ emesonargs+=(-Dgallium-va=disabled)
+ fi
+
+ if use video_cards_d3d12; then
+ emesonargs+=($(meson_feature vaapi gallium-d3d12-video))
+ fi
+
+ if use video_cards_d3d12 ||
+ use video_cards_nouveau ||
+ use video_cards_r600 ||
+ use video_cards_radeonsi ||
+ use video_cards_virgl; then
+ emesonargs+=($(meson_feature vdpau gallium-vdpau))
+ else
+ emesonargs+=(-Dgallium-vdpau=disabled)
+ fi
+
+ if use video_cards_freedreno ||
+ use video_cards_intel ||
+ use video_cards_nouveau ||
+ use video_cards_vmware; then
+ emesonargs+=($(meson_feature xa gallium-xa))
+ else
+ emesonargs+=(-Dgallium-xa=disabled)
+ fi
+
+ gallium_enable !llvm softpipe
+ gallium_enable llvm llvmpipe
+ gallium_enable video_cards_d3d12 d3d12
+ gallium_enable video_cards_freedreno freedreno
+ gallium_enable video_cards_intel crocus i915 iris
+ gallium_enable video_cards_lima lima
+ gallium_enable video_cards_nouveau nouveau
+ gallium_enable video_cards_panfrost panfrost
+ gallium_enable video_cards_v3d v3d
+ gallium_enable video_cards_vc4 vc4
+ gallium_enable video_cards_virgl virgl
+ gallium_enable video_cards_vivante etnaviv
+ gallium_enable video_cards_vmware svga
+ gallium_enable video_cards_zink zink
+
+ gallium_enable video_cards_r300 r300
+ gallium_enable video_cards_r600 r600
+ gallium_enable video_cards_radeonsi radeonsi
+ if ! use video_cards_r300 &&
+ ! use video_cards_r600; then
+ gallium_enable video_cards_radeon r300 r600
+ fi
+
+ if use llvm && use opencl; then
+ PKG_CONFIG_PATH="$(get_llvm_prefix)/$(get_libdir)/pkgconfig"
+ # See https://gitlab.freedesktop.org/mesa/mesa/-/blob/main/docs/rusticl.rst
+ emesonargs+=(
+ $(meson_native_true gallium-rusticl)
+ -Drust_std=2021
+ )
+ fi
+
+ if use vulkan; then
+ vulkan_enable video_cards_d3d12 microsoft-experimental
+ vulkan_enable video_cards_freedreno freedreno
+ vulkan_enable video_cards_intel intel intel_hasvk
+ vulkan_enable video_cards_lavapipe swrast
+ vulkan_enable video_cards_panfrost panfrost
+ vulkan_enable video_cards_radeonsi amd
+ vulkan_enable video_cards_v3d broadcom
+ vulkan_enable video_cards_vc4 broadcom
+ vulkan_enable video_cards_virgl virtio
+ if use video_cards_nvk; then
+ vulkan_enable video_cards_nvk nouveau
+ if ! multilib_is_native_abi; then
+ echo -e "[binaries]\nrust = ['rustc', '--target=$(rust_abi $CBUILD)']" > "${T}/rust_fix.ini"
+ emesonargs+=(
+ --native-file "${T}"/rust_fix.ini
+ )
+ fi
+ fi
+ fi
+
+ driver_list() {
+ local drivers="$(sort -u <<< "${1// /$'\n'}")"
+ echo "${drivers//$'\n'/,}"
+ }
+
+ local vulkan_layers
+ use vulkan && vulkan_layers+="device-select"
+ use vulkan-overlay && vulkan_layers+=",overlay"
+ emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
+
+ if use opengl && use X; then
+ emesonargs+=(-Dglx=dri)
+ else
+ emesonargs+=(-Dglx=disabled)
+ fi
+
+ if [[ "${ABI}" == amd64 ]]; then
+ emesonargs+=($(meson_feature video_cards_intel intel-rt))
+ fi
+
+ use debug && EMESON_BUILDTYPE=debug
+
+ emesonargs+=(
+ $(meson_use test build-tests)
+ -Dshared-glapi=enabled
+ -Ddri3=enabled
+ -Dexpat=enabled
+ $(meson_use opengl)
+ $(meson_feature opengl gbm)
+ $(meson_feature opengl gles1)
+ $(meson_feature opengl gles2)
+ $(meson_feature opengl glvnd)
+ $(meson_feature opengl egl)
+ $(meson_feature llvm)
+ $(meson_feature lm-sensors lmsensors)
+ $(meson_use osmesa)
+ $(meson_use selinux)
+ $(meson_feature unwind libunwind)
+ $(meson_feature zstd)
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ -Dintel-clc=$(usex video_cards_intel system auto)
+ -Dvalgrind=$(usex valgrind auto disabled)
+ -Dvideo-codecs=$(usex proprietary-codecs "all" "all_free")
+ -Dgallium-drivers=$(driver_list "${GALLIUM_DRIVERS[*]}")
+ -Dvulkan-drivers=$(driver_list "${VULKAN_DRIVERS[*]}")
+ -Db_ndebug=$(usex debug false true)
+ )
+ meson_src_configure
+
+ if ! multilib_is_native_abi && use video_cards_nvk; then
+ sed -i -E '{N; s/(rule rust_COMPILER_FOR_BUILD\n command = rustc) --target=[a-zA-Z0-9=:-]+ (.*) -C link-arg=-m[[:digit:]]+/\1 \2/g}' build.ninja || die
+ fi
+}
+
+multilib_src_test() {
+ meson_src_test -t 100
+}
+
+# $1 - VIDEO_CARDS flag (check skipped for "--")
+# other args - names of DRI drivers to enable
+gallium_enable() {
+ if [[ $1 == -- ]] || use $1; then
+ shift
+ GALLIUM_DRIVERS+=("$@")
+ fi
+}
+
+vulkan_enable() {
+ if [[ $1 == -- ]] || use $1; then
+ shift
+ VULKAN_DRIVERS+=("$@")
+ fi
+}
diff --git a/media-libs/vidstab/Manifest b/media-libs/vidstab/Manifest
index 30e05490e4a9..28c8b84ba1ca 100644
--- a/media-libs/vidstab/Manifest
+++ b/media-libs/vidstab/Manifest
@@ -1,5 +1,5 @@
DIST vidstab-1.1.1.tar.gz 80717 BLAKE2B e2ce03d24358404c617816466ad3fd715999ef4d391617e9cec7923353ba2ce4ac3b3eedce67f3fadf3bd6fdfb2e4516a5b95c3fca9f613e367b1490ec78ae0a SHA512 b27ac95ab5302e9500af5a52cb09f557b9dacbdc4dc57a9781e2f9ae65a6ffea396f9819bca1f6a103f9d1896bf3061f1cb647166b14b8de8e89a1b15f010e5c
-EBUILD vidstab-1.1.1-r1.ebuild 1728 BLAKE2B 864c8eed0c95858aad245308781ca1c915858674f1819e349c50bc20d0abfdc7170cf75f62ef43f27215ed75ebc324ce4ccb0457be2fd5dff6cc44156b6f73ef SHA512 2fd2c0b1ce0f24949a32d9f211f34e14e869257d075e3c0f0fe98a31cef1640c83dc234a465cf9fd01485a7d6d98d8c02637f0c97f94df3c78cd34ca07333f3c
-EBUILD vidstab-1.1.1.ebuild 1675 BLAKE2B e6a438b61ab9eb3da931907cf556403cb4f993de60e0d88b9636c2d0eae70d54fe988f379c9cc5b604fff0dc2a8b286fd2043fe076cd9efc82133501104fd3a9 SHA512 c09d61418f6f7375c928026904d03458130b23af98bc28cdeeea446adb6c8037d80d3b5fa08eae1932a77d3e10fb4e44e6a2e61135fe44941cfb473d09bc6d26
-EBUILD vidstab-9999.ebuild 1726 BLAKE2B 72ea6a20017f6efde93de1a0c49c4eaeab67d18a45e96eda4903f0d3397dda5a2f303cc83df6b6441aec9c54f504805b1a0225ef35d64c886cd296f0ee16f585 SHA512 203018227a8a843d1e9fc705d3e073877aac528f3203600dcf9fa4659a4a69322990c6af8e0cbd6fd79f93b2bcf8b08f92308d9af9771ac73f0aa10231a8304d
+EBUILD vidstab-1.1.1-r1.ebuild 1722 BLAKE2B e977122367860045e519d6d9109b6bd20c7c653e857cadebbf4c9960f6e4f28f8769b2f487e2c671f3d012dfe3ac9d53f8ccae2079984bb9a6e98a7ffb76d7d0 SHA512 2a93a813fe2486d3d21ac6d85d42b25771c4ef8a1cee5b3f70cbbe17ddc3773d50230a5a4bfaa8f3ac9c3d642115676bf5a1c1a9e9d7dedc2e9f340a08acb916
+EBUILD vidstab-1.1.1.ebuild 1669 BLAKE2B ae4e6843e0ff4fc24459427e2e49034718d78b9f4bc55db17178842f9e2c95c0e3574a87ee5493f03bc18599394bf83b9237c4ae4c008febb8676fb05d98299b SHA512 6e385a7d519cd0c036850a6cebfe0587e8de19d12db38a14be7e67fbb4491c819b06068c77657471a5439797a28d7320fcff7f88778acc0737770d22fd9a407f
+EBUILD vidstab-9999.ebuild 1720 BLAKE2B da201c5f262473c8a1ea74930c1263e8d8797faf267c7f382d190a8f6cf8a571b45a61159a81511820823feb3723aa9672ea7947c00cfe981c4e6f48a1fb7975 SHA512 14910c3b57cf9cab4717f6195fcbc5cecbd7455076d4804757bbe2846537b9174880436ba44cb490e46b10739496961999cc4b82abd56c6d96ea4a1239a55761
MISC metadata.xml 615 BLAKE2B 9260db65c08e6d6284fff960a229259d5d62672b5014697e0503a39f7e48b82955396fec6f608611306b2c586a39532fc61ebde8fe06ad0e9fb8c150f6d914f7 SHA512 8ffb575f589d09954230457a7d7b100a6f5fa9886a0a99bfb6813c0174c74817a3670957b09afedeaf9afe74451e8dd8da55bd1eb6d6fce36c655bce14fb21ac
diff --git a/media-libs/vidstab/vidstab-1.1.1-r1.ebuild b/media-libs/vidstab/vidstab-1.1.1-r1.ebuild
index 6df252bff8f9..c8203cc91f9d 100644
--- a/media-libs/vidstab/vidstab-1.1.1-r1.ebuild
+++ b/media-libs/vidstab/vidstab-1.1.1-r1.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/georgmartius/vid.stab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~loong ppc ppc64 ~riscv ~x86"
S="${WORKDIR}/vid.stab-${PV}"
fi
diff --git a/media-libs/vidstab/vidstab-1.1.1.ebuild b/media-libs/vidstab/vidstab-1.1.1.ebuild
index ec0ef0590a9a..a05d655f90b3 100644
--- a/media-libs/vidstab/vidstab-1.1.1.ebuild
+++ b/media-libs/vidstab/vidstab-1.1.1.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/georgmartius/vid.stab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
S="${WORKDIR}/vid.stab-${PV}"
fi
diff --git a/media-libs/vidstab/vidstab-9999.ebuild b/media-libs/vidstab/vidstab-9999.ebuild
index fa73a3e3e1e3..6ad7e8b24a26 100644
--- a/media-libs/vidstab/vidstab-9999.ebuild
+++ b/media-libs/vidstab/vidstab-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/georgmartius/vid.stab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~x86"
S="${WORKDIR}/vid.stab-${PV}"
fi