summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild')
-rw-r--r--media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild b/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild
new file mode 100644
index 000000000000..fc4e9c3f0adf
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="vgmstream decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.vgmstream"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.vgmstream"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.vgmstream/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.vgmstream-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ "
+RDEPEND="
+ ${DEPEND}
+ "