summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-extb
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-extb')
-rw-r--r--media-plugins/vdr-extb/Manifest2
-rw-r--r--media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild24
2 files changed, 12 insertions, 14 deletions
diff --git a/media-plugins/vdr-extb/Manifest b/media-plugins/vdr-extb/Manifest
index 1b7ec4f32492..10400c521504 100644
--- a/media-plugins/vdr-extb/Manifest
+++ b/media-plugins/vdr-extb/Manifest
@@ -3,5 +3,5 @@ AUX vdr-extb-0.3.1_vdr-1.7.13.diff 873 BLAKE2B dd1bdd48a005c3caf4536f85e72e0ebab
DIST extb.tar.gz 45417 BLAKE2B 70c264b9d988e64ea5c21e76f5b02c23bf89a90d846f41f785a2491f138e182483046b8457cb46615430a42f7ae8ec337bd5c999998457470866c2c020eebd07 SHA512 2fd539425b773419aaca27ee6c00879a420b8bc47fc3033082eef03275f5e8cdeba0c6562fe160cbdf1146f5cb4a45ad4e723f7e63d627e1937a847615456381
DIST extb_firmware_1.08_lircd.conf.zip 8197 BLAKE2B 7635ab601e10170e6b063fec3cc8486550a75083beb5e9071e6779859bfe57764a9210472925df0375e997db6618460d27bf68a42c2571d82ef0de0f2a062f5e SHA512 bee864bdf876a117f4235ab415feb04dfc31f59118ed9c601a46ee90b0df010d890e61bf12f9351fe9b3977815d3c3b9985e069a1ad9e72ceb177691bbd70609
DIST vdr-extb-0.3.1.tar.gz 53136 BLAKE2B ccb3bb5a4a251e2928be1b7d836e98ab756730ecc7f6976c9520f3c9a13dcfb6ee513630fc42bca306134f04d2f3b92e22ca9ee7c25f4fc00e0544c136dd3397 SHA512 cbef33eef77e22266adc10fe305be2ae50c69c312dce44711d3e889387638daf9e6a0d71e8342a63f6655eb82f51c15f274b3a9815f876d17fbc4079da2ee391
-EBUILD vdr-extb-0.3.1.ebuild 1781 BLAKE2B fdeecf8b4364ebcfa20cf34f8b045b09289aca0b9ae0bb675e909af1954bd33900000bf27df249a4a1a74bf69db00ecfa262718b40a667e74a27546f5bf75066 SHA512 0d5efeedfb590f15304041ed091b8cc363506f5821bf858af71cb2e577ea1c2f77ebb7e364b387e969bc3442796274b571b5b6c09e126a06eb9bf222981fe4e1
+EBUILD vdr-extb-0.3.1.ebuild 1744 BLAKE2B 81d5315c8e6efe50a23936182015f82d0d3eeb77655c4c6039109ed97eb3e3c1442d481207f275d70fb107cc9fdc0ee61668327b9b9aa0745500ca776bf6776e SHA512 4b496955eb52e9370e98a03052aa32dc136f0b62797589aff4682864f0589c3a7d2b6d3253d4782a5183555d167970c57903b233cedef343aa6fd82b8c7bb001
MISC metadata.xml 321 BLAKE2B 8db922a52a70940c07786766b9ae2e76d51c13fb68dd79ab9fe84f841a71592757c2a7d72a1943cee54d54b4e9bcd11f5ebc10b6ff21c2c22338591279b8369f SHA512 1bfa4279dd2502d0aa29b160da234cea71acb09d6b4775c65c11b83f38e56f69b71d96076f516a54ce4ac7b84790f0a2b5822d0d54fd65e9afd7c905a2f7f7ce
diff --git a/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild b/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
index 70c48ee88c03..ad6f148be980 100644
--- a/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
+++ b/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vdr-plugin-2
DESCRIPTION="VDR Plugin: used to control the VDR Extension Board"
-HOMEPAGE="http://www.deltab.de/content/view/74/76/"
-SRC_URI="http://www.deltab.de/component/option,com_docman/task,doc_download/gid,102/ -> "${P}".tar.gz
- mirror://vdrfiles/${PN}/extb_firmware_1.08_lircd.conf.zip
- mirror://vdrfiles/${PN}/extb.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tar.gz
+ http://vdr.websitec.de/download/${PN}/extb_firmware_1.08_lircd.conf.zip
+ http://vdr.websitec.de/download/${PN}/extb.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=media-video/vdr-1.6.0
- app-misc/lirc"
+DEPEND="app-misc/lirc
+ media-video/vdr"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -27,8 +27,8 @@ src_prepare() {
-e "s:\$(LDLIBS):\$(LDFLAGS) \$(LDLIBS):"
cd "${WORKDIR}"
- epatch "${FILESDIR}/${P}-gentoo.diff"
- epatch "${FILESDIR}/${P}_vdr-1.7.13.diff"
+ eapply -p0 "${FILESDIR}/${P}-gentoo.diff"
+ eapply -p0 "${FILESDIR}/${P}_vdr-1.7.13.diff"
}
src_compile() {
@@ -39,8 +39,7 @@ src_compile() {
src_install() {
vdr-plugin-2_src_install
- dodoc README.de
- dodoc "${WORKDIR}/lircd.conf.extb_FW1.08"
+ dodoc README.de "${WORKDIR}/lircd.conf.extb_FW1.08"
docinto wakeup
dodoc "${S}/wakeup/README.de"
@@ -62,10 +61,9 @@ src_install() {
pkg_postinst() {
vdr-plugin-2_pkg_postinst
- einfo
einfo "You need to upload the included firmware (1.08)"
einfo "(you will find it in /usr/share/extb/)"
einfo "into the extension board and update your lircd.conf"
einfo "See the supplied lircd.conf.extb_FW1.08 in"
- einfo "/usr/share/doc/vdrplugin-extb"
+ einfo "/usr/share/doc/${PF}"
}