summaryrefslogtreecommitdiff
path: root/media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch')
-rw-r--r--media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch b/media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch
new file mode 100644
index 000000000000..7f1592e9825d
--- /dev/null
+++ b/media-radio/xwxapt/files/xwxapt-3.4.2-fix-autotools.patch
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,17 +35,16 @@
+ AC_CHECK_LIB([gmodule-2.0], [g_module_open])
+
+ # Internationalization tools
++AM_GNU_GETTEXT([external])
+ AM_GNU_GETTEXT_VERSION([0.19.8])
+ GETTEXT_PACKAGE=xwxapt
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext package.])
+-AM_GNU_GETTEXT
+ PROGRAMNAME_LOCALEDIR=[${datadir}/locale]
+ AC_SUBST(PROGRAMNAME_LOCALEDIR)
+
+ # Add the languages which your application supports here.
+ ALL_LINGUAS=""
+-AM_GNU_GETTEXT
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([libintl.h stdlib.h string.h unistd.h])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -48,18 +48,5 @@
+ if test -d files/; then \
+ cp files/$(PACKAGE).desktop $(DESTDIR)/usr/share/applications/; \
+ cp files/$(PACKAGE).png $(DESTDIR)/usr/share/pixmaps/; \
+- fi; \
+- if !(test -d $(DESTDIR)/usr/share/doc/$(PACKAGE)); then \
+- mkdir $(DESTDIR)/usr/share/doc/$(PACKAGE)/; \
+- fi; \
+- if test -d doc/; then \
+- cp -r doc/* $(DESTDIR)/usr/share/doc/$(PACKAGE)/; \
+- cp -r doc/$(PACKAGE).1.gz $(DESTDIR)/usr/share/man/man1/; \
+- fi; \
+- if !(test -d /home/`logname`/$(PACKAGE)); then \
+- cp -r $(PACKAGE) /home/`logname`/; \
+- else \
+- cp $(PACKAGE)/$(PACKAGE).glade /home/`logname`/$(PACKAGE); \
+- fi; \
+- chown -R `logname`:`logname` /home/`logname`/$(PACKAGE);
++ fi;
+