summaryrefslogtreecommitdiff
path: root/media-sound/csound/csound-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/csound/csound-9999.ebuild')
-rw-r--r--media-sound/csound/csound-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index 2f6048b164b7..fb5d82a5cfaa 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -8,7 +8,7 @@
EAPI=8
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake lua-single python-single-r1
@@ -22,7 +22,7 @@ else
https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_pdf.zip
https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_html.zip
)"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 x86"
fi
DESCRIPTION="Sound design and signal processing system for composition and performance"
@@ -105,6 +105,13 @@ src_prepare() {
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
-i CMakeLists.txt || die
+
+ if use doc; then
+ local png="${WORKDIR}/html/images/delayk.png"
+ pngfix -q --out=${png/.png/fixed.png} ${png} # see pngfix help for exit codes
+ [[ $? -gt 15 ]] && die "Failed to fix ${png}"
+ mv -f ${png/.png/fixed.png} ${png} || die
+ fi
}
src_configure() {