summaryrefslogtreecommitdiff
path: root/media-sound/mpg321/mpg321-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpg321/mpg321-0.3.2.ebuild')
-rw-r--r--media-sound/mpg321/mpg321-0.3.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/mpg321/mpg321-0.3.2.ebuild b/media-sound/mpg321/mpg321-0.3.2.ebuild
index 1c6cf71665a0..390abffdec04 100644
--- a/media-sound/mpg321/mpg321-0.3.2.ebuild
+++ b/media-sound/mpg321/mpg321-0.3.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools eutils
DESCRIPTION="A realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
@@ -23,9 +23,15 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${P}-orig
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.12-check-for-lround.patch"
+ "${FILESDIR}/${P}-format-security.patch"
+ "${FILESDIR}/${P}-CVE-2019-14247.patch"
+ "${FILESDIR}/${P}-gcc10.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.2.12-check-for-lround.patch \
- "${FILESDIR}"/${P}-format-security.patch
+ default
eautoreconf
}