summaryrefslogtreecommitdiff
path: root/media-sound/pms/pms-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pms/pms-9999.ebuild')
-rw-r--r--media-sound/pms/pms-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
new file mode 100644
index 000000000000..2a0de1e38b9c
--- /dev/null
+++ b/media-sound/pms/pms-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="https://ambientsound.github.io/pms"
+
+EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
+EGIT_BRANCH="0.42.x" # todo: package the golang version
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="+regex doc"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+ media-libs/libmpdclient
+"
+DEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/pandoc )
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOC=$(usex doc)
+ -DENABLE_REGEX=$(usex regex)
+ )
+
+ cmake-utils_src_configure
+}