summaryrefslogtreecommitdiff
path: root/media-sound/snapcast/snapcast-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/snapcast/snapcast-9999.ebuild')
-rw-r--r--media-sound/snapcast/snapcast-9999.ebuild53
1 files changed, 19 insertions, 34 deletions
diff --git a/media-sound/snapcast/snapcast-9999.ebuild b/media-sound/snapcast/snapcast-9999.ebuild
index 09e72be8ff2e..6228cd7ec667 100644
--- a/media-sound/snapcast/snapcast-9999.ebuild
+++ b/media-sound/snapcast/snapcast-9999.ebuild
@@ -1,32 +1,38 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
+
+inherit cmake
DESCRIPTION="Synchronous multi-room audio player"
HOMEPAGE="https://github.com/badaix/snapcast"
-if [[ ${PV} == *9999 ]] ; then
- inherit user cmake-utils git-r3
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/badaix/snapcast.git"
EGIT_BRANCH="develop"
else
- inherit user cmake-utils
-
SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+client +flac +server static-libs tremor +vorbis +zeroconf"
+IUSE="+client +expat +flac +opus +server static-libs tremor +vorbis +zeroconf"
REQUIRED_USE="|| ( server client )"
-RDEPEND="client? ( media-libs/alsa-lib )
+RDEPEND="client? (
+ acct-user/snapclient
+ media-libs/alsa-lib )
+ expat? ( dev-libs/expat )
flac? ( media-libs/flac )
+ opus? ( media-libs/opus )
+ server? (
+ acct-group/snapserver
+ acct-user/snapserver )
tremor? ( media-libs/tremor )
vorbis? ( media-libs/libvorbis )
zeroconf? ( net-dns/avahi[dbus] )"
@@ -35,21 +41,12 @@ DEPEND="${RDEPEND}
>=dev-cpp/asio-1.12.1
>=dev-cpp/popl-1.2.0"
-pkg_setup() {
- if use server ; then
- enewgroup "snapserver"
- enewuser "snapserver" -1 -1 /var/lib/snapserver snapserver
- fi
-
- if use client ; then
- enewuser "snapclient" -1 -1 /var/lib/snapclient audio
- fi
-}
-
src_configure() {
local mycmakeargs=(
-DBUILD_CLIENT=$(usex client)
+ -DBUILD_WITH_EXPAT=$(usex expat)
-DBUILD_WITH_FLAC=$(usex flac)
+ -DBUILD_WITH_OPUS=$(usex opus)
-DBUILD_SERVER=$(usex server)
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DBUILD_TESTS=no
@@ -58,11 +55,11 @@ src_configure() {
-DBUILD_WITH_AVAHI=$(usex zeroconf)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
for bin in server client ; do
if use ${bin} ; then
@@ -72,16 +69,4 @@ src_install() {
newinitd "${FILESDIR}/snap${bin}.initd" "snap${bin}"
fi
done
-
- if use client ; then
- keepdir /var/lib/snapclient
- fowners snapclient:audio /var/lib/snapclient
- fperms 0770 /var/lib/snapclient
- fi
-
- if use server ; then
- keepdir /var/lib/snapserver
- fowners snapserver:snapserver /var/lib/snapserver
- fperms 0770 /var/lib/snapserver
- fi
}