summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin57100 -> 57099 bytes
-rw-r--r--media-sound/abcmidi/Manifest2
-rw-r--r--media-sound/abcmidi/abcmidi-2023.08.22.ebuild35
-rw-r--r--media-sound/gnump3d/Manifest1
-rw-r--r--media-sound/gnump3d/gnump3d-3.0-r5.ebuild76
5 files changed, 114 insertions, 0 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index 71a4291ac74f..c2927a5ececd 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
index a032e81d3088..46ac2ece87ba 100644
--- a/media-sound/abcmidi/Manifest
+++ b/media-sound/abcmidi/Manifest
@@ -1,3 +1,5 @@
DIST abcMIDI-2023.06.25.zip 623842 BLAKE2B bc50ef0b1ed8507ea2c3a1bb67920f052eb0f45236f75a8640aef02693790a74298c4b20305509b94ce6c698b99b8a796d7a174f02677df7efc0f1bea2e9acf0 SHA512 1f2c337e66a4072f0693260b3ff3caaa6ba7b7082566f7619966c794686c00915ad412c7c007bb839085ce54cb9cd860bbdf9fb1d3e8e58667c32cf1838866e3
+DIST abcMIDI-2023.08.22.zip 624039 BLAKE2B 881a4be397350dec0fb0afca81497b79055fbf654532eb32fa7363f0897aeb810133a4a88fade996917451288352b4e47f93c2e5728b77fb8e78898d53faa98d SHA512 31c005401e1f375658f3a3145bcba85d0fdae5231912f0c806b12e07aa42300dbb4da87d7c7ebea8b27b1bd2bcf3e30973baa3e5a698a2b15d731fd43c1e412f
EBUILD abcmidi-2023.06.25.ebuild 676 BLAKE2B 31477b1343585fb2359f83e9bd3073bf381e7c3c58f72255acc221eccb88f56cb8b1312a50a11ebb1d7d922b237743f144178f524cc1bd02d421cefc6afedbcd SHA512 a0a9665494091ae1f38cd72327ab1b6544af3a9368b3c42ca57d23f9370af0f5469db1cc46d2ac0aefd0dc44a91e807249d7ea8b62ad98ba7c339bb75470eaf0
+EBUILD abcmidi-2023.08.22.ebuild 678 BLAKE2B e80a5b9b4ab2b6b2f3a9100a759875547a3971d443d876db558a5abf5a323eb29f03cf318bd6ac2abb429648955d67cfee9bcdbaa43f13bacd2654ec6d1eef72 SHA512 3a687ee6c926bda64ab5b99d072505c88b949dab46b44fa7b34a002eceb8c9394eedd64def057d5ed99fc06b26776d519a88f77821dcd0ab4ca7f97dbafbc2d7
MISC metadata.xml 327 BLAKE2B d92d9b40b1c1af1a4ba5cea8b956a098066ae7cc9eab2cb31a0dfbcc37400558f5f35a6ce04a7541ecbea7578906f688d2931c1f62751e5a2d7bb7b80e97cd2f SHA512 170ca99684768ef2d5b0e8a26e6ca64468b3134847ffe53f6a1efb623bfe77a6c09dfd67df553a306af045a47bc69f0d41ceadf508cce7f75f3c2a7614d2d725
diff --git a/media-sound/abcmidi/abcmidi-2023.08.22.ebuild b/media-sound/abcmidi/abcmidi-2023.08.22.ebuild
new file mode 100644
index 000000000000..636c9619449a
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2023.08.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="abcMIDI-${PV}"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
+SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+ sed -i "s:-O2::" configure.ac || die
+ sed -i "s:@datarootdir@/doc/abcmidi:@docdir@:" Makefile.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}
diff --git a/media-sound/gnump3d/Manifest b/media-sound/gnump3d/Manifest
index a8da750969a0..91fb89b907a6 100644
--- a/media-sound/gnump3d/Manifest
+++ b/media-sound/gnump3d/Manifest
@@ -2,4 +2,5 @@ AUX gnump3d.conf.d 159 BLAKE2B d03de16b977c8c892be3dcd6ec7b45414dac9694a777fde57
AUX gnump3d.init.d-r1 826 BLAKE2B 37e9ea5403584881c2a4d87460fa058464eac1a1342af0decec37149f682b4946bb9cf34dc8eff21e6cd83c03aa2a334a8fbe2d9f7c9afd77194897b914dec20 SHA512 c54609e031615cf84328e52ed44d2744391abc580c19df512a62ff8e9091f52eea3741748559fe22f995cedc7d47bb12ea5bd0f5851bf4706327a8fd24d17309
DIST gnump3d-3.0.tar.bz2 633215 BLAKE2B aec3e2e95ebcbf2b9465f8f7e5cf579fe64e9e48d3b1757f78d3102f3a02f92970cbccc5986741013505e1b2f0e54e0d7a7c3871837c6169898e763f23e7fcca SHA512 23778604b557346e42f5cd2045cc394c7d6f7044479c74cd635dfdbbfd6835c8e3ad761d54c5cba239cc5e020b049ac11d64eb463272fc4134b7645226e2524b
EBUILD gnump3d-3.0-r4.ebuild 1889 BLAKE2B 4e6cb3bc6dedcc7a4457a54667b3bbf973b171cb79632d526787d4a0a0a37315c9ae4b86223d4b8f332f1977258ac8dba8f259702135c83f235e8ac1edda1cda SHA512 101c6fa5cc4a54a246df1b37a5ae12e20db1643dd62d20fdc315815567bb65df5271030d3a95e14f8c489a24221f2c318c0648012d583206e8982deeba1c82aa
+EBUILD gnump3d-3.0-r5.ebuild 1915 BLAKE2B e1e72c0c396555a6781aaec31eacdd73690df932e092187d450f8d5fc4288623585b19feedf86c2de6a7029422068dbb3bb12190bdb094d694888cc53f2015c2 SHA512 70cef9caf1d94631851bb6beb6f73f55ea14aba8fa36256bc147625d87384dc2f190a50b8f7fd44c0a2c9c73b185ea6d7f64b42007c930f5849283e005d7ce1a
MISC metadata.xml 250 BLAKE2B 3e6dae5d5f3b3ac412806dd8615a1975c7ea8a64bfd72ad54f2c93a9b24c19c620ac3e8b26e1f6cadec899443e138ee4fb7a82ecb83c784d0c03ee91854d8622 SHA512 2bfce2cf73aefce6dda06ea351cb93b2990b9543f48be1ae5406a5a5acf2c34faed1eb2ce715eb689eb50a9a1add5576b39232eb818c233f5a5589e16032aca8
diff --git a/media-sound/gnump3d/gnump3d-3.0-r5.ebuild b/media-sound/gnump3d/gnump3d-3.0-r5.ebuild
new file mode 100644
index 000000000000..79be656f708f
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-3.0-r5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="https://www.gnu.org/software/gnump3d/"
+SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ || ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="sox"
+
+DEPEND="
+ acct-group/gnump3d
+ acct-user/gnump3d
+"
+
+RDEPEND="
+ ${DEPEND}
+ sox? ( media-sound/sox )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ perl_set_version
+
+ insinto "${VENDOR_LIB}"/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ insinto /usr/share/gnump3d
+ doins -r templates/*
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ sed -e "s,PLUGINDIR,${VENDOR_LIB},g" -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+ sed -e 's,^user *= *\(.*\)$,user = gnump3d,g' -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d-r1 gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ fowners gnump3d:gnump3d /var/log/gnump3d
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ elog ""
+ elog "At the very least, you will need to change the root directory"
+ elog "where music is found. By default, gnump3d will also listen"
+ elog "to any address on port 8888"
+ elog ""
+ elog "You can optionally use sox to downmix the quality of streamed"
+ elog "music in realtime for slow connections."
+}