summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin57390 -> 57386 bytes
-rw-r--r--media-sound/beets/Manifest4
-rw-r--r--media-sound/beets/beets-2.2.0.ebuild174
-rw-r--r--media-sound/beets/beets-9999.ebuild24
4 files changed, 189 insertions, 13 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index 3d334346bc9d..8a43659b0156 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/beets/Manifest b/media-sound/beets/Manifest
index 130e2527d4b6..6c4b955e5363 100644
--- a/media-sound/beets/Manifest
+++ b/media-sound/beets/Manifest
@@ -1,4 +1,6 @@
DIST beets-1.7.0_pre20240501.gh.tar.gz 2247319 BLAKE2B e215c8a2a30a44d298746351be4fa2de1cebb7d6aec2bc7dfc679b133ea5eddefec20d038aa1aa1d734b176c09163b93f917c6c29ea5115c4c2349e090c8c5df SHA512 f397c72b481d7d8822db598ab37c99d0b9063ae45455c0d34116fab7b5a4cc683a3357bdfe436181b1dea46ee05192cc37faf355b5e093d63c2e440e523b92bc
+DIST beets-2.2.0.gh.tar.gz 2414560 BLAKE2B 24c68b27c0d35afb26a39505810ba8ae224173c6f0e36ca551f32cb78250a6b0e777a603c47fd18b6d7e6cdecc5fcaa6b64fe4fd33379de8d6b545dbd49f369f SHA512 ff3a2ea7820129f4b793766ac7dbe3bcfb353563ed3b64ada47db3ba64930caa5841f6cbd20e97e58a4a9eb340bc9e8cd90c7fc188f11420a3cb680ea7a25e48
EBUILD beets-1.7.0_pre20240501.ebuild 6153 BLAKE2B f630dc3ee3ac6b7397e52ba2fdf15b19538d70179ac854cf292832351d192cc8ffd583815b47d2aea170f7b4e337173a9e270dedb45e7ec484fa4382fba4586c SHA512 e74fe44c6fe0ee290b027276e102d6019d04c27a88ed60e1d218a6fd8b8e86ff4e26188b9dab500ac67018becc75e3ff028b803c8737c956eec3d570853bb3f1
-EBUILD beets-9999.ebuild 5941 BLAKE2B 05888d8e0a203043b46e40ade8151f23ba232be8e4904eefbbb44b35ff368ac3950a42b2df95e005deccf5522d4c71c4c70e2e477cfe5e1b442fe8d3bc1146a2 SHA512 d08bd4bb97186b050aa27bc01aa4b05698cda439a703a399a43943ba37b858b315ed3d23bcb612d0fff245a5ac30c55c4aeb867c9a74d55fad8aee9b4f446830
+EBUILD beets-2.2.0.ebuild 5862 BLAKE2B 73beb81dababe79d43a37f0229d9a828218abe50f1d7e736d0f573203a4a374440aa70cba7025bacfad2e130de67806d031f421d3cf7da13176772491e0a64ea SHA512 72ac78b6d2d5953af487bb6998e63ce69681af20a3585d8c1ba2c74b0f420c8d1ac9f7f43ff18897051b000e8753799bf3d5a3a61873c6fb8628f041336c3858
+EBUILD beets-9999.ebuild 5650 BLAKE2B 92642911ecb632e2163906dc2566154614f621a3f20378cf5bfca0b25e5df92f94808433aeb8d590c6338e7d4e9e92c8446b2eff4bdc4ec390f165e2ef4690e8 SHA512 15695f2529b5e68bba02e220eebb8a3e0c36a2b6ac7e68bbd36e2d918c798c0f586821af60f603e1511f4dd91fe5e70330f5c6a4a13b8e4ca5044b4399f5fbc1
MISC metadata.xml 1856 BLAKE2B 0c3482123a1452fbd45e94c83d7eaba9c9548f781f87b7981c3df694eb09e0078f2de68a1e12b5ecd8ee0d69e6eb0f3189472b8c09bee17dfdd5494e9ecd3af7 SHA512 37369b9bb3a5607694bc5b40ba4f59bb33a41d6ac716ccb75f55f93ae35c71187d681a305e4fb6e03f6bf045867b3def2413342cb89784ac4b44a80d36760f73
diff --git a/media-sound/beets/beets-2.2.0.ebuild b/media-sound/beets/beets-2.2.0.ebuild
new file mode 100644
index 000000000000..3978ca21b116
--- /dev/null
+++ b/media-sound/beets/beets-2.2.0.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=poetry
+# Passes tests with python3_13 but dev-python/audioread is problematic
+PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_REQ_USE="sqlite"
+
+# These envvars are used to treat github tarball builds differently
+# from pypi sources. Enable where required
+: ${IS_VCS_SOURCE="no"}
+: ${UPDATE_VERSION="no"}
+
+inherit distutils-r1 bash-completion-r1 multiprocessing optfeature
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/beetbox/beets.git"
+ IS_VCS_SOURCE="yes"
+ UPDATE_VERSION="yes"
+ inherit git-r3
+else
+ # The 2.2.0 pypi tarball does not include zsh completions
+ # https://github.com/beetbox/beets/issues/5531
+ IS_VCS_SOURCE="yes"
+ # The 2.2.0 tarball calls itself 2.1.0 for some reason?
+ UPDATE_VERSION="yes"
+ SRC_URI="https://github.com/beetbox/beets/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Media library management system for obsessive music geeks"
+HOMEPAGE="https://beets.io/ https://pypi.org/project/beets/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/jellyfish-0.7.1[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.33[${PYTHON_USEDEP}]
+ >=dev-python/musicbrainzngs-0.4[${PYTHON_USEDEP}]
+ dev-python/confuse[${PYTHON_USEDEP}]
+ dev-python/mediafile[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/reflink[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ ')"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? (
+ dev-python/sphinx
+ dev-python/pydata-sphinx-theme
+ )
+ $(python_gen_cond_dep '
+ test? (
+ dev-db/sqlite[icu]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bluelet[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/python3-discogs-client[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyacoustid[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pytest-flask[${PYTHON_USEDEP}]
+ dev-python/python-mpd2[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/reflink[${PYTHON_USEDEP}]
+ || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ )
+ dev-python/rarfile[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ media-libs/chromaprint[tools]
+ media-libs/flac
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-good:1.0
+ media-sound/mp3val
+ media-sound/mp3gain
+ media-plugins/gst-plugins-libav:1.0
+ media-video/ffmpeg:0[encode]
+ app-shells/bash-completion
+ )
+ ')"
+
+# Beets uses sphinx to generate manpages; these are not available
+# directly in VCS sources, only pypi tarballs, so handle the dependency
+# here automagically.
+if [[ ${PV} == "9999" ]] || [[ ${IS_VCS_SOURCE} == "yes" ]]; then
+ BDEPEND+="
+ dev-python/sphinx
+ "
+fi
+
+DOCS=( README.rst docs/changelog.rst )
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] || [[ ${UPDATE_VERSION} == "yes" ]]; then
+ sed -i -e "s/^version = \".*\"$/version = \"${PV}\"/" \
+ pyproject.toml \
+ || die "Failed to update version in VCS sources"
+ sed -i -e "s/__version__ = \".*\"/__version__ = \"${PV}\"/" beets/__init__.py
+ fi
+ default
+}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc ; then
+ sphinx-build -b html docs docs/build/html || die
+ fi
+ # If building from VCS sources we need to generate manpages, then copy them to ${S}/man
+ # We could install mans from the sphinx build path, but to be consistent with pypi for src_install
+ # we'll instead generate them and copy to the same install location if building from VCS sources.
+ if [[ ${PV} == "9999" ]] || [[ ${IS_VCS_SOURCE} == "yes" ]]; then
+ einfo "Building man pages"
+ sphinx-build -b man docs docs/build/man || die "Failed to generate man pages"
+ mkdir "${S}/man" || die
+ cp docs/build/man/{beet.1,beetsconfig.5} "${S}/man" || die
+ fi
+}
+
+python_test() {
+ # test/test_art_resize.py can be flaky, parallelisation?
+ epytest -n$(makeopts_jobs) -v
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman man/*
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ einstalldocs
+ # Generate the bash completions; we'll set PYTHONPATH for this invocation so that beets can start.
+ PYTHONPATH="${ED}/usr/lib/${PYTHON}:$PYTHONPATH" ${PYTHON} "${ED}/usr/bin/beet" completion > "${T}/beet.bash" || die
+ newbashcomp "${T}/beet.bash" beet
+ insinto /usr/share/zsh/site-functions
+ newins "${S}/extra/_beet" _beet
+
+ optfeature "badfiles support" "media-libs/flac media-sound/mp3val"
+ optfeature "chromaprint support" "dev-python/pyacoustid media-libs/chromaprint[tools]"
+ optfeature "discogs support" dev-python/python3-discogs-client
+ optfeature "ffmpeg support" media-video/ffmpeg[encode]
+ optfeature "gstreamer support" "media-libs/gst-plugins-bad media-libs/gst-plugins-good"
+ optfeature "icu support" dev-db/sqlite[icu]
+ optfeature "lastfm support" dev-python/pylast
+ optfeature "mpd support" "dev-python/bluelet dev-python/python-mpd2"
+ optfeature "replaygain with gstreamer support" "dev-python/pygobject media-plugins/gst-plugins-libav"
+ optfeature "replaygain without gstreamer support" media-sound/mp3gain
+ optfeature "thumbnail support" dev-python/pyxdg "dev-python/pillow media-gfx/imagemagick"
+ optfeature "webserver support" dev-python/flask
+ optfeature "webserver cors support" dev-python/flask-cors
+ optfeature "Amarok metadata synchronisation" dev-python/dbus-python
+}
diff --git a/media-sound/beets/beets-9999.ebuild b/media-sound/beets/beets-9999.ebuild
index ed8336d62a74..d369086b7ef3 100644
--- a/media-sound/beets/beets-9999.ebuild
+++ b/media-sound/beets/beets-9999.ebuild
@@ -5,7 +5,8 @@ EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
+# Passes tests with python3_13 but dev-python/audioread is problematic
+PYTHON_COMPAT=( python3_{11..12} )
PYTHON_REQ_USE="sqlite"
# These envvars are used to treat github tarball builds differently
@@ -17,6 +18,8 @@ inherit distutils-r1 bash-completion-r1 multiprocessing optfeature
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/beetbox/beets.git"
+ IS_VCS_SOURCE="yes"
+ UPDATE_VERSION="yes"
inherit git-r3
else
inherit pypi
@@ -62,12 +65,14 @@ BDEPEND="
dev-db/sqlite[icu]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/bluelet[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/python3-discogs-client[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pyacoustid[${PYTHON_USEDEP}]
dev-python/pylast[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pytest-flask[${PYTHON_USEDEP}]
dev-python/python-mpd2[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
dev-python/reflink[${PYTHON_USEDEP}]
@@ -105,13 +110,10 @@ EPYTEST_XDIST=1
distutils_enable_tests pytest
src_prepare() {
- # https://github.com/beetbox/beets/commit/8b4983fe7cae9397acd3e23602e419d8dc1041d4
- # merged code coverage into standard test runs; since we disable coverage globally
- # we need to sed out some 'addopts' for coverage in setup.cfg that cause tests to choke.
- #sed -i -e "/--cov=beets/,+9d" setup.cfg || die "Failed to disable code coverage options in setup.cfg"
- # Update the version if we're not building from pypy; it's probably a _pre or live ebuild.
if [[ ${PV} == "9999" ]] || [[ ${UPDATE_VERSION} == "yes" ]]; then
- sed -i -e "s/^version = \".*\"$/version = \"${PV}\"/" pyproject.toml || die "Failed to update version in VCS sources"
+ sed -i -e "s/^version = \".*\"$/version = \"${PV}\"/" \
+ pyproject.toml \
+ || die "Failed to update version in VCS sources"
sed -i -e "s/__version__ = \".*\"/__version__ = \"${PV}\"/" beets/__init__.py
fi
default
@@ -137,11 +139,8 @@ python_compile_all() {
}
python_test() {
- # https://github.com/beetbox/beets/issues/5243 testing bash completions is broken.
- local EPYTEST_DESELECT=(
- test/test_ui.py::CompletionTest::test_completion
- )
- epytest -n$(makeopts_jobs) -v --no-cov
+ # test/test_art_resize.py can be flaky, parallelisation?
+ epytest -n$(makeopts_jobs) -v
}
python_install_all() {
@@ -169,4 +168,5 @@ python_install_all() {
optfeature "thumbnail support" dev-python/pyxdg "dev-python/pillow media-gfx/imagemagick"
optfeature "webserver support" dev-python/flask
optfeature "webserver cors support" dev-python/flask-cors
+ optfeature "Amarok metadata synchronisation" dev-python/dbus-python
}