summaryrefslogtreecommitdiff
path: root/media-video/vlc/vlc-3.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc/vlc-3.0.6.ebuild')
-rw-r--r--media-video/vlc/vlc-3.0.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-video/vlc/vlc-3.0.6.ebuild b/media-video/vlc/vlc-3.0.6.ebuild
index 9743750ed2e1..63a6fda40894 100644
--- a/media-video/vlc/vlc-3.0.6.ebuild
+++ b/media-video/vlc/vlc-3.0.6.ebuild
@@ -296,6 +296,7 @@ src_configure() {
$(use_enable chromecast microdns)
$(use_enable cpu_flags_x86_mmx mmx)
$(use_enable cpu_flags_x86_sse sse)
+ $(use_enable dav1d)
$(use_enable dbus)
$(use_enable dbus kwallet)
$(use_enable dc1394)
@@ -418,10 +419,15 @@ src_configure() {
--disable-spatialaudio
--disable-vsxu
--disable-wasapi
- --disable-x26410b
)
# ^ We don't have these disabled libraries in the Portage tree yet.
+ if use x264 && has_version ">=media-libs/x264-0.0.20190214"; then
+ myeconfargs+=( --enable-x26410b )
+ else
+ myeconfargs+=( --disable-x26410b )
+ fi
+
# Compatibility fix for Samba 4.
use samba && append-cppflags "-I/usr/include/samba-4.0"