summaryrefslogtreecommitdiff
path: root/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arp-scan/arp-scan-1.10.0.ebuild')
-rw-r--r--net-analyzer/arp-scan/arp-scan-1.10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild b/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
new file mode 100644
index 000000000000..7ab46fd66b97
--- /dev/null
+++ b/net-analyzer/arp-scan/arp-scan-1.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="ARP scanning and fingerprinting tool"
+HOMEPAGE="https://github.com/royhills/arp-scan"
+SRC_URI="https://github.com/royhills/arp-scan/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/libcap
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+# Needed for _F_S patch
+BDEPEND="sys-devel/autoconf-archive"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.0-dont-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}