summaryrefslogtreecommitdiff
path: root/net-analyzer/cnet/cnet-3.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cnet/cnet-3.3.1.ebuild')
-rw-r--r--net-analyzer/cnet/cnet-3.3.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/net-analyzer/cnet/cnet-3.3.1.ebuild b/net-analyzer/cnet/cnet-3.3.1.ebuild
deleted file mode 100644
index e5765dba0c8d..000000000000
--- a/net-analyzer/cnet/cnet-3.3.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Network simulation tool"
-HOMEPAGE="https://www.csse.uwa.edu.au/cnet3/"
-SRC_URI="https://dev.gentoo.org/~jer/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-lang/tk-8.5
- dev-libs/elfutils
- x11-libs/libX11
-"
-DEPEND="
- ${RDEPEND}
-"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.3.1-gentoo.patch \
- "${FILESDIR}"/${PN}-3.3.1-tcl.patch
-
- # Set libdir properly
- sed -i -e "/CNETPATH/s:local/lib:$(get_libdir):" src/preferences.h || die
- sed -i -e "/^LIBDIR/s:lib:$(get_libdir):" Makefile || die
-
- epatch_user
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ANNOUNCE
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${P}/examples
- fi
-}