summaryrefslogtreecommitdiff
path: root/net-analyzer/goaccess/goaccess-0.8.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/goaccess/goaccess-0.8.5.ebuild')
-rw-r--r--net-analyzer/goaccess/goaccess-0.8.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/net-analyzer/goaccess/goaccess-0.8.5.ebuild b/net-analyzer/goaccess/goaccess-0.8.5.ebuild
deleted file mode 100644
index 6e14a77788ec..000000000000
--- a/net-analyzer/goaccess/goaccess-0.8.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils
-
-DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
-HOMEPAGE="http://goaccess.io"
-SRC_URI="http://tar.goaccess.io/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-
-IUSE="btree debug geoip bzip2 memhash unicode zlib"
-
-REQUIRED_USE="btree? ( !memhash )"
-
-RDEPEND="
- dev-libs/glib:2
- sys-libs/ncurses:0=[unicode?]
- geoip? ( dev-libs/geoip )
- btree? ( dev-db/tokyocabinet )
- memhash? ( dev-db/tokyocabinet )
- zlib? ( sys-libs/zlib )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- # Fix path to GeoIP bases in config
- sed -e s':/usr/local:/usr:' -i config/goaccess.conf || die
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable geoip) \
- $(use_enable bzip2 bzip) \
- $(use_enable unicode utf8) \
- $(use_enable zlib) \
- $(use memhash && echo "--enable-tcb=memhash") \
- $(use btree && echo "--enable-tcb=btree")
-
- epatch_user
-}