summaryrefslogtreecommitdiff
path: root/net-analyzer/isic
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/isic')
-rw-r--r--net-analyzer/isic/Manifest2
-rw-r--r--net-analyzer/isic/files/isic-0.07-configure.patch39
-rw-r--r--net-analyzer/isic/isic-0.07-r3.ebuild35
3 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/isic/Manifest b/net-analyzer/isic/Manifest
index 13095f09e32a..3e4905615e89 100644
--- a/net-analyzer/isic/Manifest
+++ b/net-analyzer/isic/Manifest
@@ -1,3 +1,5 @@
+AUX isic-0.07-configure.patch 1335 BLAKE2B 207534a2593e93738fe66a4ae219ceeb67f4b2e4544986df526b49a8aeee43e0405d7cadf2231b10752260a454a3ff3321528f237910d65312098525c37e3115 SHA512 2f89330af33796f16fa92f645b4da399e5096ceaaca9423047206f6eca30fa491ce55cfb0c8a3ce24bc1c23b085faf2fec6c8b2aa95c71fc016bab5036d5d320
DIST isic-0.07.tgz 39823 BLAKE2B 1a6a0bdca9b8e3c6acab9879b1165862311c331697db09f2f6facf1bd5b2b2f716bc2b1c8bea69a771553836fc7ead11c826f8cf5c9369f30577afafbae027c8 SHA512 2495ee1c6d552fa6f8f79ab06a886aeef39d247589479e75124a03d5633a75d47e8c9a15e16de3596744a83f74da7afa460cc3dd8653e346e58ac70e04126882
EBUILD isic-0.07-r2.ebuild 758 BLAKE2B 03eba3108190be581c652cf81420eeee7670473d733560e6d8ecfa593392cfb8786fd0f18af444a0b661270037e504e1ef5d6662e869f0af02e01d0233b4a618 SHA512 14b93d2af62738d0a99748a35a06e74db305c62a7178ae15fdff2046725b7d8014d019065e0442b22c1f246992f6c19e268259264952f716a848ef560e576923
+EBUILD isic-0.07-r3.ebuild 629 BLAKE2B c88f5ccc0f9335aad1e2b5f8db22deb431fc051022a42e242b8c3f2871b66bfe44ca1dab857d0018851db01b47344b0c8a07e0912da5800234d24cd13b04c3e2 SHA512 82fe846e36c0656e2c47a01ab358de993f073e516cbf462069d34763e556f637824776338b9f1385e4b5893a174cb67f81edbd55cca39647b69583d166536983
MISC metadata.xml 355 BLAKE2B 3b8f517e5a3552157da3987eed5994e1a0575675f46f20fa2a2e49fec04021cdf555f8046c947984ca8e65b520b9aec770401b39f0d81486f1f7011e34426137 SHA512 868919ca5288f406742333f99c10ef6584e57e4af860b72eb27b16a912be2b18e792eae91e3d172afc78cdf7a9a7720de90bea7f21eb84c29147e7bd6feb83c6
diff --git a/net-analyzer/isic/files/isic-0.07-configure.patch b/net-analyzer/isic/files/isic-0.07-configure.patch
new file mode 100644
index 000000000000..9a080f2a936d
--- /dev/null
+++ b/net-analyzer/isic/files/isic-0.07-configure.patch
@@ -0,0 +1,39 @@
+Make build system respect DESTDIR, fix just the configure
+as a path of least resistance.
+Autoreconf stuffs spaces where they don't belong and produces
+broken configure
+https://bugs.gentoo.org/899938
+https://bugs.gentoo.org/874531
+--- a/configure
++++ b/configure
+@@ -652,7 +652,7 @@
+ #line 653 "configure"
+ #include "confdefs.h"
+
+-main(){return(0);}
++int main(){return(0);}
+ EOF
+ if { (eval echo configure:658: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ac_cv_prog_cc_works=yes
+@@ -1092,6 +1092,7 @@
+ #line 1119 "configure"
+ #include "confdefs.h"
+ #include <ctype.h>
++#include <stdlib.h>
+ #define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ #define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
+ #define XOR(e, f) (((e) && !(f)) || (!(e) && (f)))
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -63,7 +63,7 @@
+ tar -czvf isic-$(VERSION).tgz ./isic-$(VERSION)/* )
+
+ install: $(BINS) $(MAN)
+- $(INSTALL) -m 0755 -d $(PREFIX)/bin
+- $(INSTALL) -m 0755 -c $(BINS) $(PREFIX)/bin
+- $(INSTALL) -m 0755 -d $(PREFIX)/man/man1
+- ${INSTALL} -m 0755 -c $(MAN) $(PREFIX)/man/man1
++ $(INSTALL) -m 0755 -d $(DESTDIR)/$(PREFIX)/bin
++ $(INSTALL) -m 0755 -c $(BINS) $(DESTDIR)/$(PREFIX)/bin
++ $(INSTALL) -m 0755 -d $(DESTDIR)/$(PREFIX)/share/man/man1
++ ${INSTALL} -m 0755 -c $(MAN) $(DESTDIR)/$(PREFIX)/share/man/man1
diff --git a/net-analyzer/isic/isic-0.07-r3.ebuild b/net-analyzer/isic/isic-0.07-r3.ebuild
new file mode 100644
index 000000000000..65fb0951e17a
--- /dev/null
+++ b/net-analyzer/isic/isic-0.07-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="IP Stack Integrity Checker"
+HOMEPAGE="https://isic.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/isic/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-libs/libnet:1.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-configure.patch"
+)
+
+src_prepare() {
+ default
+ # Add two missing includes
+ echo "#include <netinet/udp.h>" >> isic.h || die
+ echo "#include <netinet/tcp.h>" >> isic.h || die
+
+}
+
+src_configure() {
+ tc-export CC
+
+ econf
+}