summaryrefslogtreecommitdiff
path: root/net-analyzer/kapacitor/kapacitor-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/kapacitor/kapacitor-1.5.1.ebuild')
-rw-r--r--net-analyzer/kapacitor/kapacitor-1.5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/kapacitor/kapacitor-1.5.1.ebuild b/net-analyzer/kapacitor/kapacitor-1.5.1.ebuild
new file mode 100644
index 000000000000..dd499480fbdd
--- /dev/null
+++ b/net-analyzer/kapacitor/kapacitor-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/influxdata/kapacitor
+
+inherit golang-build golang-vcs-snapshot systemd user
+
+DESCRIPTION="Monitoring, processing and alerting on time series data"
+HOMEPAGE="https://www.influxdata.com"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+pkg_setup() {
+ enewgroup kapacitor
+ enewuser kapacitor -1 -1 /var/lib/kapacitor kapacitor
+}
+
+src_compile() {
+ pushd "src/${EGO_PN}" > /dev/null || die
+ set -- env GOPATH="${S}" go build -v -work -x ./...
+ echo "$@"
+ "$@" || die "compile failed"
+ popd > /dev/null
+}
+
+src_install() {
+ pushd "src/${EGO_PN}" > /dev/null || die
+ set -- env GOPATH="${S}" go install -v -work -x ./...
+ echo "$@"
+ "$@" || die
+ dobin "${S}"/bin/kapacitor{,d}
+ insinto /etc/kapacitor
+doins etc/kapacitor/kapacitor.conf
+keepdir /etc/kapacitor/load
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/kapacitor
+ systemd_dounit scripts/kapacitor.service
+ keepdir /var/log/kapacitor
+ fowners kapacitor:kapacitor /var/log/kapacitor
+ newconfd "${FILESDIR}"/kapacitor.confd kapacitor
+ newinitd "${FILESDIR}"/kapacitor.rc kapacitor
+ popd > /dev/null || die
+}