summaryrefslogtreecommitdiff
path: root/net-analyzer/notus-scanner
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/notus-scanner')
-rw-r--r--net-analyzer/notus-scanner/Manifest1
-rw-r--r--net-analyzer/notus-scanner/notus-scanner-22.6.3-r2.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-analyzer/notus-scanner/Manifest b/net-analyzer/notus-scanner/Manifest
index 4431f2981958..9f0a22b13359 100644
--- a/net-analyzer/notus-scanner/Manifest
+++ b/net-analyzer/notus-scanner/Manifest
@@ -6,4 +6,5 @@ DIST notus-scanner-22.6.2.tar.gz 316406 BLAKE2B c24ec5e4fd9f8fc181145d64580d04f7
DIST notus-scanner-22.6.3.tar.gz 293997 BLAKE2B 889416d2324088dc11f2df5146b3c88b276d1170552f55b2cb7ef49f4d8d855b98d6c0e53a1d49bd725b97b88c12df69a1997a38a614aa941dd699d0efb1de51 SHA512 fc3a05a3a9d61dd0b7a9913cfbbf507fec9dd3797a42a82283d14ab7fa8090fbc847487cf3a1d064f49572dda9acadba4bd7d30003fd32a179f572e327254546
EBUILD notus-scanner-22.6.2.ebuild 2131 BLAKE2B d754be7534a460285cddf9387039523f998e5342c71ad0db5780a0766d06e89402f36eee19de6d0621f2b1d94ded87086f66b508741f7a8b0b1e3e25d4f96198 SHA512 6be8b83e4a6a8edeb0511b03b387420c171349921ac4a38d260b72e26f51f71e98e99d930d034ae5177f7e0a917a62afe9b67e5b001a649f67f5dd4f84095531
EBUILD notus-scanner-22.6.3-r1.ebuild 2173 BLAKE2B 0fad1f1917dd51e37743a4b1775012f30388682abc34190cd117b482c1c410d7d241fe15e8892b1684882faec90f501141115bfcd5c5a4c4b050391fb49eb270 SHA512 5a428aa49b67720f5359cf5021288dbe1e6bf5ccf3a1496da5d2fec24675a283baaf8d187d98eb82d34706250236155d49cea7317a97000426539a7460dc54e2
+EBUILD notus-scanner-22.6.3-r2.ebuild 2173 BLAKE2B 198ab4d3fb2891847166dd64d37b04c5445ace1b1c8ffe5b579c83cab9463d63b776d4fbb4331965ac17c59833d0e8d3f4712ecff22060744c42a4168f81dbf0 SHA512 826dcb9c9bec6af7d1121b534d813da0b22bec51eaa31a262f4ed6ce0b32d61c8dacf8bcd603fe6be7c19788746593960e2810b42c5f05aaed6cd146be6f29f5
MISC metadata.xml 735 BLAKE2B 78af413540fe6af7214b65b50b50aaf9cf59280037ada5228d38e529d90752b0516bf1d7514e7d9436edd93b50cd8a9dadc1e9fbf84a5c57a0ff0cb45b712cc8 SHA512 fdb4ce92c1eede58fe267ed2a4832dd1d4e7a1694591efb3d2ff372a621320275c4090317cb57c50724ceb7e386fa28965e45b724b311127ecd8665e2908cf92
diff --git a/net-analyzer/notus-scanner/notus-scanner-22.6.3-r2.ebuild b/net-analyzer/notus-scanner/notus-scanner-22.6.3-r2.ebuild
new file mode 100644
index 000000000000..72a3e8e36936
--- /dev/null
+++ b/net-analyzer/notus-scanner/notus-scanner-22.6.3-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 readme.gentoo-r1 systemd
+
+DESCRIPTION="Notus is a vulnerability scanner for creating results from local security checks"
+HOMEPAGE="https://github.com/greenbone/notus-scanner"
+SRC_URI="https://github.com/greenbone/notus-scanner/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3 AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-user/gvm
+ net-libs/paho-mqtt-c
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.5.1[${PYTHON_USEDEP}]
+ <dev-python/packaging-24.2[${PYTHON_USEDEP}]
+ >=dev-python/paho-mqtt-1.5.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-misc/mosquitto
+"
+
+PATCHES=(
+ "${FILESDIR}"/notus-scanner-22.6.2-remove-tests.patch
+)
+
+DOC_CONTENTS="
+For validating the feed content, a GnuPG keychain with the Greenbone Community Feed integrity key needs to be created.
+Please, read here on how to create it:
+https://greenbone.github.io/docs/latest/22.4/source-build/index.html#feed-validation
+https://wiki.gentoo.org/wiki/Greenbone_Vulnerability_Management#Notus_Scanner
+
+To enable feed validation, edit /etc/gvm/${PN}.toml
+and set
+disable-hashsum-verification = false"
+DISABLE_AUTOFORMATTING=true
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ insinto /etc/gvm
+ use prefix || fowners -R gvm:gvm /etc/gvm
+ newins "${FILESDIR}/${PN}.toml" "${PN}.toml"
+ use prefix || fowners gvm:gvm "/etc/gvm/${PN}.toml"
+
+ # Set proper permissions on required files/directories
+ keepdir /var/lib/notus
+ keepdir /var/lib/notus/products
+ keepdir /var/lib/notus/advisories
+ if ! use prefix; then
+ fowners -R gvm:gvm /var/lib/notus
+ fi
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ systemd_dounit config/${PN}.service
+
+ systemd_install_serviced "${FILESDIR}/notus-scanner.service.conf" \
+ ${PN}.service
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}