summaryrefslogtreecommitdiff
path: root/net-analyzer/prelude-correlator/prelude-correlator-4.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/prelude-correlator/prelude-correlator-4.1.1.ebuild')
-rw-r--r--net-analyzer/prelude-correlator/prelude-correlator-4.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/prelude-correlator/prelude-correlator-4.1.1.ebuild b/net-analyzer/prelude-correlator/prelude-correlator-4.1.1.ebuild
new file mode 100644
index 000000000000..1ff9d4c41e25
--- /dev/null
+++ b/net-analyzer/prelude-correlator/prelude-correlator-4.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Real time correlator of events received by Prelude Manager"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/4.1.0/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="~dev-libs/libprelude-4.1.0[python,${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.1.1-fix_python3.patch"
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.run" "${PN}.conf"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+}