summaryrefslogtreecommitdiff
path: root/net-analyzer/slurm/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/slurm/files')
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch48
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-overflow.patch17
-rw-r--r--net-analyzer/slurm/files/slurm-0.3.3-theme.patch16
-rw-r--r--net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch11
-rw-r--r--net-analyzer/slurm/files/slurm-0.4.3-version.patch7
5 files changed, 99 insertions, 0 deletions
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch b/net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch
new file mode 100644
index 000000000000..bd97a10c1e81
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.3.3-gentoo.patch
@@ -0,0 +1,48 @@
+--- a/configure.in
++++ b/configure.in
+@@ -40,31 +40,6 @@
+ fi
+ AC_DEFINE(OSTYPE, ["${OSTYPE}"], [The operating system to build for])
+
+-for cursespath in /usr/include/ncurses.h /usr/local/include/ncurses.h /usr/local/include/ncurses/ncurses.h /opt/include/ncurses.h /opt/include/curses.h /usr/include/curses.h /usr/local/include/curses.h /dev/null
+-do
+- test -f "${cursespath}" && break
+-done
+-case ${cursespath} in
+- /usr/include/*)
+- CFLAGS="$CFLAGS -I/usr/include"
+- LDFLAGS=""
+- ;;
+- /usr/local/include/ncurses/*)
+- CFLAGS="${CFLAGS} -I/usr/local/include/ncurses"
+- LDFLAGS="-L/usr/local/lib"
+- SOLLDFLAGS="-R/usr/local/lib"
+- ;;
+- /usr/local/include/*)
+- CFLAGS="${CFLAGS} -I/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+- SOLLDFLAGS="-R/usr/local/lib"
+- ;;
+- /opt/include/*)
+- CFLAGS="${CFLAGS} -I/opt/include"
+- LDFLAGS="-L/opt/lib"
+- SOLLDFLAGS="-R/opt/lib"
+- ;;
+-esac
+ # add Slowlaris -R and libraries to LDFLAGS
+ if test ${OSTYPE} = "solaris" ; then
+ LDFLAGS="${LDFLAGS} ${SOLLDFLAGS} -lnsl -lsocket -lkstat"
+@@ -74,7 +49,12 @@
+ ncurses_support="no"
+ curses_support="no"
+ color_support="no"
+-AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES -D_HAVE_NCURSES_COLOR"; color_support="yes"; ncurses_support="yes", AC_CHECK_LIB(ncurses, use_default_colors, LDFLAGS="$LDFLAGS -lncurses"; CFLAGS="$CFLAGS -D_HAVE_NCURSES"; ncurses_support="yes"; echo "NO TRANSPARENCY SUPPORT in this ncurses lib", AC_CHECK_LIB(curses, initscr, LDFLAGS="$LDFLAGS -lcurses"; CFLAGS="$CFLAGS -D_HAVE_CURSES"; curses_support="yes"; echo "NO TRANSPARENCY SUPPORT in curses lib")))
++PKG_CHECK_MODULES(ncurses,ncurses,
++ LIBS="$LIBS $ncurses_LIBS"
++ AC_DEFINE(HAVE_NCURSES, 1, [Define if we have ncurses])
++ AC_DEFINE(HAVE_NCURSES_COLOR, 1, [We want color])
++ color_support="yes"; ncurses_support="yes"
++ ,AC_MSG_ERROR([ncurses not found]))
+
+ # disable color support on Solaris for now
+ if test ${OSTYPE} = "solaris" ; then
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch b/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch
new file mode 100644
index 000000000000..f9adc1d9bf71
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.3.3-overflow.patch
@@ -0,0 +1,17 @@
+--- a/src/linux.c
++++ b/src/linux.c
+@@ -68,11 +68,11 @@
+
+ /* do not parse the first two lines as they only contain static garbage */
+ fseek(proc_net_dev, 0, SEEK_SET);
+- fgets(buffer, BUFSIZ-1, proc_net_dev);
+- fgets(buffer, BUFSIZ-1, proc_net_dev);
++ fgets(buffer, BUFSIZE-1, proc_net_dev);
++ fgets(buffer, BUFSIZE-1, proc_net_dev);
+
+ interfacefound = 0;
+- while (fgets(buffer, BUFSIZ-1, proc_net_dev) != NULL)
++ while (fgets(buffer, BUFSIZE-1, proc_net_dev) != NULL)
+ {
+ /* find the device name and substitute ':' with '\0' */
+ ptr = buffer;
diff --git a/net-analyzer/slurm/files/slurm-0.3.3-theme.patch b/net-analyzer/slurm/files/slurm-0.3.3-theme.patch
new file mode 100644
index 000000000000..131554ee57f7
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.3.3-theme.patch
@@ -0,0 +1,16 @@
+--- a/theme.c
++++ b/theme.c
+@@ -70,13 +70,7 @@
+ if ((f = fopen(filename, "r")) == NULL)
+ {
+ bzero(&filename, BUFSIZ);
+-#ifdef __NetBSD__
+- snprintf(filename, BUFSIZ, "/usr/pkg/share/slurm/%s.theme", name);
+-#elif __Debian__
+ snprintf(filename, BUFSIZ, "/usr/share/slurm/%s.theme", name);
+-#else
+- snprintf(filename, BUFSIZ, "/usr/local/share/slurm/%s.theme", name);
+-#endif
+ if ((f = fopen(filename, "r")) == NULL)
+ error(ERR_FATAL, "cannot find theme '%s'", name);
+ }
diff --git a/net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch b/net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch
new file mode 100644
index 000000000000..c1a1233f177b
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,7 +25,7 @@
+
+ add_executable(slurm ${SLURM_SOURCES})
+
+-target_link_libraries(slurm ncurses)
++target_link_libraries(slurm ${CURSES_LIBRARY} ${CURSES_EXTRA_LIBRARY})
+
+ # install
+ install(TARGETS slurm DESTINATION bin)
diff --git a/net-analyzer/slurm/files/slurm-0.4.3-version.patch b/net-analyzer/slurm/files/slurm-0.4.3-version.patch
new file mode 100644
index 000000000000..2266cad19356
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.4.3-version.patch
@@ -0,0 +1,7 @@
+--- a/config.h
++++ b/config.h
+@@ -1,2 +1,2 @@
+-#define PACKAGE_VERSION "0.4.3+git"
+-#define VERSION "0.4.3+git"
++#define PACKAGE_VERSION "0.4.3"
++#define VERSION "0.4.3"