summaryrefslogtreecommitdiff
path: root/net-analyzer/sniffit/sniffit-0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sniffit/sniffit-0.5-r1.ebuild')
-rw-r--r--net-analyzer/sniffit/sniffit-0.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/sniffit/sniffit-0.5-r1.ebuild b/net-analyzer/sniffit/sniffit-0.5-r1.ebuild
new file mode 100644
index 000000000000..1247440f794f
--- /dev/null
+++ b/net-analyzer/sniffit/sniffit-0.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interactive Packet Sniffer"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/sniffit"
+SRC_URI="https://github.com/resurrecting-open-source-projects/sniffit/archive/${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+RDEPEND="
+ net-libs/libpcap
+ >=sys-libs/ncurses-5.2
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-tinfo.patch
+ "${FILESDIR}"/${PN}-0.5.0-implicit-func-decl.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}