summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-3.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wapiti/wapiti-3.0.1.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-3.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/wapiti/wapiti-3.0.1.ebuild b/net-analyzer/wapiti/wapiti-3.0.1.ebuild
new file mode 100644
index 000000000000..0b0c74416a8a
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kerberos ntlm"
+
+DEPEND=""
+RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/tld[${PYTHON_USEDEP}]
+ dev-python/yaswfp[${PYTHON_USEDEP}]
+ kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
+ ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}