summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43734 -> 43734 bytes
-rw-r--r--net-analyzer/nikto/Manifest2
-rw-r--r--net-analyzer/nikto/nikto-2.5.0.ebuild45
3 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index b4aa0b812007..dfa8e559df93 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index c3c7ecc9646b..346342c88b7b 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1,3 +1,5 @@
DIST nikto-2.1.6_p20220602.tar.gz 455528 BLAKE2B 71094c786b274069eb17aac7d367bdc8535c7730afde7c7bf36d40719e2799561eb31ad9cc09ee39c47101880795eee0f1c46ca51c00644cdc23916033cc5f7e SHA512 5c8ce194951c10b8a5f4299e088928022193aa8ae7ed4fb6b9be76bcf03a405d776d6e30274f997ad9eeb95c012c7e09b6dec7cbecbe0ab4049e5d15529ae814
+DIST nikto-2.5.0.tar.gz 435886 BLAKE2B 66e3aaab87f031daeade1a46afce5f02b296a75a542c1f781140fa9e2a2b98c7a0051f0920cd109e35684c14e4137a59ac7f26a10d98dcaf663424ee1f5e10af SHA512 8561c048b2db9b91a53f389097f6f47b06b51d0bbb06d945a26463067a1b2192ae6ad086e8f14e8775827fa8075dabfff66df8c3f79915b7a2d4eaefb09894de
EBUILD nikto-2.1.6_p20220602.ebuild 1132 BLAKE2B 3cd901506be50538e7513e0fa7461dfc7c39f253d070c47a47e8032eda81887129f4ffeff9dafd46a523fb987affc4b8fd2a5d4a478e497a4037beb7f4467c83 SHA512 d740bd3e058f2b4262f0fd611fabce3c88b76aeac0a0834e8e21f17bd5a4e2618095731274e548859745366304f016937c370e880cdb4475a3976154e526848f
+EBUILD nikto-2.5.0.ebuild 1054 BLAKE2B ea86ec984f771220620d48c1b5428a431f26622a0612a73608722b38a36cb7f661700f3e52ec7a19da93f8cf996eb317ec35d9b5c36eecc0af0427e5ae19eff9 SHA512 674f62711c47235616669054c473acada93417a14871874b99589ae11ad28fcea780f01e9d2035c7d87a819762ebc8c5fb4c3553508bce29827bef3a5bce7f25
MISC metadata.xml 475 BLAKE2B 6218a2c00b817c7e2ea1b7e05f8875924ac4f4cd7ef1a0546db1903fc67fe4fcb936735466d8a6d7986b89af3d7c762ccc0585dc179f4cdd01c4fd6e4d23dce1 SHA512 3673e2d8d30dc8327d4ec8c89cfe1acdc12ff691fc4866059b0831f723eb8ebe9ee6c633bb5a7b95775cfdedaa57b5472b730a2f0461b535f538f25e44bb6347
diff --git a/net-analyzer/nikto/nikto-2.5.0.ebuild b/net-analyzer/nikto/nikto-2.5.0.ebuild
new file mode 100644
index 000000000000..e7bb2ea3e968
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+SRC_URI="https://github.com/sullo/nikto/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ doman docs/nikto.1
+ dodoc docs/nikto.dtd
+ dodoc docs/nikto_schema.sql
+}