summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43577 -> 43582 bytes
-rw-r--r--net-analyzer/iplog/Manifest2
-rw-r--r--net-analyzer/iplog/files/iplog-2.2.3-C23.patch26
3 files changed, 17 insertions, 11 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index 7ae21a6a0ba0..db57e22d3cde 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/iplog/Manifest b/net-analyzer/iplog/Manifest
index 7da11bfa7f9a..98d0199165bf 100644
--- a/net-analyzer/iplog/Manifest
+++ b/net-analyzer/iplog/Manifest
@@ -1,5 +1,5 @@
AUX 2.2.3-DLT_LINUX_SSL.patch 7265 BLAKE2B a20edebe47d65d066b1b3e214d8365b4a5811a7be4f600028edc11fc4c17e48f8396c34335a855299da17534a52dc89c916c890ae50a147620988b5f3c6ca8d9 SHA512 de93d97688e1079e480c138abc1a25572c47f2e045f70c98b7ba2c2098bcfffdb36997aab0a4272cbe908bead503b2531543368ac35624527cb8c0640594ad4b
-AUX iplog-2.2.3-C23.patch 915 BLAKE2B c6fbfedccfeee2c3e6f74094bc8fb22a65667ebd1d6950f210d4830347ff56a831f0433e34bf432acbed2f5bc721e4732325e683086808e1f36133b254ec6b06 SHA512 9871b83e0a392538040870714413e68dd0b443c28f14b67c576ddeb138a825001d1756f72de421147798a781266e335ae687b1ba08535386a71f1c2426d2ae0f
+AUX iplog-2.2.3-C23.patch 1167 BLAKE2B 516e24358e935b1046930e58b858e160ed37ecc2bb3ecd2b53fa3af8817814fdbe667b0d018a06b3bc0dab9cbb2fd36c507223a24814e4e2469a49744a018d22 SHA512 e5b524b572cbca43b6850e38d4b0b60a90b548b16b4787df0365b670d84c057459af89a006ebd2075e600bf6f0ba385b0ccba7ca3eaac407032e26446abb7f3a
AUX iplog.rc6 776 BLAKE2B fba34208b2d16ba508cc9c3592e21eb7f0a479a89bf4617320bd9627047024f0cadde7fef55304baf25f7ccc56836e899b71801141b1802facc8b885b9b121ad SHA512 f0c3965810f7005e1ae183a2f3ed66ba06c054fcfd78da6277eaa364518ebffb9f44a0c99200b0d3042a63d4c57141d5b29823e8bc1d3f030e00d8e913021a34
DIST iplog-2.2.3.tar.gz 133639 BLAKE2B f8108259f3f9b662297785988c40711d9d4ce6381377ed9a797f441c84fd1dcd9f0c3832e07ed9a660ddcc41bc52777136204274de873b72bce151327738ec2d SHA512 d7669e39b728af366b5199c58d396c6907496b4895ffb1ba0cba54fae0646f9792170f932de1eae9634b5ac356644a5d6d0ccaf7bc77a62641695992245c9aed
EBUILD iplog-2.2.3-r3.ebuild 711 BLAKE2B 928594fb1952974eb3b843dcc83665e6fd36ac816956d1099dc89c453b85845f2291774577697be74b3583db983e27b7449360a09b6458d7deec43e1792a7612 SHA512 58bb5e3672c96b44d27ac2295702e311a311d096df0d2efee75c9cedd23b777d7dbc8916158c383569ece11004bcacc3211a55036f28df478392e3cad937f811
diff --git a/net-analyzer/iplog/files/iplog-2.2.3-C23.patch b/net-analyzer/iplog/files/iplog-2.2.3-C23.patch
index b905f0be4d9a..8552f4de932a 100644
--- a/net-analyzer/iplog/files/iplog-2.2.3-C23.patch
+++ b/net-analyzer/iplog/files/iplog-2.2.3-C23.patch
@@ -2,11 +2,10 @@ https://bugs.gentoo.org/945194 - guard bool for modern compilers
https://bugs.gentoo.org/712644 - type aliaces for musl
--- a/src/iplog.h
+++ b/src/iplog.h
-@@ -21,6 +21,9 @@
+@@ -21,6 +21,8 @@
#ifndef __IPLOG_H
#define __IPLOG_H
-+#define _GNU_SOURCE 1
+#include <sys/types.h> /* for u_* types */
+
#ifndef HAVE_IPADDR_T
@@ -22,15 +21,22 @@ https://bugs.gentoo.org/712644 - type aliaces for musl
#ifdef HAVE_PATHS_H
# include <paths.h>
-C23 and GNU-15 compatibility, explicitly cast sockaddr
---- a/src/iplog_tcp.c
-+++ b/src/iplog_tcp.c
-@@ -144,7 +144,7 @@
+Explicitly cast sockaddr_in to sockaddr, always correct thing to do in this situation.
+--- a/src/iplog_tcp.c 2025-02-16 22:16:15.486203469 +0400
++++ b/src/iplog_tcp.c 2025-02-16 22:16:58.045309444 +0400
+@@ -142,14 +142,11 @@
+ fn_sin.sin_port = tcp->th_sport;
+ fn_sin.sin_addr.s_addr = ip->ip_src.s_addr;
ret = sendto(raw_sock, (char *) xip,
sizeof(struct ip) + sizeof(struct tcphdr), 0,
-#if !defined(__GLIBC__) || (__GLIBC__ < 2)
-+#if !defined(__GLIBC__) || (__GLIBC__ < 2) || (__STDC_VERSION__ > 201710L)
- (struct sockaddr *)
- #endif
- &fn_sin,
+- (struct sockaddr *)
+-#endif
+- &fn_sin,
++ (struct sockaddr *)&fn_sin,
+ sizeof(struct sockaddr_in));
+
+ if (ret == -1)
+ IDEBUG(("[%s:%d] sendto: %s", __FILE__, __LINE__, strerror(errno)));
+