summaryrefslogtreecommitdiff
path: root/net-dialup/mingetty/mingetty-1.08-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/mingetty/mingetty-1.08-r3.ebuild')
-rw-r--r--net-dialup/mingetty/mingetty-1.08-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-dialup/mingetty/mingetty-1.08-r3.ebuild b/net-dialup/mingetty/mingetty-1.08-r3.ebuild
new file mode 100644
index 000000000000..74f1b8f75842
--- /dev/null
+++ b/net-dialup/mingetty/mingetty-1.08-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A compact getty program for virtual consoles only"
+HOMEPAGE="https://sourceforge.net/projects/mingetty"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="unicode"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.08-check_chroot_chdir_nice.patch"
+)
+
+src_prepare() {
+ use unicode && eapply "${FILESDIR}"/${PN}-1.08-utf8.patch
+ default
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -W -pipe -D_GNU_SOURCE" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man8
+ emake DESTDIR="${D}" install
+}