summaryrefslogtreecommitdiff
path: root/net-dns/fpdns/fpdns-20190131.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/fpdns/fpdns-20190131.ebuild')
-rw-r--r--net-dns/fpdns/fpdns-20190131.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-dns/fpdns/fpdns-20190131.ebuild b/net-dns/fpdns/fpdns-20190131.ebuild
new file mode 100644
index 000000000000..b556dd7766a9
--- /dev/null
+++ b/net-dns/fpdns/fpdns-20190131.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Fingerprinting DNS servers"
+HOMEPAGE="https://github.com/kirei/fpdns/"
+SRC_URI="https://github.com/kirei/fpdns/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-perl/Net-DNS-0.74"
+
+src_install() {
+ dobin apps/fpdns
+ insinto "${VENDOR_LIB}"/Net/DNS/
+ doins lib/Net/DNS/Fingerprint.pm
+}