summaryrefslogtreecommitdiff
path: root/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/mydns/mydns-1.2.8.31-r2.ebuild')
-rw-r--r--net-dns/mydns/mydns-1.2.8.31-r2.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/net-dns/mydns/mydns-1.2.8.31-r2.ebuild b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
index febcd54ce5da..e81a5dfecaf3 100644
--- a/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
+++ b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
-DESCRIPTION="A DNS-Server which gets its data from a MySQL-/PostgreSQL-database"
+DESCRIPTION="A DNS-Server which gets its data from a MySQL/PostgreSQL-database"
HOMEPAGE="http://www.mydns.pl/"
SRC_URI="mirror://sourceforge/mydns-ng/${P}.tar.gz"
@@ -14,20 +14,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc x86"
IUSE="alias debug nls mysql postgres ssl static status"
-RDEPEND="mysql? ( dev-db/mysql-connector-c:= )
+BDEPEND="sys-devel/bison"
+RDEPEND="
+ virtual/libiconv
+ mysql? ( dev-db/mysql-connector-c:= )
nls? ( virtual/libintl )
postgres? ( dev-db/postgresql )
ssl? ( dev-libs/openssl:0= )
- virtual/libiconv"
-DEPEND="${RDEPEND}
+"
+DEPEND="
+ ${RDEPEND}
nls? ( >=sys-devel/gettext-0.12 )
- sys-devel/bison"
+"
REQUIRED_USE="^^ ( mysql postgres )"
PATCHES=(
"${FILESDIR}/${PN}-1.2.8.27-m4.patch"
"${FILESDIR}/${P}-texinfo.patch"
+ "${FILESDIR}/${PN}-1.2.8.31-ssl-libdir.patch"
+ "${FILESDIR}/${PN}-1.2.8.31-misc-libdir.patch"
)
src_prepare() {
@@ -36,6 +42,9 @@ src_prepare() {
}
src_configure() {
+ # bug #775134
+ append-flags -fcommon
+
econf \
$(use_enable alias) \
$(use_enable nls) \