summaryrefslogtreecommitdiff
path: root/net-firewall/nftables/nftables-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/nftables/nftables-9999.ebuild')
-rw-r--r--net-firewall/nftables/nftables-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-firewall/nftables/nftables-9999.ebuild b/net-firewall/nftables/nftables-9999.ebuild
index a0795444e9b8..60c4f92e0ca9 100644
--- a/net-firewall/nftables/nftables-9999.ebuild
+++ b/net-firewall/nftables/nftables-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/netfilter.org.asc
inherit edo linux-info distutils-r1 systemd verify-sig
@@ -33,7 +33,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=net-libs/libmnl-1.0.4:=
- >=net-libs/libnftnl-1.2.6:=
+ >=net-libs/libnftnl-1.2.7:=
gmp? ( dev-libs/gmp:= )
json? ( dev-libs/jansson:= )
python? ( ${PYTHON_DEPS} )
@@ -177,7 +177,9 @@ pkg_preinst() {
# will not always be printed in a way that constitutes a valid
# syntax for ntf(8). Ignore them.
return
- elif set -- "${ED}"/usr/lib*/libnftables.so; ! LD_LIBRARY_PATH=${1%/*} "${ED}"/sbin/nft -c -f -- "${T}"/ruleset.nft; then
+ elif set -- "${ED}"/usr/lib*/libnftables.so;
+ ! LD_LIBRARY_PATH=${1%/*} "${ED}"/sbin/nft -c -f -- "${T}"/ruleset.nft
+ then
eerror "Your currently loaded ruleset cannot be parsed by the newly built instance of"
eerror "nft. This probably means that there is a regression introduced by v${PV}."
eerror "(To make the ebuild fail instead of warning, set NFTABLES_ABORT_ON_RELOAD_FAILURE=1.)"